summaryrefslogtreecommitdiffstats
path: root/recipes/gnome/gnome-keyring_2.28.0.bb
diff options
context:
space:
mode:
authorSteve Sakoman <steve@sakoman.com>2009-10-13 20:03:51 -0700
committerKoen Kooi <koen@openembedded.org>2009-10-13 22:43:54 +0200
commitb20cb3a42c1b5a4bdd00e332ae6d525f8e9a5b61 (patch)
tree442e093e09e8cd75d7e4e07de4f95a75270ccfc7 /recipes/gnome/gnome-keyring_2.28.0.bb
parent16a7d3d53eed671e5e51809cdd68cc1b5c6354bd (diff)
downloadopenembedded-b20cb3a42c1b5a4bdd00e332ae6d525f8e9a5b61.tar.gz
gnome-keyring: add 2.28.0
Diffstat (limited to 'recipes/gnome/gnome-keyring_2.28.0.bb')
-rw-r--r--recipes/gnome/gnome-keyring_2.28.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/gnome/gnome-keyring_2.28.0.bb b/recipes/gnome/gnome-keyring_2.28.0.bb
new file mode 100644
index 0000000000..46d2de0fd0
--- /dev/null
+++ b/recipes/gnome/gnome-keyring_2.28.0.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "GNOME security credential management"
+LICENSE = "GPL"
+SECTION = "x11/gnome"
+DEPENDS = " libpam gconf gtk+ libtasn1 libtasn1-native libgcrypt"
+
+inherit autotools gnome pkgconfig
+
+EXTRA_OECONF = "--disable-gtk-doc --enable-pam --with-pam-dir=${libdir}/security/"
+
+SRC_URI += "file://tasn.m4 file://org.gnome.keyring.service"
+
+do_configure_prepend() {
+ cp ${WORKDIR}/tasn.m4 acinclude.m4
+}
+
+do_install_append () {
+ install -d ${D}${datadir}/dbus-1/services
+ install -m 0644 ${WORKDIR}/org.gnome.keyring.service ${D}${datadir}/dbus-1/services
+}
+
+FILES_${PN} += "${datadir}/dbus-1/services ${datadir}/gcr"
+PACKAGES =+ "gnome-keyring-pam-plugin"
+FILES_gnome-keyring-pam-plugin = "${libdir}/security/*.so"
+FILES_${PN}-dbg += "${libdir}/gnome-keyring/*/.debug ${libdir}/security/.debug"
+
+do_stage() {
+ autotools_stage_all
+}