aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome/gnome-keyring_2.28.2.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-01-19 14:59:25 +0100
committerKoen Kooi <koen@openembedded.org>2010-01-20 10:04:39 +0100
commitdfc707b84076939eb91c776c3d2d684588f0bada (patch)
tree86059afb8d70fb3551d2e6f28b5dfed50eb4b186 /recipes/gnome/gnome-keyring_2.28.2.bb
parent680760be3ab2431586f52c55f4311502cab1c50d (diff)
downloadopenembedded-dfc707b84076939eb91c776c3d2d684588f0bada.tar.gz
gnome-keyring 2.28: update to 2.28.2
Diffstat (limited to 'recipes/gnome/gnome-keyring_2.28.2.bb')
-rw-r--r--recipes/gnome/gnome-keyring_2.28.2.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/gnome/gnome-keyring_2.28.2.bb b/recipes/gnome/gnome-keyring_2.28.2.bb
new file mode 100644
index 0000000000..70a7349a3b
--- /dev/null
+++ b/recipes/gnome/gnome-keyring_2.28.2.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "GNOME security credential management"
+LICENSE = "GPL"
+SECTION = "x11/gnome"
+DEPENDS = " libpam gconf gtk+ libtasn1 libtasn1-native libgcrypt"
+
+inherit gnome pkgconfig
+
+EXTRA_OECONF = "--disable-gtk-doc --enable-pam --with-pam-dir=${libdir}/security/"
+
+SRC_URI += "file://tasn.m4 file://org.gnome.keyring.service"
+
+do_configure_prepend() {
+ cp ${WORKDIR}/tasn.m4 acinclude.m4
+}
+
+do_install_append () {
+ install -d ${D}${datadir}/dbus-1/services
+ install -m 0644 ${WORKDIR}/org.gnome.keyring.service ${D}${datadir}/dbus-1/services
+}
+
+FILES_${PN} += "${datadir}/dbus-1/services ${datadir}/gcr"
+PACKAGES =+ "gnome-keyring-pam-plugin"
+FILES_gnome-keyring-pam-plugin = "${libdir}/security/*.so"
+FILES_${PN}-dbg += "${libdir}/gnome-keyring/*/.debug ${libdir}/security/.debug"
+