aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome/gnome-python_2.26.1.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-10-28 09:59:02 +0100
committerKoen Kooi <koen@openembedded.org>2009-10-28 09:59:02 +0100
commitb4c532efcabe6dbd5ff13ae5746eb56e6594e5ba (patch)
tree7fcf7676f7862f06707e59fbfa0515633be4eb6d /recipes/gnome/gnome-python_2.26.1.bb
parent1a4bd59fdadcbada295b10ff9ecc6d1b5f155ab7 (diff)
downloadopenembedded-b4c532efcabe6dbd5ff13ae5746eb56e6594e5ba.tar.gz
gnome-python: fix 2.26.1 build, add 2.28.0
python-pygobject*: add 2.20.0
Diffstat (limited to 'recipes/gnome/gnome-python_2.26.1.bb')
-rw-r--r--recipes/gnome/gnome-python_2.26.1.bb15
1 files changed, 10 insertions, 5 deletions
diff --git a/recipes/gnome/gnome-python_2.26.1.bb b/recipes/gnome/gnome-python_2.26.1.bb
index 1027437b7a..54523f898f 100644
--- a/recipes/gnome/gnome-python_2.26.1.bb
+++ b/recipes/gnome/gnome-python_2.26.1.bb
@@ -3,13 +3,18 @@ LICENSE = "LGPL"
DEPENDS = "libgnomeui pyorbit python-pygtk"
RDEPENDS = "pyorbit"
+PR = "r1"
+
inherit gnome distutils-base pkgconfig
-do_configure() {
- sed -i -e s:'`$PKG_CONFIG --variable=defsdir pygtk-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/defs\":g ${S}/configure.ac
- export HOST_SYS=${HOST_SYS}
- export BUILD_SYS=${BUILD_SYS}
- autotools_do_configure
+
+do_configure_prepend() {
+ export HOST_SYS=${HOST_SYS}
+ export BUILD_SYS=${BUILD_SYS}
+ sed -i -e s:'`$PKG_CONFIG --variable=defsdir pygtk-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/defs\":g \
+ -e s:'`$PKG_CONFIG --variable=defsdir gnome-python-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/defs\":g \
+ -e s:'`$PKG_CONFIG --variable=argtypesdir gnome-python-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/argtypes/\":g \
+ ${S}/configure.ac
}
do_stage() {