aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome/gnome-python_2.28.0.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-10-28 09:59:02 +0100
committerKoen Kooi <koen@openembedded.org>2009-10-28 09:59:02 +0100
commitb4c532efcabe6dbd5ff13ae5746eb56e6594e5ba (patch)
tree7fcf7676f7862f06707e59fbfa0515633be4eb6d /recipes/gnome/gnome-python_2.28.0.bb
parent1a4bd59fdadcbada295b10ff9ecc6d1b5f155ab7 (diff)
downloadopenembedded-b4c532efcabe6dbd5ff13ae5746eb56e6594e5ba.tar.gz
gnome-python: fix 2.26.1 build, add 2.28.0
python-pygobject*: add 2.20.0
Diffstat (limited to 'recipes/gnome/gnome-python_2.28.0.bb')
-rw-r--r--recipes/gnome/gnome-python_2.28.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/gnome/gnome-python_2.28.0.bb b/recipes/gnome/gnome-python_2.28.0.bb
new file mode 100644
index 0000000000..54523f898f
--- /dev/null
+++ b/recipes/gnome/gnome-python_2.28.0.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "GNOME Python miscellaneous bindings"
+LICENSE = "LGPL"
+DEPENDS = "libgnomeui pyorbit python-pygtk"
+RDEPENDS = "pyorbit"
+
+PR = "r1"
+
+inherit gnome distutils-base pkgconfig
+
+
+do_configure_prepend() {
+ export HOST_SYS=${HOST_SYS}
+ export BUILD_SYS=${BUILD_SYS}
+ sed -i -e s:'`$PKG_CONFIG --variable=defsdir pygtk-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/defs\":g \
+ -e s:'`$PKG_CONFIG --variable=defsdir gnome-python-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/defs\":g \
+ -e s:'`$PKG_CONFIG --variable=argtypesdir gnome-python-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/argtypes/\":g \
+ ${S}/configure.ac
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} += "${datadir}"
+FILES_${PN}-dbg += "${libdir}/gnome-vfs-2.0/modules/.debug"
+
+