aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome/libgweather_2.26.2.1.bb
diff options
context:
space:
mode:
authorSteve Sakoman <steve@sakoman.com>2009-08-13 22:35:00 -0700
committerKoen Kooi <koen@openembedded.org>2009-08-14 09:50:07 +0200
commit9671737de1a5ba1cb362ba611f354ebab71d675a (patch)
tree6d7bb512571c6bb2c7e8221879cf3ac4e7e572e7 /recipes/gnome/libgweather_2.26.2.1.bb
parentc5d2c1b6b2bb55fea74f30de3d29681049b4967f (diff)
downloadopenembedded-9671737de1a5ba1cb362ba611f354ebab71d675a.tar.gz
libgweather: add 2.26.2.1
Diffstat (limited to 'recipes/gnome/libgweather_2.26.2.1.bb')
-rw-r--r--recipes/gnome/libgweather_2.26.2.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/gnome/libgweather_2.26.2.1.bb b/recipes/gnome/libgweather_2.26.2.1.bb
new file mode 100644
index 0000000000..d6aead7d0b
--- /dev/null
+++ b/recipes/gnome/libgweather_2.26.2.1.bb
@@ -0,0 +1,26 @@
+LICENSE = "LGPL"
+DEPENDS = "libgnome libsoup-2.4 gtk+"
+
+inherit gnome
+
+EXTRA_OEMAKE = "ORBIT_IDL=${STAGING_BINDIR_NATIVE}/orbit-idl-2"
+
+do_configure_prepend() {
+ sed -i -e 's:help::' ${S}/Makefile.am
+ sed -i -e 's: doc : :g' ${S}/Makefile.am
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} += "${datadir}/gnome* \
+ ${datadir}/icons"
+
+PACKAGES += "${PN}-locationdata"
+FILES_${PN}-locationdata = "${datadir}/libgweather/Locations*"
+
+PACKAGES += "libpanel-applet"
+FILES_libpanel-applet = "${libdir}/libpanel-applet-2.so.*"
+
+