aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome/metacity_2.30.3.bb
diff options
context:
space:
mode:
authorMichael Smith <msmith@cbnco.com>2010-11-08 15:57:06 -0500
committerMichael Smith <msmith@cbnco.com>2010-11-09 17:57:43 -0500
commit91eb9425d1ba165f43c9dee7b035b86d180a8dd9 (patch)
treefa87aa1cd1478a910d60ef0deafbf5dce2245ea9 /recipes/gnome/metacity_2.30.3.bb
parent30c2729b7ee6b75b47fcf7895fd856d266ad2025 (diff)
downloadopenembedded-91eb9425d1ba165f43c9dee7b035b86d180a8dd9.tar.gz
metacity: upgrade to 2.30.3 from 2.30.0
Signed-off-by: Michael Smith <msmith@cbnco.com>
Diffstat (limited to 'recipes/gnome/metacity_2.30.3.bb')
-rw-r--r--recipes/gnome/metacity_2.30.3.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/gnome/metacity_2.30.3.bb b/recipes/gnome/metacity_2.30.3.bb
new file mode 100644
index 0000000000..24abecf689
--- /dev/null
+++ b/recipes/gnome/metacity_2.30.3.bb
@@ -0,0 +1,29 @@
+SECTION = "x11/wm"
+DESCRIPTION = "Metacity is the boring window manager for the adult in you."
+LICENSE = "GPL"
+DEPENDS = "libcanberra libwnck startup-notification gtk+ gconf gdk-pixbuf-csource-native gnome-doc-utils"
+
+inherit gnome update-alternatives
+
+SRC_URI += "file://crosscompile.patch "
+
+SRC_URI[archive.md5sum] = "553784f376d96b902e19ff437cd5b339"
+SRC_URI[archive.sha256sum] = "08f887018fa5e447cf184d03bae3fe2c05fdb7583bed6768e3b4d66392fc18dd"
+
+EXTRA_OECONF += "--disable-verbose \
+ --disable-xinerama \
+"
+
+do_configure_prepend() {
+ sed -i -e 's:$ZENITY:$NOZENITY:g' -e 's:-Werror::g' ${S}/configure.in
+}
+
+EXTRA_OEMAKE = ' STAGING_INCDIR_NATIVE="${STAGING_INCDIR_NATIVE}" STAGING_LIBDIR_NATIVE="${STAGING_LIBDIR_NATIVE}"'
+
+ALTERNATIVE_NAME = "x-window-manager"
+ALTERNATIVE_LINK = "${bindir}/x-window-manager"
+ALTERNATIVE_PATH = "${bindir}/metacity"
+ALTERNATIVE_PRIORITY = "30"
+
+RDEPENDS_${PN} = "zenity"
+FILES_${PN} += "${datadir}/themes ${datadir}/gnome*"