aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome/system-tools-backends_2.8.3.bb
diff options
context:
space:
mode:
authorDavid-John Willis <John.Willis@Distant-earth.com>2010-01-17 17:33:39 +0000
committerKoen Kooi <koen@openembedded.org>2010-02-17 09:43:46 +0100
commita9904949e3d06d7c389a3e330b3442be4ef504ea (patch)
tree8b51d96de0ac18675f95ae10268a2d82b3c3df78 /recipes/gnome/system-tools-backends_2.8.3.bb
parent74501117c261f743c76ae3c2988cbcfdc141cf3a (diff)
downloadopenembedded-a9904949e3d06d7c389a3e330b3442be4ef504ea.tar.gz
system-tools-backends: Add 2.8.3 and checksum and remove DEFAULT_PREFERENCE = "-1" from 2.8.1 as I can find no good reason for it to be set.
* Update Angstrom distro patch for 2.8.3 and make it only apply if Angstrom distro is set.
Diffstat (limited to 'recipes/gnome/system-tools-backends_2.8.3.bb')
-rw-r--r--recipes/gnome/system-tools-backends_2.8.3.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes/gnome/system-tools-backends_2.8.3.bb b/recipes/gnome/system-tools-backends_2.8.3.bb
new file mode 100644
index 0000000000..117882395e
--- /dev/null
+++ b/recipes/gnome/system-tools-backends_2.8.3.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "gnome system tools backends"
+LICENSE = "GPL"
+
+DEPENDS = "dbus dbus-glib glib-2.0 policykit"
+
+# Shadow added so there is a full adduser/deluser
+# (Gnome images tend to pull in shadow anyway)
+RDEPENDS = "shadow"
+
+inherit gnome pkgconfig update-rc.d
+
+SRC_URI += " \
+ file://system-tools-backends \
+ "
+
+SRC_URI_append_angstrom = " \
+ file://add-angstrom-distro.patch;patch=1 \
+ "
+
+do_configure_prepend() {
+ sed -i -e /IT_PROG_INTLTOOL/d ${S}/configure.in
+ sed -i -e /Makefile.in/d ${S}/configure.in
+ sed -i -e 's: po : :g' ${S}/Makefile.am
+ sed -i -e /policy/d ${S}/Makefile.am
+ sed -i -e 's:org.freedesktop.SystemToolsBackends.service \\:org.freedesktop.SystemToolsBackends.service:g' ${S}/Makefile.am
+ sed -i -e 's:@INTLTOOL_POLICY_RULE@::g' ${S}/Makefile.am
+ sed -i -e 's:CC=$(CC):CC="$(CC)":g' ${S}/Net-DBus/Makefile.am
+}
+
+do_install_append () {
+ install -d ${D}/${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/system-tools-backends ${D}/${sysconfdir}/init.d/
+}
+
+INITSCRIPT_NAME = "system-tools-backends"
+INITSCRIPT_PARAMS = "start 50 2 3 4 5 . stop 70 1 ."
+
+FILES_${PN} += " ${sysconfdir}/dbus-1/system.d"
+FILES_${PN} += " ${libdir}/pkgconfig"
+FILES_${PN} += " ${datadir}/dbus-1/system-services"
+FILES_${PN} += " ${datadir}/system-tools-backends-2.0/files"
+FILES_${PN} += " ${datadir}/system-tools-backends-2.0/scripts"