aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-04-08 12:51:51 +0200
committerKoen Kooi <koen@openembedded.org>2010-04-08 12:51:51 +0200
commit55693a05e9e52261aadd851730533a3e0f5ccf87 (patch)
tree5e1cc7d2badf343ef764070ed74c5afe00fe29aa /recipes/gnome
parent03fdb2997c8ec63710be7e047544e69f38f75a06 (diff)
downloadopenembedded-55693a05e9e52261aadd851730533a3e0f5ccf87.tar.gz
gnome-power-manager: add 2.30.0
Diffstat (limited to 'recipes/gnome')
-rw-r--r--recipes/gnome/gnome-power-manager_2.30.0.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/recipes/gnome/gnome-power-manager_2.30.0.bb b/recipes/gnome/gnome-power-manager_2.30.0.bb
new file mode 100644
index 0000000000..a7528520c8
--- /dev/null
+++ b/recipes/gnome/gnome-power-manager_2.30.0.bb
@@ -0,0 +1,45 @@
+LICENSE = "GPLv2"
+DEPENDS = "devicekit-power gtk+ gnome-keyring libgnome libgnomeui hal dbus libglade \
+ libnotify libwnck cairo libunique gnome-panel gstreamer \
+ xrandr policykit-gnome gnome-doc-utils dbus-glib "
+
+inherit gnome
+
+SRC_URI[archive.md5sum] = "2f47606d16d54915dc49a06364d208da"
+SRC_URI[archive.sha256sum] = "8fc2c772f1c0d89b200e405d02656e69a71362771175fbcb6b6db426410db647"
+
+EXTRA_OECONF = " --disable-scrollkeeper \
+ --disable-keyring \
+ --x-includes=${STAGING_INCDIR} \
+ --x-libraries=${STAGING_LIBDIR} \
+ --with-dpms-ext=${STAGING_INCDIR}/.. \
+ --enable-compile-warnings=no \
+ ac_cv_header_X11_extensions_dpms_h=yes \
+ "
+
+do_configure_prepend() {
+ sed -i -e 's: man ::g' ${S}/Makefile.am
+}
+
+do_configure_append() {
+ rm config.log
+ # Sigh... --enable-compile-warnings=no doesn't actually turn off -Werror
+ for i in $(find ${S} -name "Makefile") ; do
+ sed -i -e s:-Werror::g $i
+ done
+}
+
+PACKAGES =+ "${PN}-applets"
+
+FILES_${PN}-applets = "${bindir}/*applet* \
+ ${libdir}/bonobo/servers \
+ ${datadir}/gnome-2.0/ui"
+
+FILES_${PN} += "${datadir}/icons \
+ ${datadir}/dbus-1 \
+ ${datadir}/gnome/autostart \
+ "
+
+FILES_${PN}-doc += "${datadir}/omf \
+ ${datadir}/gnome/help "
+