aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-04-01 14:38:48 +0200
committerKoen Kooi <koen@openembedded.org>2010-04-01 19:59:09 +0200
commit980c3230ebfd9f1e7a28dc4b5758cddd5a19c33f (patch)
treec17288a369df851256dbd14ced661da487d91478 /recipes/gnome
parent5a491e2f1fe84231c66f5871f5e3e8e6f6fa8063 (diff)
downloadopenembedded-980c3230ebfd9f1e7a28dc4b5758cddd5a19c33f.tar.gz
system-tools-backends: add 2.10.0
Diffstat (limited to 'recipes/gnome')
-rw-r--r--recipes/gnome/system-tools-backends-2.10.0/add-angstrom-distro.patch28
-rw-r--r--recipes/gnome/system-tools-backends-2.10.0/system-tools-backends74
-rw-r--r--recipes/gnome/system-tools-backends_2.10.0.bb45
3 files changed, 147 insertions, 0 deletions
diff --git a/recipes/gnome/system-tools-backends-2.10.0/add-angstrom-distro.patch b/recipes/gnome/system-tools-backends-2.10.0/add-angstrom-distro.patch
new file mode 100644
index 0000000000..f258f326c1
--- /dev/null
+++ b/recipes/gnome/system-tools-backends-2.10.0/add-angstrom-distro.patch
@@ -0,0 +1,28 @@
+Index: system-tools-backends-2.8.3/Utils/Platform.pm
+===================================================================
+--- system-tools-backends-2.8.3.orig/Utils/Platform.pm 2010-01-17 16:05:55.794914937 +0000
++++ system-tools-backends-2.8.3/Utils/Platform.pm 2010-01-17 16:13:07.271917106 +0000
+@@ -91,6 +91,7 @@
+ "nexenta-1.0" => [ "Nexenta GNU/Solaris", "1.0", "Ellate" ],
+ "yellowdog-4.1" => [ "Yellow Dog Linux", "4.1", "Sagitta" ],
+ "guadalinex-v4" => [ "Guadalinex", "v4", "Toro" ],
++ "angstrom" => [ "Angstrom", "", "" ],
+ };
+
+ sub get_platform_info
+@@ -141,6 +142,7 @@
+ "vine-3.1" => "vine-3.0",
+ "vlos-1.2" => "gentoo",
+ "nexenta-1.0" => "solaris-2.11",
++ "angstrom" => "debian-3.0",
+ );
+
+ return $metamap{$distro} if ($metamap{$distro});
+@@ -373,6 +375,7 @@
+ [ \&check_ark ],
+ [ \&check_yoper ],
+ [ \&check_distro_file, "/etc/yellowdog-release", "yellowdog", "^Yellow Dog Linux release (\\S+)" ],
++ [ \&check_file_exists, "/etc/angstrom-version", "angstrom" ],
+ ],
+ "FreeBSD" => [[ \&check_freebsd ]],
+ "SunOS" => [[ \&check_solaris ]]
diff --git a/recipes/gnome/system-tools-backends-2.10.0/system-tools-backends b/recipes/gnome/system-tools-backends-2.10.0/system-tools-backends
new file mode 100644
index 0000000000..704c36dbf4
--- /dev/null
+++ b/recipes/gnome/system-tools-backends-2.10.0/system-tools-backends
@@ -0,0 +1,74 @@
+#! /bin/sh
+### BEGIN INIT INFO
+# Provides: system-tools-backends
+# Required-Start: $local_fs dbus
+# Required-Stop: $local_fs dbus
+# Should-Start: $syslog
+# Should-Stop: $syslog
+# Default-Start: 2 3 4 5
+# Default-Stop: 1
+# Short-Description: Gnome System Tools Backends
+# Description: The Gnome System Tools Backends daemon handles root-needed
+# operations to configure your machine with the Gnome System
+# Tools.
+### END INIT INFO
+
+PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
+DAEMON=/usr/bin/system-tools-backends
+PIDDIR=/var/run
+PIDFILE=$PIDDIR/system-tools-backends.pid
+NAME=system-tools-backends
+DESC="System Tools Backends"
+
+test -x $DAEMON || exit 0
+
+set -e
+
+do_start() {
+ echo "Starting $DESC"
+ start-stop-daemon --start --startas $DAEMON --quiet --pidfile $PIDFILE
+}
+
+do_stop() {
+ echo "Stopping $DESC"
+ start-stop-daemon --stop --oknodo --quiet --pidfile $PIDFILE --startas $DAEMON
+}
+
+case "$1" in
+ start)
+ do_start
+ ;;
+ stop)
+ do_stop
+ ;;
+ #reload)
+ #
+ # If the daemon can reload its config files on the fly
+ # for example by sending it SIGHUP, do it here.
+ #
+ # If the daemon responds to changes in its config file
+ # directly anyway, make this a do-nothing entry.
+ #
+ # echo "Reloading $DESC configuration files."
+ # start-stop-daemon --stop --signal 1 --quiet --pidfile \
+ # /var/run/$NAME.pid --exec $DAEMON
+ #;;
+ restart|force-reload)
+ #
+ # If the "reload" option is implemented, move the "force-reload"
+ # option to the "reload" entry above. If not, "force-reload" is
+ # just the same as "restart".
+ #
+ do_stop
+ sleep 5
+ do_start
+ ;;
+ *)
+ N=/etc/init.d/$NAME
+ echo "Usage: $N {start|stop|restart|reload|force-reload|status}" >&2
+ exit 1
+ ;;
+esac
+
+exit 0
+
diff --git a/recipes/gnome/system-tools-backends_2.10.0.bb b/recipes/gnome/system-tools-backends_2.10.0.bb
new file mode 100644
index 0000000000..393f971075
--- /dev/null
+++ b/recipes/gnome/system-tools-backends_2.10.0.bb
@@ -0,0 +1,45 @@
+DESCRIPTION = "gnome system tools backends"
+LICENSE = "GPL"
+
+DEPENDS = "dbus dbus-glib glib-2.0 policykit"
+
+# Shadow added so there is a full adduser/deluser
+# (Gnome images tend to pull in shadow anyway)
+RDEPENDS = "shadow"
+
+inherit gnome pkgconfig update-rc.d
+
+SRC_URI += " \
+ file://system-tools-backends \
+ "
+
+SRC_URI_append_angstrom = " \
+ file://add-angstrom-distro.patch;patch=1 \
+ "
+
+SRC_URI[archive.md5sum] = "01fd8fcfbe5f68492186404c96af915a"
+SRC_URI[archive.sha256sum] = "5afea48c0c195dd3b6e0b87a586c08bf614942d4bcb60449fd9f65d95418b60d"
+
+EXTRA_OECONF = " --with-net-dbus=${libdir}/perl5 "
+
+do_configure() {
+ sed -i -e 's:CC=$(CC):CC="$(CC)":g' ${S}/Net-DBus/Makefile.am
+ sed -i -e 's:CC=$(CC):CC="$(CC)":g' ${S}/Net-DBus/Makefile.in
+ gnu-configize
+ oe_runconf
+}
+
+do_install_append () {
+ install -d ${D}/${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/system-tools-backends ${D}/${sysconfdir}/init.d/
+}
+
+INITSCRIPT_NAME = "system-tools-backends"
+INITSCRIPT_PARAMS = "start 50 2 3 4 5 . stop 70 1 ."
+
+FILES_${PN} += " ${sysconfdir}/dbus-1/system.d"
+FILES_${PN} += " ${libdir}/pkgconfig"
+FILES_${PN} += " ${datadir}/dbus-1/system-services"
+FILES_${PN} += " ${datadir}/system-tools-backends-2.0/files"
+FILES_${PN} += " ${datadir}/system-tools-backends-2.0/scripts"
+FILES_${PN} += " ${datadir}/polkit*"