aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome
diff options
context:
space:
mode:
authorSteve Sakoman <steve@sakoman.com>2009-08-06 10:42:17 -0700
committerKoen Kooi <koen@openembedded.org>2009-08-08 11:20:06 +0200
commit7eed60cd78cef71b6ada4d1c64ad71d4d4bdec95 (patch)
tree10378a2b1348294f8616b00ab4dd6b8e00ad4bc5 /recipes/gnome
parentaa5fa3a8bd5044e132284910e4cf864702b0c01f (diff)
downloadopenembedded-7eed60cd78cef71b6ada4d1c64ad71d4d4bdec95.tar.gz
gnome-python-extras: add 2.25.3
Diffstat (limited to 'recipes/gnome')
-rw-r--r--recipes/gnome/gnome-python-extras_2.25.3.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/gnome/gnome-python-extras_2.25.3.bb b/recipes/gnome/gnome-python-extras_2.25.3.bb
new file mode 100644
index 0000000000..9d8e786241
--- /dev/null
+++ b/recipes/gnome/gnome-python-extras_2.25.3.bb
@@ -0,0 +1,21 @@
+LICENSE = "GPL/LGPL"
+DEPENDS = "python-pygtk libwnck"
+
+inherit gnome distutils-base
+
+SRC_URI += "file://acinclude.m4"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
+}
+
+do_configure_prepend() {
+ sed -i -e s:'`$PKG_CONFIG --variable=defsdir pygtk-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/defs\":g ${S}/configure.ac
+}
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN}-dev += "${datadir}/pygtk"