aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2011-02-19 11:34:16 +0100
committerKoen Kooi <koen@openembedded.org>2011-02-19 11:36:10 +0100
commit246abfc8659c76c83199296b06be64af25bc4aa3 (patch)
tree47c1fbcc0fdd8adbb92e0fa14bd29ad44f78d1f3 /recipes/gnome
parenta73eb65b95af505364c32fe082bda42b0b0bc84b (diff)
downloadopenembedded-246abfc8659c76c83199296b06be64af25bc4aa3.tar.gz
gvfs 1.6.6: add patch to fix async_connection_accept_new_fd(
Diffstat (limited to 'recipes/gnome')
-rw-r--r--recipes/gnome/gvfs/async.patch50
-rw-r--r--recipes/gnome/gvfs_1.6.6.bb6
2 files changed, 55 insertions, 1 deletions
diff --git a/recipes/gnome/gvfs/async.patch b/recipes/gnome/gvfs/async.patch
new file mode 100644
index 0000000000..22d4b3b2b9
--- /dev/null
+++ b/recipes/gnome/gvfs/async.patch
@@ -0,0 +1,50 @@
+From 4502330afc4623fd6cf7c5cadac01413052e49bf Mon Sep 17 00:00:00 2001
+From: Henry Hoegelow <h.hoegelow@raumfeld.com>
+Date: Thu, 25 Nov 2010 21:37:43 +0000
+Subject: Fix return value of async_connection_accept_new_fd()
+
+async_connection_accept_new_fd() is a GSource callback and needs
+to return TRUE so that it is called again. Add the missing return
+value.
+
+Fixes gvfs client code on the ARM platform (and probably other
+platforms too).
+See https://bugzilla.gnome.org/show_bug.cgi?id=633330 for further
+details.
+
+Acked-by: Sven Neumann <sven@gimp.org>
+(cherry picked from commit 2b6c559ea87fc929ac43527da5cc61c6d831f357)
+---
+diff --git a/client/gvfsdaemondbus.c b/client/gvfsdaemondbus.c
+index 2f999ee..fe9702e 100644
+--- a/client/gvfsdaemondbus.c
++++ b/client/gvfsdaemondbus.c
+@@ -244,7 +244,7 @@ outstanding_fd_free (OutstandingFD *outstanding)
+ g_free (outstanding);
+ }
+
+-static void
++static gboolean
+ async_connection_accept_new_fd (VfsConnectionData *data,
+ GIOCondition condition,
+ int fd)
+@@ -260,7 +260,7 @@ async_connection_accept_new_fd (VfsConnectionData *data,
+ g_source_destroy (data->extra_fd_source);
+ g_source_unref (data->extra_fd_source);
+ data->extra_fd_source = NULL;
+- return;
++ return FALSE;
+ }
+
+ fd_id = data->extra_fd_count;
+@@ -287,6 +287,8 @@ async_connection_accept_new_fd (VfsConnectionData *data,
+ outstanding_fd);
+ }
+ }
++
++ return TRUE;
+ }
+
+ static void
+--
+cgit v0.8.3.4
diff --git a/recipes/gnome/gvfs_1.6.6.bb b/recipes/gnome/gvfs_1.6.6.bb
index a0b5029234..a5646f6f5b 100644
--- a/recipes/gnome/gvfs_1.6.6.bb
+++ b/recipes/gnome/gvfs_1.6.6.bb
@@ -1,9 +1,13 @@
DESCRIPTION = "gvfs is a userspace virtual filesystem"
-LICENSE = "LGPL"
+LICENSE = "LGPLv2"
DEPENDS = "libcdio gawk-native libimobiledevice gnome-keyring glib-2.0 obexftp fuse avahi fuse hal gconf samba gphoto2"
+PR = "r1"
+
inherit gnome
+SRC_URI += "file://async.patch"
+
SRC_URI[archive.md5sum] = "e1f324c45ea07d630f85bd3199865fd9"
SRC_URI[archive.sha256sum] = "902890deb6a670f642180ea958406ebb02af1d5867a464c87e493d56f1dde7bd"