aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnuradio/gnuradio.inc
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-06-01 15:39:06 +0200
committerKoen Kooi <koen@openembedded.org>2009-06-01 15:39:06 +0200
commit71e69ad8b551aa06f63160232d1bd87b8d801a1d (patch)
tree9aab0256970f53fd7a3266d1bd53d11d71950120 /recipes/gnuradio/gnuradio.inc
parentc289210c5b3983dc78ff82a2ba8e80989d846211 (diff)
downloadopenembedded-71e69ad8b551aa06f63160232d1bd87b8d801a1d.tar.gz
gnuradio: add hack to build a private copy of libusb (the gnarly old one) and statically link that since gnuradio is using private methods of libusb that libusb-compat won't provide
Diffstat (limited to 'recipes/gnuradio/gnuradio.inc')
-rw-r--r--recipes/gnuradio/gnuradio.inc18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/gnuradio/gnuradio.inc b/recipes/gnuradio/gnuradio.inc
index 88462404d1..2688636629 100644
--- a/recipes/gnuradio/gnuradio.inc
+++ b/recipes/gnuradio/gnuradio.inc
@@ -26,6 +26,24 @@ EXTRA_OECONF = " \
GR_CPU_SELECTION_armv7a = " --with-md-cpu=arm "
+# This is an awful hack to allow GNU Radio to use libusb-0.12, regardless
+# of what is used by the rest of OE
+
+export USB_CFLAGS=""
+export USB_LIBS="-L${WORKDIR}/libusb-0.1.12/.libs/ -l:libusb-gnur.a"
+
+do_buildlibusb() {
+ cd ${WORKDIR}/libusb-0.1.12
+ sed -e 's/AC_LANG_CPLUSPLUS/AC_PROG_CXX/' -i configure.in
+ sed -e s:tests::g -i Makefile.am
+ sed -e s:tests::g -i Makefile.in || true
+ ./configure --build=${BUILD_SYS} --host=${HOST_SYS} --target=${TARGET_SYS} --prefix=${prefix} --exec_prefix=${exec_prefix} --bindir=${bindir} --sbindir=${sbindir} --libexecdir=${libexecdir} --datadir=${datadir} --sysconfdir=${sysconfdir} --sharedstatedir=${sharedstatedir} --localstatedir=${localstatedir} --libdir=${libdir} --includedir=${includedir} --oldincludedir=${oldincludedir} --infodir=${infodir} --mandir=${mandir} --disable-shared --disable-build-docs
+ make
+ mv .libs/libusb.a .libs/libusb-gnur.a || true
+ cd ${WORKDIR}
+}
+
+
do_configure_prepend() {
if [ -e ${WORKDIR}/acinclude.m4 ] ; then
cp ${WORKDIR}/acinclude.m4 ${S}