aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gob2
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-12-05 00:36:53 +0100
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-12-05 00:43:22 +0100
commit8ea3c122ace4447919311007d6b24d5fbd3b6ad1 (patch)
treec1280fcaefb3ab93fdbf481e8171d52c63c41507 /recipes/gob2
parent0b0a6b43addca3358a04dfc97234fdc58dfbd74a (diff)
downloadopenembedded-8ea3c122ace4447919311007d6b24d5fbd3b6ad1.tar.gz
gob2: updated to 2.0.17
When trying to build gmpc on our autobuilder (64 bit ubuntu 10.04) I got compile errors because gob2 apparently corrupted some data it generated causing type names to be changed. On opensuse 11.2, 32bit it worked like a charm. As our gob2 was 2.0.14 from 2006 and the latest one was 2.0.17 from earlier this year I decided to update first. Apparently this has fixed the issue. (32 and 64 bit work fine) Also merged the native recipe in the target recipe. Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gob2')
-rw-r--r--recipes/gob2/gob2_2.0.17.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/gob2/gob2_2.0.17.bb b/recipes/gob2/gob2_2.0.17.bb
new file mode 100644
index 0000000000..b349ba85a5
--- /dev/null
+++ b/recipes/gob2/gob2_2.0.17.bb
@@ -0,0 +1,23 @@
+LICENSE = "LGPL"
+DESCRIPTION = "A library to make creating GObjects easier"
+HOMEPAGE = "http://www.5z.com/jirka/gob.html"
+SECTION = "libs"
+DEPENDS = "gtk+ bison flex"
+
+SRC_URI = "http://ftp.5z.com/pub/gob/gob2-2.0.17.tar.gz"
+SRC_URI[md5sum] = "05fa7384b30ebb2921430b2615d2c2e5"
+SRC_URI[sha256sum] = "80b4683af653809970ef237fa45427b203653edf0dd5e3dc8897433e9c29346c"
+
+inherit autotools pkgconfig
+
+do_compile_prepend() {
+ find ${S} -name Makefile | xargs sed -i 's~-I/usr/include~-I${STAGING_INCDIR}~g'
+ find ${S} -name Makefile | xargs sed -i 's~-I$(includedir)~-I${STAGING_INCDIR}~g'
+}
+
+do_stage() {
+ install -m 0644 ${S}/gob2.m4 ${STAGING_DATADIR}/aclocal
+}
+
+BBCLASSEXTEND = "native"
+