aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gobby
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gobby
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gobby')
-rw-r--r--recipes/gobby/gobby_0.4.1.bb7
-rw-r--r--recipes/gobby/gtksourceview_1.7.2.bb9
-rw-r--r--recipes/gobby/net6_1.2.2.bb15
-rw-r--r--recipes/gobby/net6_1.3.1.bb14
-rw-r--r--recipes/gobby/obby_0.4.1.bb18
5 files changed, 63 insertions, 0 deletions
diff --git a/recipes/gobby/gobby_0.4.1.bb b/recipes/gobby/gobby_0.4.1.bb
new file mode 100644
index 0000000000..f9474c8fe3
--- /dev/null
+++ b/recipes/gobby/gobby_0.4.1.bb
@@ -0,0 +1,7 @@
+LICENSE = "LGPL"
+HOMEPAGE = "http://darcs.0x539.de/trac/obby/cgi-bin/trac.cgi/wiki/"
+
+DEPENDS = "net6 gtkmm obby gtksourceview libxml++"
+inherit autotools pkgconfig
+
+SRC_URI = "http://releases.0x539.de/gobby/gobby-${PV}.tar.gz"
diff --git a/recipes/gobby/gtksourceview_1.7.2.bb b/recipes/gobby/gtksourceview_1.7.2.bb
new file mode 100644
index 0000000000..6b4c8e686c
--- /dev/null
+++ b/recipes/gobby/gtksourceview_1.7.2.bb
@@ -0,0 +1,9 @@
+LICENSE = "GPL"
+
+DEPENDS = "gtk+ libgnomeprint"
+
+inherit gnome pkgconfig
+
+do_stage() {
+autotools_stage_all
+}
diff --git a/recipes/gobby/net6_1.2.2.bb b/recipes/gobby/net6_1.2.2.bb
new file mode 100644
index 0000000000..5399cd57c6
--- /dev/null
+++ b/recipes/gobby/net6_1.2.2.bb
@@ -0,0 +1,15 @@
+LICENSE = "LGPL"
+HOMEPAGE = "http://darcs.0x539.de/trac/obby/cgi-bin/trac.cgi/wiki/"
+
+DEPENDS = "libsigc++-2.0"
+inherit autotools pkgconfig
+
+SRC_URI = "http://releases.0x539.de/${PN}/${P}.tar.gz"
+
+do_stage() {
+ autotools_stage_all
+ install -d ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/net6
+ install -m 644 inc/*.hpp ${STAGING_INCDIR}/net6
+ install -m 755 .libs/*so* ${STAGING_LIBDIR}/
+}
diff --git a/recipes/gobby/net6_1.3.1.bb b/recipes/gobby/net6_1.3.1.bb
new file mode 100644
index 0000000000..bafc185322
--- /dev/null
+++ b/recipes/gobby/net6_1.3.1.bb
@@ -0,0 +1,14 @@
+LICENSE = "LGPL"
+HOMEPAGE = "http://darcs.0x539.de/trac/obby/cgi-bin/trac.cgi/wiki/"
+
+DEPENDS = "libsigc++-2.0 gnutls"
+inherit autotools pkgconfig
+
+SRC_URI = "http://releases.0x539.de/${PN}/${P}.tar.gz"
+
+do_stage() {
+ install -d ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/net6
+ install -m 644 inc/*.hpp ${STAGING_INCDIR}/net6
+ install -m 755 .libs/*so* ${STAGING_LIBDIR}/
+}
diff --git a/recipes/gobby/obby_0.4.1.bb b/recipes/gobby/obby_0.4.1.bb
new file mode 100644
index 0000000000..f72ca51ab3
--- /dev/null
+++ b/recipes/gobby/obby_0.4.1.bb
@@ -0,0 +1,18 @@
+LICENSE = "LGPL"
+HOMEPAGE = "http://darcs.0x539.de/trac/obby/cgi-bin/trac.cgi/wiki/"
+
+DEPENDS = "net6 gtkmm gmp"
+inherit autotools pkgconfig
+
+SRC_URI = "http://releases.0x539.de/obby/obby-${PV}.tar.gz"
+
+EXTRA_OECONF += " --with-libgmp-prefix=${STAGING_LIBDIR}"
+
+do_stage() {
+ install -d ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/obby
+ install -d ${STAGING_INCDIR}/obby/serialise
+ install -m 644 inc/*.hpp ${STAGING_INCDIR}/obby
+ install -m 644 inc/serialise/*.hpp ${STAGING_INCDIR}/obby/serialise
+ install -m 755 src/.libs/*so* ${STAGING_LIBDIR}/
+}