aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gparted
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gparted
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gparted')
-rw-r--r--recipes/gparted/files/cross.patch12
-rw-r--r--recipes/gparted/files/gparted-0.3.3-llabs.patch72
-rw-r--r--recipes/gparted/gparted_0.3.3.bb10
-rw-r--r--recipes/gparted/gparted_0.4.1.bb11
4 files changed, 105 insertions, 0 deletions
diff --git a/recipes/gparted/files/cross.patch b/recipes/gparted/files/cross.patch
new file mode 100644
index 0000000000..08d4a29e5a
--- /dev/null
+++ b/recipes/gparted/files/cross.patch
@@ -0,0 +1,12 @@
+diff -ur gparted-0.3.3.org/configure.in gparted-0.3.3/configure.in
+--- gparted-0.3.3.org/configure.in 2006-12-06 15:23:35.000000000 +0200
++++ gparted-0.3.3/configure.in 2007-07-10 02:10:59.000000000 +0300
+@@ -37,7 +37,7 @@
+ AC_MSG_CHECKING(for libparted >= $LIBPARTED_VERSION)
+ LIBS_save="$LIBS"
+ LIBS="-lparted -luuid -ldl"
+-AC_TRY_RUN(
++AC_TRY_LINK(
+ #include <stdio.h>
+ #include <parted/parted.h>
+
diff --git a/recipes/gparted/files/gparted-0.3.3-llabs.patch b/recipes/gparted/files/gparted-0.3.3-llabs.patch
new file mode 100644
index 0000000000..07c4020e57
--- /dev/null
+++ b/recipes/gparted/files/gparted-0.3.3-llabs.patch
@@ -0,0 +1,72 @@
+--- src/GParted_Core.cc 2006/09/25 21:49:32 1.1
++++ src/GParted_Core.cc 2006/09/25 22:03:31
+@@ -1604,7 +1604,7 @@ bool GParted_Core::copy_filesystem( cons
+
+ while ( succes &&
+ timer .elapsed() <= smallest_time &&
+- std::llabs( done ) + N <= length &&
++ llabs( done ) + N <= length &&
+ optimal_blocksize * 2 < N )
+ {
+ if ( done != 0 )
+@@ -1648,7 +1648,7 @@ bool GParted_Core::copy_filesystem( cons
+ dst_device,
+ src_start + ( dst_start > src_start ? 0 : done ),
+ dst_start + ( dst_start > src_start ? 0 : done ),
+- length - std::llabs( done ),
++ length - llabs( done ),
+ optimal_blocksize,
+ operationdetail,
+ readonly,
+@@ -1822,7 +1822,7 @@ bool GParted_Core::copy_blocks( const Gl
+ if ( lp_device_src && lp_device_dst && ped_device_open( lp_device_src ) && ped_device_open( lp_device_dst ) )
+ {
+ Glib::ustring error_message ;
+- buf = static_cast<char *>( malloc( std::llabs( blocksize ) * 512 ) ) ;
++ buf = static_cast<char *>( malloc( llabs( blocksize ) * 512 ) ) ;
+ if ( buf )
+ {
+ ped_device_sync( lp_device_dst ) ;
+@@ -1843,7 +1843,7 @@ bool GParted_Core::copy_blocks( const Gl
+ operationdetail .get_last_child() .add_child( OperationDetail( "", STATUS_NONE ) ) ;
+
+ Glib::Timer timer_progress_timeout, timer_total ;
+- while( succes && std::llabs( done ) < length )
++ while( succes && llabs( done ) < length )
+ {
+ succes = copy_block( lp_device_src,
+ lp_device_dst,
+@@ -1858,7 +1858,7 @@ bool GParted_Core::copy_blocks( const Gl
+ if ( timer_progress_timeout .elapsed() >= 0.5 )
+ {
+ set_progress_info( length,
+- std::llabs( done + blocksize ),
++ llabs( done + blocksize ),
+ timer_total,
+ operationdetail .get_last_child() .get_last_child(),
+ readonly ) ;
+@@ -1877,13 +1877,13 @@ bool GParted_Core::copy_blocks( const Gl
+
+ //final description
+ operationdetail .get_last_child() .get_last_child() .set_description(
+- String::ucompose( readonly ? _("%1 of %2 read") : _("%1 of %2 copied"), std::llabs( done ), length ), FONT_ITALIC ) ;
++ String::ucompose( readonly ? _("%1 of %2 read") : _("%1 of %2 copied"), llabs( done ), length ), FONT_ITALIC ) ;
+
+ if ( ! succes && ! error_message .empty() )
+ operationdetail .get_last_child() .add_child(
+ OperationDetail( error_message, STATUS_NONE, FONT_ITALIC ) ) ;
+
+- total_done += std::llabs( done ) ;
++ total_done += llabs( done ) ;
+
+ //close and destroy the devices..
+ ped_device_close( lp_device_src ) ;
+@@ -1912,7 +1912,7 @@ bool GParted_Core::copy_block( PedDevice
+
+ if ( blocksize < 0 )
+ {
+- blocksize = std::llabs( blocksize ) ;
++ blocksize = llabs( blocksize ) ;
+ offset_src -= ( blocksize -1 ) ;
+ offset_dst -= ( blocksize -1 ) ;
+ }
diff --git a/recipes/gparted/gparted_0.3.3.bb b/recipes/gparted/gparted_0.3.3.bb
new file mode 100644
index 0000000000..43623d7348
--- /dev/null
+++ b/recipes/gparted/gparted_0.3.3.bb
@@ -0,0 +1,10 @@
+DESCRIPTION = "GNOME Partition Manager"
+LICENSE = "GPL"
+DEPENDS = "gtkmm parted"
+PR = "r1"
+
+inherit autotools
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/gparted/gparted-${PV}.tar.bz2 \
+ file://cross.patch;patch=1 \
+ file://gparted-0.3.3-llabs.patch;patch=1;pnum=0"
diff --git a/recipes/gparted/gparted_0.4.1.bb b/recipes/gparted/gparted_0.4.1.bb
new file mode 100644
index 0000000000..c95fb6471c
--- /dev/null
+++ b/recipes/gparted/gparted_0.4.1.bb
@@ -0,0 +1,11 @@
+DESCRIPTION = "GNOME Partition Manager"
+LICENSE = "GPL"
+DEPENDS = "gtkmm parted"
+
+inherit gnome
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/gparted/gparted-${PV}.tar.bz2 \
+ file://cross.patch;patch=1 \
+"
+
+EXTRA_OECONF = " --disable-doc --disable-scrollkeeper "