aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpe-conf
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gpe-conf
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gpe-conf')
-rw-r--r--recipes/gpe-conf/gpe-conf-0.2.4/scriptname.patch13
-rw-r--r--recipes/gpe-conf/gpe-conf-0.2.5/backlight-bugfix.patch11
-rw-r--r--recipes/gpe-conf/gpe-conf-0.2.5/wireless.patch16
-rw-r--r--recipes/gpe-conf/gpe-conf-0.2.7/poweroff.patch11
-rw-r--r--recipes/gpe-conf/gpe-conf-0.2.7/wifi-key.patch166
-rw-r--r--recipes/gpe-conf/gpe-conf_0.2.3.bb21
-rw-r--r--recipes/gpe-conf/gpe-conf_0.2.4.bb25
-rw-r--r--recipes/gpe-conf/gpe-conf_0.2.5.bb27
-rw-r--r--recipes/gpe-conf/gpe-conf_0.2.6.bb25
-rw-r--r--recipes/gpe-conf/gpe-conf_0.2.7.bb28
-rw-r--r--recipes/gpe-conf/gpe-conf_0.2.8.bb23
-rw-r--r--recipes/gpe-conf/gpe-conf_svn.bb27
12 files changed, 393 insertions, 0 deletions
diff --git a/recipes/gpe-conf/gpe-conf-0.2.4/scriptname.patch b/recipes/gpe-conf/gpe-conf-0.2.4/scriptname.patch
new file mode 100644
index 0000000000..e66d509c9f
--- /dev/null
+++ b/recipes/gpe-conf/gpe-conf-0.2.4/scriptname.patch
@@ -0,0 +1,13 @@
+Index: Makefile.am
+===================================================================
+--- Makefile.am (revision 9037)
++++ Makefile.am (working copy)
+@@ -178,7 +178,7 @@
+
+ install-data-hook:
+ chmod u+s $(DESTDIR)$(bindir)/gpe-conf
+- cd $(DESTDIR)/$(xscriptsdir) && mv soundsettings.sh S30soundsettings
++ cd $(DESTDIR)/$(xscriptsdir) && mv soundsettings.sh 30soundsettings
+
+ deb: dist
+ -mkdir $(top_builddir)/debian-build
diff --git a/recipes/gpe-conf/gpe-conf-0.2.5/backlight-bugfix.patch b/recipes/gpe-conf/gpe-conf-0.2.5/backlight-bugfix.patch
new file mode 100644
index 0000000000..7a953c25ec
--- /dev/null
+++ b/recipes/gpe-conf/gpe-conf-0.2.5/backlight-bugfix.patch
@@ -0,0 +1,11 @@
+--- gpe-conf-0.2.5/modules/screen/brightness.c~brightness
++++ gpe-conf-0.2.5/modules/screen/brightness.c
+@@ -216,7 +216,7 @@
+ FILE *f_power;
+ gint value = SYS_STATE_ON;
+
+- f_power = fopen(SYS_BRIGHTNESS, "r");
++ f_power = fopen(SYS_POWER, "r");
+ if (f_power != NULL)
+ {
+ fscanf(f_power,"%i", &value);
diff --git a/recipes/gpe-conf/gpe-conf-0.2.5/wireless.patch b/recipes/gpe-conf/gpe-conf-0.2.5/wireless.patch
new file mode 100644
index 0000000000..4e52f8b092
--- /dev/null
+++ b/recipes/gpe-conf/gpe-conf-0.2.5/wireless.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- gpe-conf-0.2.5/modules/sysinfo.c~wireless
++++ gpe-conf-0.2.5/modules/sysinfo.c
+@@ -28,6 +28,8 @@
+ #include <sys/utsname.h>
+
+ #include <sys/socket.h>
++#include <linux/types.h>
++#include <linux/if.h>
+ #include <linux/wireless.h>
+ #include <sys/ioctl.h>
+
diff --git a/recipes/gpe-conf/gpe-conf-0.2.7/poweroff.patch b/recipes/gpe-conf/gpe-conf-0.2.7/poweroff.patch
new file mode 100644
index 0000000000..2255886968
--- /dev/null
+++ b/recipes/gpe-conf/gpe-conf-0.2.7/poweroff.patch
@@ -0,0 +1,11 @@
+--- gpe-conf/suid.c~ 2008-06-05 12:41:26.000000000 +0200
++++ gpe-conf/suid.c 2008-06-05 12:41:26.000000000 +0200
+@@ -454,7 +454,7 @@
+ else if (strcmp (cmd, "SHDN") == 0) // shutdown device
+ {
+ fscanf (in, "%100s", arg2);
+- system ("poweroff");
++ system ("/sbin/poweroff");
+ }
+ else if (strcmp (cmd, "MODP") == 0) /* modprobe kernel module */
+ {
diff --git a/recipes/gpe-conf/gpe-conf-0.2.7/wifi-key.patch b/recipes/gpe-conf/gpe-conf-0.2.7/wifi-key.patch
new file mode 100644
index 0000000000..f05c04cb45
--- /dev/null
+++ b/recipes/gpe-conf/gpe-conf-0.2.7/wifi-key.patch
@@ -0,0 +1,166 @@
+---
+ ChangeLog | 4 ++++
+ modules/cfgfile.c | 49 +++++++++++++++++++++++++++++--------------------
+ 2 files changed, 33 insertions(+), 20 deletions(-)
+
+--- ChangeLog.orig
++++ ChangeLog
+@@ -1,5 +1,9 @@
++2008-12-18 Florian Boor <florian@kernelconcepts.de>
++
++ * cfgfile.c: Some fixes to wifi key string generation.
++
+ 2008-05-23 Florian Boor <florian.boor@kernelconcepts.de>
+
+ * Relase version 0.2.7
+ * Update translations
+
+--- modules/cfgfile.c.orig
++++ modules/cfgfile.c
+@@ -1,8 +1,8 @@
+ /*
+ *
+- * Copyright (C) 2002, 2003 Florian Boor <florian.boor@kernelconcepts.de>
++ * Copyright (C) 2002, 2003, 2008 Florian Boor <florian.boor@kernelconcepts.de>
+ * 2004 Ole Reinhardt <ole.reinhardt@kernelconcepts.de>
+ *
+ * This program is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License
+ * as published by the Free Software Foundation; either version
+@@ -128,12 +128,10 @@ gint get_param_val(gchar* line, gchar* p
+ for (b=a+1;b<strlen(line);b++)
+ if ((line[b]=='\n') || (line[b]=='\0')) break;
+ param=strncpy(param,&line[st],sep-st);
+ param[sep-st]='\0';
+
+-//KC-OR: changed because singe character values not recognized correctly
+-// if ((b-a) > 0) value=strncpy(value,&line[a],b-a);
+ if ((b-a) > 0) value=strncpy(value,&line[a],b-a);
+ value[b-a]='\0';
+ return 0;
+ }
+
+@@ -562,15 +560,17 @@ gchar *get_iflist()
+ strncat(result," ",255);
+ }
+ return result;
+ }
+
+-void get_wifikey_string(NWInterface_t iface, char* key)
++void get_wifikey_string(NWInterface_t iface, gchar** key)
+ {
+ gint nokeys = FALSE;
+ gint count;
+ gchar temp[42];
++ gchar *lkey = g_strdup(""), *t;
++
+
+ if ((strlen(iface.key[0]) == 0) &&
+ (strlen(iface.key[1]) == 0) &&
+ (strlen(iface.key[2]) == 0) &&
+ (strlen(iface.key[3]) == 0))
+@@ -581,29 +581,36 @@ void get_wifikey_string(NWInterface_t if
+
+ if (strlen(iface.key[iface.keynr-1]) == 0)
+ for (iface.keynr = 1; iface.keynr <=4; iface.keynr++)
+ if (strlen(iface.key[iface.keynr-1]) != 0) break;
+
+- switch (iface.encmode)
+- {
+- case ENC_OFF: strcpy(key, "off"); break;
+- case ENC_OPEN: strcpy(key, "open"); break;
+- case ENC_RESTRICTED: strcpy(key, "restricted"); break;
+- }
+-
+ if (!nokeys)
+ {
+ for (count = 0; count < 4; count++)
+ if (strlen(iface.key[count]) > 0)
+ {
+- sprintf(temp, " key %s [%d]", iface.key[count], count+1);
+- strcat(key, temp);
++ t = lkey;
++ lkey = g_strdup_printf("%s key %s [%d]", lkey, iface.key[count], count+1);
++ g_free(t);
+ }
+
+- sprintf(temp, " key [%d]", iface.keynr);
+- strcat(key, temp);
++ t = lkey;
++ lkey = g_strdup_printf(" %s key [%d]", lkey, iface.keynr);
++ g_free(t);
+ }
++
++ t = lkey;
++ switch (iface.encmode)
++ {
++ case ENC_OPEN: lkey = g_strdup_printf ("%s key open", lkey); break;
++ case ENC_RESTRICTED: lkey = g_strdup_printf("%s key restricted", lkey); break;
++ case ENC_OFF: lkey = g_strdup_printf("%s key off", lkey); break;
++ default: lkey = g_strdup_printf("%s key off", lkey); break;
++ }
++ g_free(t);
++
++ *key = lkey;
+ }
+
+ gint write_sections()
+ {
+ gint i,j;
+@@ -613,11 +620,11 @@ gint write_sections()
+ gchar paramval[255];
+ gchar ifname[255];
+ gint svd[14];
+ gint lastwpos = 0;
+ gint last_i;
+- gchar key[128];
++ gchar *key;
+
+ for (i=0;i<configlen;i++)
+ {
+ get_param_val(configtext[i],paramval,ifname); // get next tokens
+ /* handled by hotplug
+@@ -724,12 +731,13 @@ gint write_sections()
+ svd[Swifichannel] = TRUE;
+ lastwpos = i;
+ } else
+ if (!strcmp("wireless_key", paramval))
+ {
+- get_wifikey_string(iflist[l-1], key);
++ get_wifikey_string(iflist[l-1], &key);
+ configtext[i] = subst_val(configtext[i], key);
++ g_free(key);
+ svd[Swifikey] = TRUE;
+ lastwpos = i;
+ }
+
+ } // else
+@@ -807,11 +815,11 @@ gint write_sections()
+ add_line(lastwpos,outstr);
+ i++;
+ }
+ if (!svd[Swifikey])
+ {
+- get_wifikey_string(iflist[l-1], key);
++ get_wifikey_string(iflist[l-1], &key);
+ sprintf(outstr,"\twireless_key %s",key);
+ add_line(lastwpos,outstr);
+ i++;
+ }
+ }
+@@ -884,12 +892,13 @@ gint write_sections()
+ if (strlen (iflist[i].channel) > 0)
+ {
+ sprintf(outstr,"\twireless_channel %s",iflist[i].channel);
+ add_line(configlen,outstr);
+ }
+- get_wifikey_string(iflist[i], key);
+- sprintf(outstr,"\twireless_key %s",key);
++ get_wifikey_string(iflist[i], &key);
++ sprintf(outstr,"\twireless_key %s",key);
++ g_free(key);
+ add_line(configlen,outstr);
+ }
+
+ } //if status
+
diff --git a/recipes/gpe-conf/gpe-conf_0.2.3.bb b/recipes/gpe-conf/gpe-conf_0.2.3.bb
new file mode 100644
index 0000000000..0cb645c5d4
--- /dev/null
+++ b/recipes/gpe-conf/gpe-conf_0.2.3.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Configuration applets for GPE"
+SECTION = "gpe"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+DEPENDS = "gtk+ esound audiofile libgpewidget libxsettings libxsettings-client"
+RDEPENDS_${PN} = "xst xset ipaq-sleep ntpdate gpe-login gpe-icons tzdata"
+RDEPENDS_gpe-conf-panel = "gpe-conf"
+
+PR = "r1"
+
+GPE_TARBALL_SUFFIX = "bz2"
+
+inherit gpe autotools pkgconfig
+
+PACKAGES += "gpe-conf-panel"
+
+FILES_${PN} = "${sysconfdir} ${bindir} ${datadir}/pixmaps \
+ ${datadir}/applications/gpe-conf-* ${datadir}/gpe/pixmaps \
+ ${datadir}/gpe-conf"
+FILES_gpe-conf-panel = "${datadir}/applications/gpe-conf.desktop"
diff --git a/recipes/gpe-conf/gpe-conf_0.2.4.bb b/recipes/gpe-conf/gpe-conf_0.2.4.bb
new file mode 100644
index 0000000000..15a5bce0f3
--- /dev/null
+++ b/recipes/gpe-conf/gpe-conf_0.2.4.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Configuration applets for GPE"
+SECTION = "gpe"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+DEPENDS = "gtk+ esound audiofile libgpewidget libxsettings libxsettings-client libxrandr"
+RDEPENDS_${PN} = "xst xset ntpdate gpe-login gpe-icons tzdata xrandr"
+RDEPENDS_gpe-conf-panel = "gpe-conf"
+
+PR = "r2"
+
+GPE_TARBALL_SUFFIX = "bz2"
+
+inherit gpe autotools pkgconfig
+
+SRC_URI += "file://scriptname.patch;patch=1;pnum=0"
+
+PACKAGES += "gpe-conf-panel"
+
+FILES_${PN} = "${sysconfdir} ${bindir} ${datadir}/pixmaps \
+ ${datadir}/applications/gpe-conf-* ${datadir}/gpe/pixmaps \
+ ${datadir}/gpe-conf"
+FILES_gpe-conf-panel = "${datadir}/applications/gpe-conf.desktop"
+
+
diff --git a/recipes/gpe-conf/gpe-conf_0.2.5.bb b/recipes/gpe-conf/gpe-conf_0.2.5.bb
new file mode 100644
index 0000000000..8cb2d61f3d
--- /dev/null
+++ b/recipes/gpe-conf/gpe-conf_0.2.5.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Configuration applets for GPE"
+SECTION = "gpe"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+DEPENDS = "gtk+ esound audiofile libgpewidget libxsettings libxsettings-client libxrandr"
+RDEPENDS_${PN} = "xst xset ntpdate gpe-login gpe-icons tzdata xrandr"
+RDEPENDS_gpe-conf-panel = "gpe-conf"
+
+RPROVIDES_${PN} += " bl"
+RCONFLICTS_${PN} = "bl"
+
+PR = "r4"
+
+GPE_TARBALL_SUFFIX = "bz2"
+
+inherit gpe autotools pkgconfig
+
+PACKAGES += "gpe-conf-panel"
+
+FILES_${PN} = "${sysconfdir} ${bindir} ${datadir}/pixmaps \
+ ${datadir}/applications/gpe-conf-* ${datadir}/gpe/pixmaps \
+ ${datadir}/gpe-conf"
+FILES_gpe-conf-panel = "${datadir}/applications/gpe-conf.desktop"
+
+SRC_URI += "file://backlight-bugfix.patch;patch=1 \
+ file://wireless.patch;patch=1"
diff --git a/recipes/gpe-conf/gpe-conf_0.2.6.bb b/recipes/gpe-conf/gpe-conf_0.2.6.bb
new file mode 100644
index 0000000000..b56b780210
--- /dev/null
+++ b/recipes/gpe-conf/gpe-conf_0.2.6.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Configuration applets for GPE"
+SECTION = "gpe"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+DEPENDS = "gtk+ esound audiofile libgpewidget libxsettings libxsettings-client libxrandr"
+RDEPENDS_${PN} = "xst gpe-confd xset ntpdate gpe-icons tzdata xrandr"
+RDEPENDS_gpe-conf-panel = "gpe-conf"
+
+RPROVIDES_${PN} += " bl"
+RCONFLICTS_${PN} = "bl"
+
+PR = "r1"
+
+GPE_TARBALL_SUFFIX = "bz2"
+
+inherit gpe autotools pkgconfig
+
+PACKAGES += "gpe-conf-panel"
+
+FILES_${PN} = "${sysconfdir} ${bindir} ${datadir}/pixmaps \
+ ${datadir}/applications/gpe-conf-* ${datadir}/gpe/pixmaps \
+ ${datadir}/gpe-conf"
+FILES_gpe-conf-panel = "${datadir}/applications/gpe-conf.desktop"
+
diff --git a/recipes/gpe-conf/gpe-conf_0.2.7.bb b/recipes/gpe-conf/gpe-conf_0.2.7.bb
new file mode 100644
index 0000000000..2d4fb2168e
--- /dev/null
+++ b/recipes/gpe-conf/gpe-conf_0.2.7.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Configuration applets for GPE"
+SECTION = "gpe"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+DEPENDS = "gtk+ esound audiofile libgpewidget libxsettings libxsettings-client libxrandr"
+RDEPENDS_${PN} = "xst gpe-confd xset ntpdate gpe-icons tzdata xrandr"
+RDEPENDS_gpe-conf-panel = "gpe-conf"
+
+RPROVIDES_${PN} += " bl"
+RCONFLICTS_${PN} = "bl"
+
+PR = "r2"
+
+GPE_TARBALL_SUFFIX = "bz2"
+
+inherit gpe autotools pkgconfig
+
+SRC_URI += "file://poweroff.patch;patch=1 \
+ file://wifi-key.patch;patch=1;pnum=0"
+
+PACKAGES += "gpe-conf-panel"
+
+FILES_${PN} = "${sysconfdir} ${bindir} ${datadir}/pixmaps \
+ ${datadir}/applications/gpe-conf-* ${datadir}/gpe/pixmaps \
+ ${datadir}/gpe-conf"
+FILES_gpe-conf-panel = "${datadir}/applications/gpe-conf.desktop"
+
diff --git a/recipes/gpe-conf/gpe-conf_0.2.8.bb b/recipes/gpe-conf/gpe-conf_0.2.8.bb
new file mode 100644
index 0000000000..de840517e6
--- /dev/null
+++ b/recipes/gpe-conf/gpe-conf_0.2.8.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Configuration applets for GPE"
+SECTION = "gpe"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+DEPENDS = "gtk+ esound audiofile libgpewidget libxsettings libxsettings-client libxrandr"
+RDEPENDS_${PN} = "xst gpe-confd xset ntpdate gpe-icons tzdata xrandr"
+RDEPENDS_gpe-conf-panel = "gpe-conf"
+
+RPROVIDES_${PN} += " bl"
+RCONFLICTS_${PN} = "bl"
+
+GPE_TARBALL_SUFFIX = "bz2"
+
+inherit gpe autotools pkgconfig
+
+PACKAGES += "gpe-conf-panel"
+
+FILES_${PN} = "${sysconfdir} ${bindir} ${datadir}/pixmaps \
+ ${datadir}/applications/gpe-conf-* ${datadir}/gpe/pixmaps \
+ ${datadir}/gpe-conf"
+FILES_gpe-conf-panel = "${datadir}/applications/gpe-conf.desktop"
+
diff --git a/recipes/gpe-conf/gpe-conf_svn.bb b/recipes/gpe-conf/gpe-conf_svn.bb
new file mode 100644
index 0000000000..5f9d60fd88
--- /dev/null
+++ b/recipes/gpe-conf/gpe-conf_svn.bb
@@ -0,0 +1,27 @@
+DEFAULT_PREFERENCE = "-1"
+
+DESCRIPTION = "Configuration applets for GPE"
+SECTION = "gpe"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+DEPENDS = "gtk+ libgpewidget libxsettings libxsettings-client pcmcia-cs xst xset ntp gpe-login gpe-icons"
+RDEPENDS_${PN} = "xst tzdata xset ntpdate gpe-login gpe-icons"
+RDEPENDS_gpe-conf-panel = "gpe-conf"
+
+inherit autotools gpe
+
+PV = "0.2.7+svnr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "${GPE_SVN}"
+S = "${WORKDIR}/${PN}"
+
+
+PACKAGES = "${PN}-dbg gpe-conf gpe-conf-panel"
+
+FILES_${PN} = "${sysconfdir} ${bindir} ${datadir}/pixmaps \
+ ${datadir}/applications/gpe-conf-* ${datadir}/gpe/pixmaps \
+ ${datadir}/gpe-conf"
+FILES_gpe-conf-panel = "${datadir}/applications/gpe-conf.desktop"
+