aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpe-ownerinfo
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gpe-ownerinfo
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gpe-ownerinfo')
-rw-r--r--recipes/gpe-ownerinfo/gpe-ownerinfo.inc17
-rw-r--r--recipes/gpe-ownerinfo/gpe-ownerinfo/compile.patch13
-rw-r--r--recipes/gpe-ownerinfo/gpe-ownerinfo/fixloop.patch16
-rw-r--r--recipes/gpe-ownerinfo/gpe-ownerinfo/svn-build.patch238
-rw-r--r--recipes/gpe-ownerinfo/gpe-ownerinfo_0.23.bb3
-rw-r--r--recipes/gpe-ownerinfo/gpe-ownerinfo_0.24.bb5
-rw-r--r--recipes/gpe-ownerinfo/gpe-ownerinfo_0.25.bb3
-rw-r--r--recipes/gpe-ownerinfo/gpe-ownerinfo_0.26.bb3
-rw-r--r--recipes/gpe-ownerinfo/gpe-ownerinfo_0.27.bb3
-rw-r--r--recipes/gpe-ownerinfo/gpe-ownerinfo_0.28.bb5
-rw-r--r--recipes/gpe-ownerinfo/gpe-ownerinfo_svn.bb11
11 files changed, 317 insertions, 0 deletions
diff --git a/recipes/gpe-ownerinfo/gpe-ownerinfo.inc b/recipes/gpe-ownerinfo/gpe-ownerinfo.inc
new file mode 100644
index 0000000000..a56d2f9852
--- /dev/null
+++ b/recipes/gpe-ownerinfo/gpe-ownerinfo.inc
@@ -0,0 +1,17 @@
+inherit gpe
+
+DESCRIPTION = "GPE owner information dialog"
+SECTION = "gpe"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "gtk+ libgpewidget"
+
+do_compile_prepend() {
+ sed -i -e 's: -s : :g' Makefile
+}
+
+do_stage () {
+ oe_libinstall -a libgpe-ownerinfo ${STAGING_LIBDIR}
+ install -m 0644 gpe-ownerinfo.h ${STAGING_INCDIR}/
+}
+
diff --git a/recipes/gpe-ownerinfo/gpe-ownerinfo/compile.patch b/recipes/gpe-ownerinfo/gpe-ownerinfo/compile.patch
new file mode 100644
index 0000000000..3406481d66
--- /dev/null
+++ b/recipes/gpe-ownerinfo/gpe-ownerinfo/compile.patch
@@ -0,0 +1,13 @@
+Index: gpe-ownerinfo-0.28/Makefile
+===================================================================
+--- gpe-ownerinfo-0.28.orig/Makefile
++++ gpe-ownerinfo-0.28/Makefile
+@@ -40,7 +40,7 @@ all: $(PACKAGE) all-mo
+
+ $(LIB_TARGET): $(LIB_OBJS)
+ rm -f $@
+- ar cq $@ $^
++ $(AR) cq $@ $^
+
+ $(PACKAGE): $(OBJS) $(LIB_TARGET)
+ $(CC) -o $@ $^ $(LDFLAGS) $(PACKAGE_LDFLAGS) -L. -lgpe-ownerinfo
diff --git a/recipes/gpe-ownerinfo/gpe-ownerinfo/fixloop.patch b/recipes/gpe-ownerinfo/gpe-ownerinfo/fixloop.patch
new file mode 100644
index 0000000000..14dc308c83
--- /dev/null
+++ b/recipes/gpe-ownerinfo/gpe-ownerinfo/fixloop.patch
@@ -0,0 +1,16 @@
+Index: gpe-ownerinfo.c
+===================================================================
+RCS file: /cvs/gpe/base/gpe-ownerinfo/gpe-ownerinfo.c,v
+retrieving revision 1.36
+diff -u -r1.36 gpe-ownerinfo.c
+--- gpe-ownerinfo.c 4 Jul 2004 12:10:12 -0000 1.36
++++ gpe-ownerinfo.c 20 Dec 2004 16:32:21 -0000
+@@ -302,7 +302,7 @@
+ height /= PANGO_SCALE;
+
+ if (height < allocation->height)
+- height = allocation->height;
++ height = allocation->height + 20;
+
+ lost_height = height - allocation->height;
+
diff --git a/recipes/gpe-ownerinfo/gpe-ownerinfo/svn-build.patch b/recipes/gpe-ownerinfo/gpe-ownerinfo/svn-build.patch
new file mode 100644
index 0000000000..9c446edb94
--- /dev/null
+++ b/recipes/gpe-ownerinfo/gpe-ownerinfo/svn-build.patch
@@ -0,0 +1,238 @@
+--- gpe-ownerinfo.orig/Makefile 2007-04-08 02:00:43.064935587 +0300
++++ gpe-ownerinfo/Makefile 2007-04-08 02:01:24.703308411 +0300
+@@ -2,7 +2,7 @@
+ VERSION = 0.28
+ PREFIX = /usr/local
+ DEBUG = no
+-CVSBUILD = yes
++CVSBUILD = no
+ ENABLE_NLS = yes
+
+ LINGUAS = de hu id pt pt_BR fr zh_TW ro sv nl sk cs ru sr es zh_CN vi fi tr sl ko ja
++++ gpe-ownerinfo/build/Makefile.dpkg_ipkg 2007-02-10 17:21:40.154584782 +0200
+@@ -0,0 +1,114 @@
++## Please read the README in this directory to see how to use this
++## Makefile snippet
++
++# Let's use whatever clean target the specific app provides
++
++CONTROL = `if test -e familiar/control1; then echo control1; else echo control; fi`
++
++# URL to source tarball
++SOURCE = http://gpe.linuxtogo.org/download/source/$(PACKAGE)-$(VERSION).tar.gz
++
++# can change this to e.g. /var/tmp/deb
++DEB_PATH = ../deb
++
++ifeq ($(CVSBUILD),yes)
++LIBGPEWIDGET_PC = libgpewidget-uninstalled
++PC_EXTRA=PKG_CONFIG_PATH=../../base/libgpewidget
++else
++LIBGPEWIDGET_PC = libgpewidget
++endif
++
++ifeq ($(IN_LIBGPEWIDGET),)
++GPECFLAGS = $(shell $(PC_EXTRA) pkg-config --cflags $(LIBGPEWIDGET_PC))
++GPELIBS = $(shell $(PC_EXTRA) pkg-config --libs $(LIBGPEWIDGET_PC))
++endif
++
++GTKCFLAGS = $(shell pkg-config --cflags gtk+-2.0)
++GTKLIBS = $(shell pkg-config --libs gtk+-2.0)
++
++STANDARD_CPPFLAGS = -D_GNU_SOURCE -DPACKAGE=\"$(PACKAGE)\" -DPREFIX=\"$(PREFIX)\" -DPACKAGE_LOCALE_DIR=\"$(PREFIX)/share/locale\"
++STANDARD_CFLAGS = -MD -Wall
++
++ifeq ($(DEBUG),yes)
++CFLAGS += -O2 -g
++LDFLAGS = -g
++else
++CFLAGS += -Os -fomit-frame-pointer
++endif
++
++dist: check-source clean dist-prep
++ rm -rf ../$(PACKAGE)-$(VERSION)
++ mkdir ../$(PACKAGE)-$(VERSION)
++ ( tar cf - --exclude "*/CVS" --exclude CVS --exclude "*~" --exclude "#*#" --exclude "debian" --exclude ".*" --exclude "*.ipk" --exclude "*.ipk.*" --exclude "*.mo" --exclude "*.batch" --exclude "translation-ipkgs.txt" * ) | (cd ../$(PACKAGE)-$(VERSION); tar xf -)
++ ( if [ -f linguas ]; then LINGUAS=`cat linguas`; PATCH_LINGUAS="s:^LINGUAS =.*:LINGUAS = $${LINGUAS}:"; fi; cd ../$(PACKAGE)-$(VERSION) && mkdir build && cp $(BUILD)/Makefile.dpkg_ipkg $(BUILD)/Makefile.translation build/ && sed "s:^CVSBUILD =.*:CVSBUILD = no:;s:^DEBUG =.*:DEBUG = no:;s:Makefile.translation-auto-linguas:Makefile.translation:;$${PATCH_LINGUAS}" < Makefile > Makefile.new && mv Makefile.new Makefile )
++ ( cd .. ; tar cf - $(PACKAGE)-$(VERSION) | gzip -9 >$(PACKAGE)-$(VERSION).tar.gz )
++ rm -rf ../$(PACKAGE)-$(VERSION)
++ $(MAKE) printinfo
++
++dist-upload: dist
++ scp ../$(PACKAGE)-$(VERSION).tar.gz $(USER)@linuxtogo.org:/media/data/projects/gpe/source/
++
++dist-prep:
++ipkg-prep:
++install-mo:
++# empty, can be filled in Makefile.translation
++
++install: install-program install-mo
++
++clean-dist:
++ rm -rf familiar/dist familiar/dist.list
++
++clean: clean-dist
++
++check-source:
++ @if [ -f familiar/$(CONTROL) ] && ! grep -q '^Source:' familiar/$(CONTROL); then echo -e "\nNo Source: field in control file. Aborting.\n"; exit 1; fi
++
++ipkg: check-source ipkg-prep clean
++ rm -rf familiar/dist
++ mkdir -p familiar/dist/CONTROL
++ sed 's:VERSION:$(VERSION):;s$$SOURCE$$$(SOURCE)$$' < familiar/$(CONTROL) > familiar/dist/CONTROL/control
++ if test -e familiar/conffiles; then install -m 644 familiar/conffiles familiar/dist/CONTROL; fi
++ if test -e familiar/preinst; then install familiar/preinst familiar/dist/CONTROL; fi
++ if test -e familiar/postinst; then install familiar/postinst familiar/dist/CONTROL; fi
++ if test -e familiar/prerm; then install familiar/prerm familiar/dist/CONTROL; fi
++ if test -e familiar/postrm; then install familiar/postrm familiar/dist/CONTROL; fi
++ $(MAKE) DESTDIR=`pwd`/familiar/dist PREFIX=/usr prefix=/usr DEBUG=no install-program
++ rm -rf familiar/dist.list
++ ipkg-build -o 0 -g 0 familiar/dist | sed 's/^Packaged .*into //; t 1; d; : 1; s:.*/::' >> familiar/dist.list
++ if [ "x$(LINGUAS)" != "x" ]; then make translation-ipkg; tr ' ' '\n' < translation-ipkgs.txt >> familiar/dist.list; fi
++ md5sum `cat familiar/dist.list` > $(PACKAGE)_$(VERSION).batch
++ rm -rf familiar/dist familiar/dist.list
++ $(MAKE) printinfo
++
++dpkg: dist
++ mkdir -p $(DEB_PATH)
++ ( olddir=`pwd`; cd $(DEB_PATH); rm -rf $(PACKAGE)-$(VERSION); ln -s $$olddir/../$(PACKAGE)-$(VERSION).tar.gz $(PACKAGE)_$(VERSION).orig.tar.gz ; tar xzf $(PACKAGE)_$(VERSION).orig.tar.gz )
++ mkdir -p $(DEB_PATH)/$(PACKAGE)-$(VERSION)/debian
++ for i in debian/*; do if test -f $$i; then cp $$i $(DEB_PATH)/$(PACKAGE)-$(VERSION)/debian/; fi; done
++
++CVSTAG := $(shell echo $(PACKAGE)-$(VERSION) | tr [a-z.] [A-Z_])
++printinfo:
++ @printf '-------------------------------------------------------------------------------\n'
++ @printf "If this becomes a package release, please add a CVS tag.\n"
++ @printf "You can use 'make tag' for that, it will execute\n"
++ @printf " cvs tag %s\n" $(CVSTAG)
++ @printf "Please upload a tarball (created with 'make dist') to\n"
++ @printf " ftp://ftp.handhelds.org/pub/projects/gpe/\n"
++ @printf " (handhelds.org:~ftp/pub/projects/gpe/source)\n"
++ @printf "You can use 'make dist-upload' to do that.\n"
++ @printf "You are currently known as USER %s.\n" $(USER)
++ @printf '-------------------------------------------------------------------------------\n'
++
++tag: check-source
++ cvs tag $(CVSTAG)
++
++retag: check-source
++ cvs tag -F $(CVSTAG)
++
++source: tag dist-upload
++
++%.pc: %.pc.in
++ sed 's:PREFIX:$(PREFIX):;s:BUILDDIR:$(shell pwd):;s:VERSION:$(VERSION):' < $< > $@
++
++.c.o:;
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(PACKAGE_CFLAGS) $(PACKAGE_CPPFLAGS) -c $< -o $@
+diff -Naur gpe-ownerinfo.orig/build/Makefile.translation gpe-ownerinfo/build/Makefile.translation
+--- gpe-ownerinfo.orig/build/Makefile.translation 1970-01-01 02:00:00.000000000 +0200
++++ gpe-ownerinfo/build/Makefile.translation 2007-02-10 17:21:46.170927636 +0200
+@@ -0,0 +1,107 @@
++.SUFFIXES: .mo .po .pot .po8
++
++CONTROL = `if test -e familiar/control1; then echo control1; else echo control; fi`
++
++# use ipkg-build or ipkg-deb-build
++IPKG_BUILD := ipkg-build
++
++TRANSLATION_SITE := http://www.iro.umontreal.ca/~gnutra/maint
++
++ifeq ($(DIR_PO),)
++DIR_PO := po
++endif
++
++ifeq ($(BINPACKAGE),)
++BINPACKAGE := $(PACKAGE)
++endif
++
++mo-files = $(patsubst %,$(DIR_PO)/%.mo,$(LINGUAS))
++po-files = $(patsubst %,$(DIR_PO)/%.po,$(LINGUAS))
++
++ifeq ($(shell if [ -f $(PACKAGE).desktop.in ]; then echo present; fi;),present)
++desktop-files += $(PACKAGE).desktop
++endif
++
++ifneq ($(EXTRA_DESKTOPS),)
++desktop-files += $(patsubst %.desktop.in,%.desktop,$(EXTRA_DESKTOPS))
++endif
++
++all-mo: $(mo-files)
++
++all-desktop: $(desktop-files)
++
++install-mo: all-mo
++ if [ "$(ENABLE_NLS)" != "no" ]; then \
++ if [ "x$(LINGUAS)" != "x" ]; then \
++ for i in $(LINGUAS); do mkdir -p $(DESTDIR)$(PREFIX)/share/locale/$$i/LC_MESSAGES; install -m 644 $(DIR_PO)/$$i.mo $(DESTDIR)$(PREFIX)/share/locale/$$i/LC_MESSAGES/$(PACKAGE).mo; done \
++ fi; \
++ fi;
++
++.po8.mo:;
++ if [ "$(ENABLE_NLS)" != "no" ]; then \
++ msgfmt -o $@ $<; \
++ fi;
++
++.po.po8:;
++ CTYPE=`grep "^\"Content-Type:" $< | sed 's/^.*charset=//;s/\\\\.*//'`; sed "s/\(Content-Type: .*=\)$$CTYPE/\1UTF-8/" < $< | iconv -f $${CTYPE} -t UTF-8 >$@
++
++update-po: $(po-files) extract-po
++
++dist-prep: update-po freshen-po
++# empty
++
++ifeq ($(CVSBUILD),yes)
++ipkg-prep: freshen-po
++# empty
++endif
++
++extract-po:
++ mkdir -p $(DIR_PO)
++ ( SOURCES="$(SOURCES)"; for DESK in $(PACKAGE).desktop.in $(EXTRA_DESKTOPS); do if [ -f $$DESK ]; then intltool-extract --type=gettext/ini $$DESK; SOURCES="$$SOURCES $${DESK}.h"; fi; done; if [ "x$$SOURCES" != "x" ]; then xgettext --add-comments=TRANSLATORS: -k_ -kN_ -o $(DIR_PO)/$(PACKAGE).pot.new $$SOURCES; fi )
++ if [ -f $(DIR_PO)/$(PACKAGE).pot.new ]; then if cmp -s $(DIR_PO)/$(PACKAGE).pot.new $(PACKAGE).pot; then rm $(DIR_PO)/$(PACKAGE).pot.new; else mv $(DIR_PO)/$(PACKAGE).pot.new $(DIR_PO)/$(PACKAGE).pot; fi; fi
++
++clean: clean-po clean-dist-translation
++
++clean-po:
++ rm -rf $(DIR_PO)/*.mo
++ for i in $(desktop-files); do if [ -f $$i.in ]; then rm -f $$i; rm -f $$i.in.h; fi; done
++
++%.desktop: %.desktop.in $(patsubst %,$(DIR_PO)/%.po,$(LINGUAS))
++ intltool-merge -u -d $(DIR_PO) $< $@
++
++freshen-po:
++ rm -rf tmp-po
++ mkdir tmp-po
++ cd tmp-po; for LANG in $(LINGUAS); do wget $(TRANSLATION_SITE)/$(PACKAGE)/$$LANG.po; done
++ for LANG in $(LINGUAS); do if [ ! -f $(DIR_PO)/$$LANG.po ] || ! cmp -s $(DIR_PO)/$$LANG.po tmp-po/$$LANG.po ; then mv tmp-po/$$LANG.po $(DIR_PO)/$$LANG.po; echo "Updated $$LANG translation"; fi; done
++ rm -rf tmp-po
++
++# ------------------------------------------------------------------------
++
++MAINTAINER = $(shell grep 'Maintainer: ' familiar/$(CONTROL) | cut -d ' ' -f 2-)
++
++ifndef BUILD
++BUILD = ../build
++endif
++
++transdist := familiar/dist-translation
++templates := $(BUILD)/familiar
++ipkglist := translation-ipkgs.txt
++
++clean-dist-translation:
++ rm -rf $(transdist) $(ipkglist)
++
++real-translation-package: all-mo
++ rm -rf $(transdist) $(ipkglist)
++ for LINGUA in $(LINGUAS); do \
++ i=$$(echo $$LINGUA | tr '[A-Z_]' '[a-z+]'); \
++ mkdir -p $(transdist)/$$i/CONTROL; \
++ mkdir -p $(transdist)/$$i$(PREFIX)/share/locale/$$LINGUA/LC_MESSAGES; \
++ install -m 644 po/$$LINGUA.mo $(transdist)/$$i$(PREFIX)/share/locale/$$LINGUA/LC_MESSAGES/$(PACKAGE).mo; \
++ sed -e "s/<maintainer>/$(MAINTAINER)/;s/<package>/$(BINPACKAGE)/;s/<version>/$(VERSION)/;s/<language>/$$i/;s!<source>!$(SOURCE)!" $(templates)/control.translation > $(transdist)/$$i/CONTROL/control; \
++ install $(templates)/postinst.translation $(transdist)/$$i/CONTROL/postinst; \
++ $(IPKG_BUILD) -g 0 -o 0 $(transdist)/$$i | sed 's/^Packaged .*into //; t 1; d; : 1; s:.*/::' >> $(ipkglist); \
++ done
++
++translation-ipkg:
++ make PREFIX=/usr real-translation-package
diff --git a/recipes/gpe-ownerinfo/gpe-ownerinfo_0.23.bb b/recipes/gpe-ownerinfo/gpe-ownerinfo_0.23.bb
new file mode 100644
index 0000000000..c5d8184cbf
--- /dev/null
+++ b/recipes/gpe-ownerinfo/gpe-ownerinfo_0.23.bb
@@ -0,0 +1,3 @@
+require gpe-ownerinfo.inc
+
+PR = "r1"
diff --git a/recipes/gpe-ownerinfo/gpe-ownerinfo_0.24.bb b/recipes/gpe-ownerinfo/gpe-ownerinfo_0.24.bb
new file mode 100644
index 0000000000..e63a6172a2
--- /dev/null
+++ b/recipes/gpe-ownerinfo/gpe-ownerinfo_0.24.bb
@@ -0,0 +1,5 @@
+require gpe-ownerinfo.inc
+
+PR = "r2"
+
+SRC_URI += "file://fixloop.patch;patch=1;pnum=0"
diff --git a/recipes/gpe-ownerinfo/gpe-ownerinfo_0.25.bb b/recipes/gpe-ownerinfo/gpe-ownerinfo_0.25.bb
new file mode 100644
index 0000000000..e7ef651bc4
--- /dev/null
+++ b/recipes/gpe-ownerinfo/gpe-ownerinfo_0.25.bb
@@ -0,0 +1,3 @@
+require gpe-ownerinfo.inc
+
+PR = "r0"
diff --git a/recipes/gpe-ownerinfo/gpe-ownerinfo_0.26.bb b/recipes/gpe-ownerinfo/gpe-ownerinfo_0.26.bb
new file mode 100644
index 0000000000..e7ef651bc4
--- /dev/null
+++ b/recipes/gpe-ownerinfo/gpe-ownerinfo_0.26.bb
@@ -0,0 +1,3 @@
+require gpe-ownerinfo.inc
+
+PR = "r0"
diff --git a/recipes/gpe-ownerinfo/gpe-ownerinfo_0.27.bb b/recipes/gpe-ownerinfo/gpe-ownerinfo_0.27.bb
new file mode 100644
index 0000000000..e7ef651bc4
--- /dev/null
+++ b/recipes/gpe-ownerinfo/gpe-ownerinfo_0.27.bb
@@ -0,0 +1,3 @@
+require gpe-ownerinfo.inc
+
+PR = "r0"
diff --git a/recipes/gpe-ownerinfo/gpe-ownerinfo_0.28.bb b/recipes/gpe-ownerinfo/gpe-ownerinfo_0.28.bb
new file mode 100644
index 0000000000..6ce0f8fbf7
--- /dev/null
+++ b/recipes/gpe-ownerinfo/gpe-ownerinfo_0.28.bb
@@ -0,0 +1,5 @@
+require gpe-ownerinfo.inc
+
+PR = "r2"
+
+SRC_URI += "file://compile.patch;patch=1"
diff --git a/recipes/gpe-ownerinfo/gpe-ownerinfo_svn.bb b/recipes/gpe-ownerinfo/gpe-ownerinfo_svn.bb
new file mode 100644
index 0000000000..036f70eaf1
--- /dev/null
+++ b/recipes/gpe-ownerinfo/gpe-ownerinfo_svn.bb
@@ -0,0 +1,11 @@
+require gpe-ownerinfo.inc
+
+PR = "r1"
+PV = "0.28+svn-${SRCDATE}"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI += "${GPE_SVN} \
+ file://svn-build.patch;patch=1"
+
+S = "${WORKDIR}/${PN}"