aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpe-themes
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gpe-themes
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gpe-themes')
-rw-r--r--recipes/gpe-themes/gpe-theme-clearlooks_0.2.bb17
-rw-r--r--recipes/gpe-themes/gpe-theme-clearlooks_0.3.bb16
-rw-r--r--recipes/gpe-themes/gpe-theme-e17_0.1.bb16
-rw-r--r--recipes/gpe-themes/gpe-theme-foxbox_0.1.bb13
-rw-r--r--recipes/gpe-themes/gpe-theme-industrial_0.1.bb17
-rw-r--r--recipes/gpe-themes/gpe-theme-industrial_0.2.bb16
6 files changed, 95 insertions, 0 deletions
diff --git a/recipes/gpe-themes/gpe-theme-clearlooks_0.2.bb b/recipes/gpe-themes/gpe-theme-clearlooks_0.2.bb
new file mode 100644
index 0000000000..da61845f4d
--- /dev/null
+++ b/recipes/gpe-themes/gpe-theme-clearlooks_0.2.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "GTK+ clearlooks theme adjusted for GPE"
+LICENSE = "GPL"
+PR = "r1"
+
+#it doesn't really depends on it, but it's nice to make OE build it
+DEPENDS = "gtk-engines"
+RDEPENDS = "gtk-engine-clearlooks"
+
+FILES_${PN} = "${datadir}/themes/"
+SRC_URI = "http://dominion.thruhere.net/koen/pda/files/${P}.tar.gz"
+
+do_install() {
+install -d ${D}${datadir}/themes/
+cp -PpR ${WORKDIR}/Clearlooks ${D}${datadir}/themes/
+}
+
+
diff --git a/recipes/gpe-themes/gpe-theme-clearlooks_0.3.bb b/recipes/gpe-themes/gpe-theme-clearlooks_0.3.bb
new file mode 100644
index 0000000000..33712c70ee
--- /dev/null
+++ b/recipes/gpe-themes/gpe-theme-clearlooks_0.3.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "GTK+ clearlooks theme adjusted for GPE"
+LICENSE = "GPL"
+
+#it doesn't really depends on it, but it's nice to make OE build it
+DEPENDS = "gtk-engines"
+RDEPENDS = "gtk-engine-clearlooks"
+
+FILES_${PN} = "${datadir}/themes/"
+SRC_URI = "http://dominion.thruhere.net/koen/pda/files/${P}.tar.gz"
+
+do_install() {
+install -d ${D}${datadir}/themes/
+cp -PpR ${WORKDIR}/Clearlooks ${D}${datadir}/themes/
+}
+
+
diff --git a/recipes/gpe-themes/gpe-theme-e17_0.1.bb b/recipes/gpe-themes/gpe-theme-e17_0.1.bb
new file mode 100644
index 0000000000..a6d36a5ac0
--- /dev/null
+++ b/recipes/gpe-themes/gpe-theme-e17_0.1.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "GTK+ enlightenment theme adjusted for GPE"
+LICENSE = "MIT + GPL"
+PR = "r0"
+
+#it doesn't really depends on it, but it's nice to make OE build it
+RDEPENDS = "gtk+"
+
+FILES_${PN} = "${datadir}/themes/"
+SRC_URI = "http://linuxtogo.org/~koen/gpe/themes/${P}.tar.gz"
+
+do_install() {
+install -d ${D}${datadir}/themes/
+cp -R ${WORKDIR}/usr/share/themes/e17-bling/ ${D}${datadir}/themes/
+}
+
+
diff --git a/recipes/gpe-themes/gpe-theme-foxbox_0.1.bb b/recipes/gpe-themes/gpe-theme-foxbox_0.1.bb
new file mode 100644
index 0000000000..c2b829ab74
--- /dev/null
+++ b/recipes/gpe-themes/gpe-theme-foxbox_0.1.bb
@@ -0,0 +1,13 @@
+inherit gpe
+
+LICENSE = "gpe-theme-foxbox"
+PR = "r2"
+SECTION = "x11/base"
+DESCRIPTION = "Simple GPE theme using the Smooth theming engine."
+DEPENDS = "gtk-engines"
+RDEPENDS = "gtk-engine-smooth"
+S = "${WORKDIR}/foxbox"
+
+FILES_${PN} = "${datadir}/themes"
+
+SRC_URI = "http://linuxtogo.org/~florian/themes/foxbox-${PV}.tar.gz"
diff --git a/recipes/gpe-themes/gpe-theme-industrial_0.1.bb b/recipes/gpe-themes/gpe-theme-industrial_0.1.bb
new file mode 100644
index 0000000000..c0322948e4
--- /dev/null
+++ b/recipes/gpe-themes/gpe-theme-industrial_0.1.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "GTK+ industrial theme adjusted for GPE"
+LICENSE = "GPL"
+PR = "r0"
+
+#it doesn't really depends on it, but it's nice to make OE build it
+DEPENDS = "gtk-engines"
+RDEPENDS = "gtk-engine-industrial"
+
+FILES_${PN} = "${datadir}/themes/"
+SRC_URI = "http://dominion.thruhere.net/koen/pda/files/${P}.tar.gz"
+
+do_install() {
+install -d ${D}${datadir}/themes/
+cp -R ${WORKDIR}/Industrial ${D}${datadir}/themes/
+}
+
+
diff --git a/recipes/gpe-themes/gpe-theme-industrial_0.2.bb b/recipes/gpe-themes/gpe-theme-industrial_0.2.bb
new file mode 100644
index 0000000000..c1cd5ca41d
--- /dev/null
+++ b/recipes/gpe-themes/gpe-theme-industrial_0.2.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "GTK+ industrial theme adjusted for GPE"
+LICENSE = "GPL"
+
+#it doesn't really depends on it, but it's nice to make OE build it
+DEPENDS = "gtk-engines"
+RDEPENDS = "gtk-engine-industrial"
+
+FILES_${PN} = "${datadir}/themes/"
+SRC_URI = "http://dominion.thruhere.net/koen/pda/files/${P}.tar.gz"
+
+do_install() {
+install -d ${D}${datadir}/themes/
+cp -R ${WORKDIR}/Industrial ${D}${datadir}/themes/
+}
+
+