aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpe-what
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gpe-what
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gpe-what')
-rw-r--r--recipes/gpe-what/gpe-what-0.33/makefile-fix.patch21
-rw-r--r--recipes/gpe-what/gpe-what-0.43/set-wm-hint.patch12
-rw-r--r--recipes/gpe-what/gpe-what.inc8
-rw-r--r--recipes/gpe-what/gpe-what_0.30.bb5
-rw-r--r--recipes/gpe-what/gpe-what_0.31.bb3
-rw-r--r--recipes/gpe-what/gpe-what_0.33.bb5
-rw-r--r--recipes/gpe-what/gpe-what_0.41.bb1
-rw-r--r--recipes/gpe-what/gpe-what_0.42.bb1
-rw-r--r--recipes/gpe-what/gpe-what_0.43.bb5
-rw-r--r--recipes/gpe-what/gpe-what_svn.bb9
10 files changed, 70 insertions, 0 deletions
diff --git a/recipes/gpe-what/gpe-what-0.33/makefile-fix.patch b/recipes/gpe-what/gpe-what-0.33/makefile-fix.patch
new file mode 100644
index 0000000000..3e48d63465
--- /dev/null
+++ b/recipes/gpe-what/gpe-what-0.33/makefile-fix.patch
@@ -0,0 +1,21 @@
+--- gpe-what-0.33/Makefile.orig 2005-11-03 21:41:33 +0100
++++ gpe-what-0.33/Makefile 2005-11-03 21:45:10 +0100
+@@ -6,16 +6,14 @@
+
+ MEMBERS = gpe-what mbtray
+
+-PACKAGE_CFLAGS += $(STANDARD_CFLAGS) $(GTKCFLAGS)
+-PACKAGE_LDFLAGS += $(GTKLDFLAGS)
++PACKAGE_CFLAGS += $(STANDARD_CFLAGS) $(GTKCFLAGS) `pkg-config --cflags libmb`
++PACKAGE_LDFLAGS += $(GTKLDFLAGS) `pkg-config --libs libmb`
+ PACKAGE_CPPFLAGS += -DPACKAGE=\"$(PACKAGE)\" -DPREFIX=\"$(PREFIX)\" -DPACKAGE_LOCALE_DIR=\"$(PREFIX)/share/locale\"
+
+ OBJS = $(patsubst %,%.o,$(MEMBERS))
+ DEPS = $(patsubst %,%.d,$(MEMBERS))
+ SOURCES = $(patsubst %,%.c,$(MEMBERS))
+
+-PACKAGE_LDFLAGS += -lmb
+-
+ ifeq ($(CVSBUILD),yes)
+ BUILD = ../build
+ else
diff --git a/recipes/gpe-what/gpe-what-0.43/set-wm-hint.patch b/recipes/gpe-what/gpe-what-0.43/set-wm-hint.patch
new file mode 100644
index 0000000000..1300635197
--- /dev/null
+++ b/recipes/gpe-what/gpe-what-0.43/set-wm-hint.patch
@@ -0,0 +1,12 @@
+Index: gpe-what.c
+===================================================================
+--- gpe-what.c (Revision 8874)
++++ gpe-what.c (Arbeitskopie)
+@@ -233,6 +233,7 @@
+
+ gtk_window_set_default_size (GTK_WINDOW (popup), width, height);
+ gtk_window_set_decorated (GTK_WINDOW (popup), FALSE);
++ gtk_window_set_type_hint (GTK_WINDOW (popup), GDK_WINDOW_TYPE_HINT_MENU);
+ gtk_label_set_line_wrap (GTK_LABEL (label), TRUE);
+ gtk_container_set_border_width (GTK_CONTAINER (box), spacing);
+
diff --git a/recipes/gpe-what/gpe-what.inc b/recipes/gpe-what/gpe-what.inc
new file mode 100644
index 0000000000..fd4307631e
--- /dev/null
+++ b/recipes/gpe-what/gpe-what.inc
@@ -0,0 +1,8 @@
+DESCRIPTION = "GPE modal help"
+SECTION = "gpe"
+LICENSE = "GPL"
+DEPENDS = "virtual/libx11 gtk+"
+
+inherit autotools gpe
+
+GPE_TARBALL_SUFFIX= "bz2"
diff --git a/recipes/gpe-what/gpe-what_0.30.bb b/recipes/gpe-what/gpe-what_0.30.bb
new file mode 100644
index 0000000000..165ea4cc3b
--- /dev/null
+++ b/recipes/gpe-what/gpe-what_0.30.bb
@@ -0,0 +1,5 @@
+require gpe-what.inc
+
+do_compile_prepend() {
+ rm *.d
+}
diff --git a/recipes/gpe-what/gpe-what_0.31.bb b/recipes/gpe-what/gpe-what_0.31.bb
new file mode 100644
index 0000000000..50a614bdd2
--- /dev/null
+++ b/recipes/gpe-what/gpe-what_0.31.bb
@@ -0,0 +1,3 @@
+require gpe-what.inc
+
+DEPENDS = "virtual/libx11 libxpm libmatchbox"
diff --git a/recipes/gpe-what/gpe-what_0.33.bb b/recipes/gpe-what/gpe-what_0.33.bb
new file mode 100644
index 0000000000..71ae7dac95
--- /dev/null
+++ b/recipes/gpe-what/gpe-what_0.33.bb
@@ -0,0 +1,5 @@
+require gpe-what.inc
+
+SRC_URI += "file://makefile-fix.patch;patch=1"
+
+DEPENDS = "virtual/libx11 libxpm libmatchbox"
diff --git a/recipes/gpe-what/gpe-what_0.41.bb b/recipes/gpe-what/gpe-what_0.41.bb
new file mode 100644
index 0000000000..853abec8aa
--- /dev/null
+++ b/recipes/gpe-what/gpe-what_0.41.bb
@@ -0,0 +1 @@
+require gpe-what.inc
diff --git a/recipes/gpe-what/gpe-what_0.42.bb b/recipes/gpe-what/gpe-what_0.42.bb
new file mode 100644
index 0000000000..853abec8aa
--- /dev/null
+++ b/recipes/gpe-what/gpe-what_0.42.bb
@@ -0,0 +1 @@
+require gpe-what.inc
diff --git a/recipes/gpe-what/gpe-what_0.43.bb b/recipes/gpe-what/gpe-what_0.43.bb
new file mode 100644
index 0000000000..624f2e365e
--- /dev/null
+++ b/recipes/gpe-what/gpe-what_0.43.bb
@@ -0,0 +1,5 @@
+require gpe-what.inc
+
+PR = "r1"
+
+SRC_URI += " file://set-wm-hint.patch;patch=1;pnum=0"
diff --git a/recipes/gpe-what/gpe-what_svn.bb b/recipes/gpe-what/gpe-what_svn.bb
new file mode 100644
index 0000000000..c448751096
--- /dev/null
+++ b/recipes/gpe-what/gpe-what_svn.bb
@@ -0,0 +1,9 @@
+require gpe-what.inc
+
+PV = "0.41+svn${SRCDATE}"
+
+SRC_URI = "${GPE_SVN}"
+
+S = "${WORKDIR}/${PN}"
+
+DEFAULT_PREFERENCE = "-1"