summaryrefslogtreecommitdiffstats
path: root/recipes/gpsd/gpsd.inc
diff options
context:
space:
mode:
authorGraham Gower <graham.gower@gmail.com>2010-09-01 16:08:26 +0000
committerKhem Raj <raj.khem@gmail.com>2010-09-01 20:57:08 -0700
commit1d48a1c15d20e40e3479d7b09dc3ef1325a9f7ea (patch)
tree984c63024f196c2494952ab28f48407a2a66efc6 /recipes/gpsd/gpsd.inc
parent0f08f4a52c7db1514941c3925933d990767e8e85 (diff)
downloadopenembedded-1d48a1c15d20e40e3479d7b09dc3ef1325a9f7ea.tar.gz
gpsd: unbreak gpsd_2.38.bb and gpsd_2.39.bb
The older recipe(s) are needed for programs which have not updated to gpsd's newer api. e.g. prismstumbler. Signed-off-by: Graham Gower <graham.gower@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/gpsd/gpsd.inc')
-rw-r--r--recipes/gpsd/gpsd.inc5
1 files changed, 2 insertions, 3 deletions
diff --git a/recipes/gpsd/gpsd.inc b/recipes/gpsd/gpsd.inc
index 63d6433fd8..23335f00f4 100644
--- a/recipes/gpsd/gpsd.inc
+++ b/recipes/gpsd/gpsd.inc
@@ -4,7 +4,7 @@ PRIORITY = "optional"
LICENSE = "GPL"
DEPENDS = "dbus-glib ncurses python"
PROVIDES = "virtual/gpsd"
-INC_PR = "r9"
+INC_PR = "r10"
EXTRA_OECONF = "--x-includes=${STAGING_INCDIR}/X11 \
--x-libraries=${STAGING_LIBDIR} \
@@ -49,14 +49,13 @@ do_install_append() {
install -m 0644 ${WORKDIR}/60-gpsd.rules ${D}/${sysconfdir}/udev/rules.d
install -d ${D}${base_libdir}/udev/
install -m 0755 ${S}/gpsd.hotplug ${D}${base_libdir}/udev/
- install -m 0755 ${S}/gpsd.hotplug.wrapper ${D}${base_libdir}/udev/
}
pkg_postinst_${PN}-conf() {
update-alternatives --install ${sysconfdir}/default/gpsd gpsd-defaults ${sysconfdir}/default/gpsd.default 10
}
-pkg_postrm_${PN}-conf() {
+pkg_postrm_${PN}-conf() {
update-alternatives --remove gpsd-defaults ${sysconfdir}/default/gpsd.default
}