aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/grep/grep_2.7.bb
diff options
context:
space:
mode:
authorScott Garman <sgarman@zenlinux.com>2010-09-28 06:42:15 +0000
committerKhem Raj <raj.khem@gmail.com>2010-09-30 13:15:07 -0700
commit6ccae1e558a51eb919a59b19e480742b88f1224e (patch)
tree118bd585b9652726cb41028b55b784607c143bd2 /recipes/grep/grep_2.7.bb
parent35686bb67b5431e8ff0c2743653279a5e94fffa8 (diff)
downloadopenembedded-6ccae1e558a51eb919a59b19e480742b88f1224e.tar.gz
grep: update 2.6.3 to 2.7
Signed-off-by: Scott Garman <sgarman@zenlinux.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/grep/grep_2.7.bb')
-rw-r--r--recipes/grep/grep_2.7.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes/grep/grep_2.7.bb b/recipes/grep/grep_2.7.bb
new file mode 100644
index 0000000000..6267162ce0
--- /dev/null
+++ b/recipes/grep/grep_2.7.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "grep GNU utility"
+SECTION = "console/utils"
+HOMEPAGE = "http://savannah.gnu.org/projects/grep/"
+LICENSE = "GPLv3"
+
+PR = "r0"
+
+SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.gz \
+ file://uclibc_libiconv.patch"
+
+SRC_URI[md5sum] = "e848f07e3e79aa7899345d17c7e4115e"
+SRC_URI[sha256sum] = "ad14831015a79cea36785aa47415f6c0653a6ac4eaf9c15456f0d9d09c9e1bad"
+
+inherit autotools gettext
+
+BBCLASSEXTEND = "native"
+
+EXTRA_OECONF = "--disable-perl-regexp"
+
+do_configure_prepend () {
+ rm -f ${S}/m4/init.m4
+}
+
+do_install () {
+ autotools_do_install
+ install -d ${D}${base_bindir}
+ mv ${D}${bindir}/grep ${D}${base_bindir}/grep.${PN}
+ mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep.${PN}
+ mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep.${PN}
+}
+
+pkg_postinst_${PN} () {
+ update-alternatives --install ${base_bindir}/grep grep grep.${PN} 100
+ update-alternatives --install ${base_bindir}/egrep egrep egrep.${PN} 100
+ update-alternatives --install ${base_bindir}/fgrep fgrep fgrep.${PN} 100
+}
+
+pkg_prerm_${PN} () {
+ update-alternatives --remove grep grep.${PN}
+ update-alternatives --remove egrep egrep.${PN}
+ update-alternatives --remove fgrep fgrep.${PN}
+}