aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gs/gs_8.16.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gs/gs_8.16.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gs/gs_8.16.bb')
-rw-r--r--recipes/gs/gs_8.16.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/gs/gs_8.16.bb b/recipes/gs/gs_8.16.bb
new file mode 100644
index 0000000000..cf1e8ba411
--- /dev/null
+++ b/recipes/gs/gs_8.16.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "An interpreter of the Postscript language"
+LICENSE = "GPL"
+SECTION = "console/utils"
+HOMEPAGE = "http://www.gnu.org/software/ghostscript/ghostscript.html"
+DEPENDS = "jpeg zlib"
+PR = "r0"
+
+SRC_URI = "${GNU_MIRROR}/ghostscript/gnu-ghostscript-${PV}.tar.gz"
+S = "${WORKDIR}/gnu-ghostscript-${PV}"
+
+inherit autotools flow-lossage
+
+EXTRA_OECONF = "--without-x"
+
+do_configure() {
+ gnu-configize
+ oe_runconf
+}
+
+do_compile() {
+ oe_runmake CCAUX="${BUILD_CC}"
+}
+
+do_install() {
+ oe_runmake bindir='${D}${bindir}' datadir='${D}${datadir}' libdir='${D}${libdir}' install
+}
+
+FILES_${PN} += "${datadir}/ghostscript"