aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gsoap
diff options
context:
space:
mode:
authorJan Paesmans <jan.paesmans@gmail.com>2009-12-21 23:05:29 +0000
committerKhem Raj <raj.khem@gmail.com>2010-01-21 16:22:56 -0800
commit5cc04010e70378484efe549b30b411f840e825f5 (patch)
treeef1d70998431af2b82cd953b0647c834836c3321 /recipes/gsoap
parent310b2cd8919a13280b445537893c109b66c5275c (diff)
downloadopenembedded-5cc04010e70378484efe549b30b411f840e825f5.tar.gz
gSOAP
Hello, In the gSOAP package I noticed the following patch was applied to the native build: use-just-built-binary.patch This patches the makefiles of gSOAP so that the correct executable is used. However the problem originates from the fact that the makefile variable $(SOAP) is overridden in gsoap_${PV}.bb with the following directive: EXTRA_OEMAKE = "SOAP=${STAGING_BINDIR_NATIVE}/soapcpp2" Instead of patching the makefiles of gsoap, I've come up with a simpler solution. In the gsoap-native_*.bb files, overwrite EXTRA_OEMAKE like so: EXTRA_OEMAKE = "" This removes the problem with building gsoap natively and not using the correct executable. Please find my patch in attachment. Regards, Jan Signed-off-by: Jan Paesmans <jan.paesmans@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/gsoap')
-rw-r--r--recipes/gsoap/gsoap-native/use-just-built-binary-2.7.13.patch12
-rw-r--r--recipes/gsoap/gsoap-native/use-just-built-binary.patch19
-rw-r--r--recipes/gsoap/gsoap-native_2.7.13.bb2
-rw-r--r--recipes/gsoap/gsoap-native_2.7.7.bb2
4 files changed, 2 insertions, 33 deletions
diff --git a/recipes/gsoap/gsoap-native/use-just-built-binary-2.7.13.patch b/recipes/gsoap/gsoap-native/use-just-built-binary-2.7.13.patch
deleted file mode 100644
index 25a8ef0db1..0000000000
--- a/recipes/gsoap/gsoap-native/use-just-built-binary-2.7.13.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urN gsoap-2.7.orig/gsoap/wsdl/Makefile.am gsoap-2.7.orig/gsoap/wsdl/Makefile.am
---- gsoap-2.7.orig/gsoap/wsdl/Makefile.am 2009-03-21 22:24:42.000000000 +0100
-+++ gsoap-2.7.orig/gsoap/wsdl/Makefile.am 2009-04-07 11:30:50.000000000 +0200
-@@ -17,7 +17,7 @@ BUILT_SOURCES=$(SOAP_CPP_SRC)
- # WSDL2H_EXTRA_LIBS=-lssl -lcrypto -lz # defined in configure.in
-
- $(SOAP_CPP_SRC) : $(SOAPHEADER)
-- $(SOAP) $(SOAP_FLAGS) $(SOAPHEADER)
-+ ../src/soapcpp2 $(SOAP_FLAGS) $(SOAPHEADER)
-
- #LIBS=
-
diff --git a/recipes/gsoap/gsoap-native/use-just-built-binary.patch b/recipes/gsoap/gsoap-native/use-just-built-binary.patch
deleted file mode 100644
index f7e4811f9e..0000000000
--- a/recipes/gsoap/gsoap-native/use-just-built-binary.patch
+++ /dev/null
@@ -1,19 +0,0 @@
----
- soapcpp2/wsdl/Makefile.am | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- gsoap-2.7.orig/soapcpp2/wsdl/Makefile.am
-+++ gsoap-2.7/soapcpp2/wsdl/Makefile.am
-@@ -13,11 +13,11 @@ SOAP_CPP_SRC=wsdlC.cpp
- SOAPHEADER=wsdl.h
- SOAP_FLAGS=-SC -pwsdl
- BUILT_SOURCES=$(SOAP_CPP_SRC)
-
- $(SOAP_CPP_SRC) : $(SOAPHEADER)
-- $(SOAP) $(SOAP_FLAGS) $(SOAPHEADER)
-+ ../src/soapcpp2 $(SOAP_FLAGS) $(SOAPHEADER)
-
- #LIBS=
-
- bin_PROGRAMS=wsdl2h
-
diff --git a/recipes/gsoap/gsoap-native_2.7.13.bb b/recipes/gsoap/gsoap-native_2.7.13.bb
index 3ed78d0227..f0370beb2b 100644
--- a/recipes/gsoap/gsoap-native_2.7.13.bb
+++ b/recipes/gsoap/gsoap-native_2.7.13.bb
@@ -2,7 +2,7 @@ require gsoap_${PV}.inc
DEPENDS = ""
-SRC_URI += "file://use-just-built-binary-2.7.13.patch;patch=1"
+EXTRA_OEMAKE = ""
inherit native
diff --git a/recipes/gsoap/gsoap-native_2.7.7.bb b/recipes/gsoap/gsoap-native_2.7.7.bb
index 206208d329..0b8a4b8a5c 100644
--- a/recipes/gsoap/gsoap-native_2.7.7.bb
+++ b/recipes/gsoap/gsoap-native_2.7.7.bb
@@ -3,7 +3,7 @@ require gsoap_${PV}.bb
DEPENDS = ""
PR = "r1"
-SRC_URI += "file://use-just-built-binary.patch;patch=1"
+EXTRA_OEMAKE = ""
inherit native