aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gsoap
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gsoap
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gsoap')
-rw-r--r--recipes/gsoap/gsoap-native/use-just-built-binary.patch19
-rw-r--r--recipes/gsoap/gsoap-native_2.7.7.bb16
-rw-r--r--recipes/gsoap/gsoap_2.7.7.bb26
3 files changed, 61 insertions, 0 deletions
diff --git a/recipes/gsoap/gsoap-native/use-just-built-binary.patch b/recipes/gsoap/gsoap-native/use-just-built-binary.patch
new file mode 100644
index 0000000000..f7e4811f9e
--- /dev/null
+++ b/recipes/gsoap/gsoap-native/use-just-built-binary.patch
@@ -0,0 +1,19 @@
+---
+ soapcpp2/wsdl/Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- gsoap-2.7.orig/soapcpp2/wsdl/Makefile.am
++++ gsoap-2.7/soapcpp2/wsdl/Makefile.am
+@@ -13,11 +13,11 @@ SOAP_CPP_SRC=wsdlC.cpp
+ SOAPHEADER=wsdl.h
+ SOAP_FLAGS=-SC -pwsdl
+ BUILT_SOURCES=$(SOAP_CPP_SRC)
+
+ $(SOAP_CPP_SRC) : $(SOAPHEADER)
+- $(SOAP) $(SOAP_FLAGS) $(SOAPHEADER)
++ ../src/soapcpp2 $(SOAP_FLAGS) $(SOAPHEADER)
+
+ #LIBS=
+
+ bin_PROGRAMS=wsdl2h
+
diff --git a/recipes/gsoap/gsoap-native_2.7.7.bb b/recipes/gsoap/gsoap-native_2.7.7.bb
new file mode 100644
index 0000000000..206208d329
--- /dev/null
+++ b/recipes/gsoap/gsoap-native_2.7.7.bb
@@ -0,0 +1,16 @@
+require gsoap_${PV}.bb
+
+DEPENDS = ""
+PR = "r1"
+
+SRC_URI += "file://use-just-built-binary.patch;patch=1"
+
+inherit native
+
+do_stage() {
+ autotools_stage_all
+}
+
+do_install() {
+ :
+}
diff --git a/recipes/gsoap/gsoap_2.7.7.bb b/recipes/gsoap/gsoap_2.7.7.bb
new file mode 100644
index 0000000000..dc6ff6e320
--- /dev/null
+++ b/recipes/gsoap/gsoap_2.7.7.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "The gSOAP toolkit provides a unique SOAP-to-C/C++ language binding \
+for the development of SOAP Web Services and clients."
+SECTION = "devel"
+LICENSE = "GPL"
+DEPENDS = "gsoap-native"
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/gsoap2/gsoap_${PV}.tar.gz"
+S = "${WORKDIR}/gsoap-2.7"
+
+inherit autotools
+
+PARALLEL_MAKE = ""
+
+EXTRA_OEMAKE = "SOAP=${STAGING_BINDIR_NATIVE}/soapcpp2"
+
+do_install_append() {
+ install -d ${D}${libdir}
+ for lib in libgsoapssl libgsoapssl++ libgsoap libgsoapck++ libgsoap++ libgsoapck
+ do
+ oe_libinstall -C soapcpp2 $lib ${D}${libdir}
+ done
+}
+
+PACKAGES = "${PN}-dbg ${PN}-dev ${PN} ${PN}-doc ${PN}-locale"
+FILES_gsoap-dev = "${bindir}/wsdl2h ${bindir}/soapcpp2 ${libdir}"