aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gstreamer/gst-plugin-pulse_0.9.7.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gstreamer/gst-plugin-pulse_0.9.7.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gstreamer/gst-plugin-pulse_0.9.7.bb')
-rw-r--r--recipes/gstreamer/gst-plugin-pulse_0.9.7.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/gstreamer/gst-plugin-pulse_0.9.7.bb b/recipes/gstreamer/gst-plugin-pulse_0.9.7.bb
new file mode 100644
index 0000000000..cfa200ef3d
--- /dev/null
+++ b/recipes/gstreamer/gst-plugin-pulse_0.9.7.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "GStreamer plugin for using pulse audio as sink and source"
+HOMEPAGE = "http://0pointer.de/lennart/projects/gst-pulse/"
+LICENSE = "GPL"
+DEPENDS = "gstreamer pulseaudio gst-plugins-base"
+PR = "r1"
+
+SRC_URI = "http://0pointer.de/lennart/projects/gst-pulse/gst-pulse-${PV}.tar.gz \
+ file://dont-overload-pulseaudio.patch;patch=1"
+S = "${WORKDIR}/gst-pulse-${PV}"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-lynx"
+GST_LIBV = 0.10
+
+do_install() {
+ install -d ${D}${libdir}/gstreamer-${GST_LIBV}/
+ install -m 0755 src/.libs/libgstpulse.so ${D}${libdir}/gstreamer-${GST_LIBV}
+}
+
+export GST_MODDIR=${libdir}/gstreamer-0.10
+
+FILES_${PN} = "${libdir}/gstreamer-0.10/libgstpulse.so"
+FILES_${PN}-dev = "\
+ ${libdir}/gstreamer-0.10/libgstpulse.a \
+ ${libdir}/gstreamer-0.10/libgstpulse.la \
+ ${libdir}/gstreamer-0.10/libgstpulse.so*"
+FILES_${PN}-dbg += "${libdir}/gstreamer-0.10/.debug"
+