aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gstreamer
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-09-30 09:58:04 +0200
committerKoen Kooi <koen@openembedded.org>2009-09-30 09:58:04 +0200
commit87a9e6b4f556808aef42bf8f89d2740379e97727 (patch)
treee221a2a1d52e322bb019ad294d3ecce32d4ca217 /recipes/gstreamer
parentcfdba342d167414279e5e246dfc32f1dfc5652f2 (diff)
downloadopenembedded-87a9e6b4f556808aef42bf8f89d2740379e97727.tar.gz
gst-plugin-gles: gles2 fix from Pratheesh
Diffstat (limited to 'recipes/gstreamer')
-rw-r--r--recipes/gstreamer/gst-plugin-gles/omap3_disable_depth_attachment.patch45
-rw-r--r--recipes/gstreamer/gst-plugin-gles/omap3_fix_renderbuffer_storage.patch29
-rw-r--r--recipes/gstreamer/gst-plugin-gles_git.bb5
3 files changed, 32 insertions, 47 deletions
diff --git a/recipes/gstreamer/gst-plugin-gles/omap3_disable_depth_attachment.patch b/recipes/gstreamer/gst-plugin-gles/omap3_disable_depth_attachment.patch
deleted file mode 100644
index 1b4cf15c8f..0000000000
--- a/recipes/gstreamer/gst-plugin-gles/omap3_disable_depth_attachment.patch
+++ /dev/null
@@ -1,45 +0,0 @@
---- /tmp/gstgldisplay.c 2009-09-28 00:49:48.000000000 +0530
-+++ git/gst-libs/gst/gl/gstgldisplay.c 2009-09-28 02:35:00.000000000 +0530
-@@ -1252,12 +1252,12 @@ gst_gl_display_thread_init_download (Gst
- default:
- g_assert_not_reached ();
- }
--
-+#if 0
- //attach the depth render buffer to the FBO
- glFramebufferRenderbufferEXT (GL_FRAMEBUFFER_EXT,
- GL_DEPTH_ATTACHMENT_EXT, GL_RENDERBUFFER_EXT,
- display->download_depth_buffer);
--
-+#endif
- gst_gl_display_check_framebuffer_status ();
-
- g_assert (glCheckFramebufferStatusEXT (GL_FRAMEBUFFER_EXT) ==
-@@ -1555,11 +1555,11 @@ gst_gl_display_thread_gen_fbo (GstGLDisp
- //attach the texture to the FBO to renderer to
- glFramebufferTexture2DEXT (GL_FRAMEBUFFER_EXT, GL_COLOR_ATTACHMENT0_EXT,
- GL_TEXTURE_RECTANGLE_ARB, fake_texture, 0);
--
-+#if 0
- //attach the depth render buffer to the FBO
- glFramebufferRenderbufferEXT (GL_FRAMEBUFFER_EXT, GL_DEPTH_ATTACHMENT_EXT,
- GL_RENDERBUFFER_EXT, display->generated_depth_buffer);
--
-+#endif
- g_assert (glCheckFramebufferStatusEXT (GL_FRAMEBUFFER_EXT) ==
- GL_FRAMEBUFFER_COMPLETE_EXT);
-
-@@ -2443,11 +2443,11 @@ gst_gl_display_thread_init_upload_fbo (G
- //attach the texture to the FBO to renderer to
- glFramebufferTexture2DEXT (GL_FRAMEBUFFER_EXT, GL_COLOR_ATTACHMENT0_EXT,
- GL_TEXTURE_RECTANGLE_ARB, fake_texture, 0);
--
-+#if 0
- //attach the depth render buffer to the FBO
- glFramebufferRenderbufferEXT (GL_FRAMEBUFFER_EXT, GL_DEPTH_ATTACHMENT_EXT,
- GL_RENDERBUFFER_EXT, display->upload_depth_buffer);
--
-+#endif
- gst_gl_display_check_framebuffer_status ();
-
- g_assert (glCheckFramebufferStatusEXT (GL_FRAMEBUFFER_EXT) ==
diff --git a/recipes/gstreamer/gst-plugin-gles/omap3_fix_renderbuffer_storage.patch b/recipes/gstreamer/gst-plugin-gles/omap3_fix_renderbuffer_storage.patch
new file mode 100644
index 0000000000..32911bf499
--- /dev/null
+++ b/recipes/gstreamer/gst-plugin-gles/omap3_fix_renderbuffer_storage.patch
@@ -0,0 +1,29 @@
+--- /tmp/gstgldisplay.c 2009-09-28 00:49:48.000000000 +0530
++++ git/gst-libs/gst/gl/gstgldisplay.c 2009-09-30 02:31:20.000000000 +0530
+@@ -1172,7 +1172,7 @@ gst_gl_display_thread_init_download (Gst
+ glGenRenderbuffersEXT (1, &display->download_depth_buffer);
+ glBindRenderbufferEXT (GL_RENDERBUFFER_EXT,
+ display->download_depth_buffer);
+- glRenderbufferStorageEXT (GL_RENDERBUFFER_EXT, GL_DEPTH_COMPONENT,
++ glRenderbufferStorageEXT (GL_RENDERBUFFER_EXT, GL_DEPTH_COMPONENT16,
+ display->download_width, display->download_height);
+
+ //setup a first texture to render to
+@@ -1536,7 +1536,7 @@ gst_gl_display_thread_gen_fbo (GstGLDisp
+ //setup the render buffer for depth
+ glGenRenderbuffersEXT (1, &display->generated_depth_buffer);
+ glBindRenderbufferEXT (GL_RENDERBUFFER_EXT, display->generated_depth_buffer);
+- glRenderbufferStorageEXT (GL_RENDERBUFFER_EXT, GL_DEPTH_COMPONENT,
++ glRenderbufferStorageEXT (GL_RENDERBUFFER_EXT, GL_DEPTH_COMPONENT16,
+ display->gen_fbo_width, display->gen_fbo_height);
+
+ //setup a texture to render to
+@@ -2422,7 +2422,7 @@ gst_gl_display_thread_init_upload_fbo (G
+ //setup the render buffer for depth
+ glGenRenderbuffersEXT (1, &display->upload_depth_buffer);
+ glBindRenderbufferEXT (GL_RENDERBUFFER_EXT, display->upload_depth_buffer);
+- glRenderbufferStorageEXT (GL_RENDERBUFFER_EXT, GL_DEPTH_COMPONENT,
++ glRenderbufferStorageEXT (GL_RENDERBUFFER_EXT, GL_DEPTH_COMPONENT16,
+ display->upload_width, display->upload_height);
+
+ //a fake texture is attached to the upload FBO (cannot init without it)
diff --git a/recipes/gstreamer/gst-plugin-gles_git.bb b/recipes/gstreamer/gst-plugin-gles_git.bb
index 68c1241191..b4938dc9f6 100644
--- a/recipes/gstreamer/gst-plugin-gles_git.bb
+++ b/recipes/gstreamer/gst-plugin-gles_git.bb
@@ -2,7 +2,8 @@ DESCRIPTION = "GStreamer OpenGL/GLES2 plugins"
LICENSE = "LGPL"
SRCREV = "18f5c4875006606b28aa9aa366abbc5dd1e16b60"
-SRCREV_common = "792d198f3f694e5475d1467b5ae9371a23baf7a3"
+
+PR = "r1"
PR_append = "+gitr${SRCREV}"
PV = "0.10"
@@ -11,7 +12,7 @@ DEPENDS = "virtual/libsdl libgles-omap3 gstreamer gst-plugins-base"
SRC_URI = "git://anongit.freedesktop.org/gstreamer/gst-plugins-gl;protocol=git \
http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-0.10.23.tar.bz2 \
- file://omap3_disable_depth_attachment.patch;patch=1 \
+ file://omap3_fix_renderbuffer_storage.patch;patch=1 \
"
S = "${WORKDIR}/git"