aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gstreamer
diff options
context:
space:
mode:
authorTK, Pratheesh Gangadhar <pratheesh@ti.com>2009-09-29 12:01:25 +0200
committerKoen Kooi <koen@openembedded.org>2009-09-29 12:01:25 +0200
commit53e7eb0ef3106cf5c9c12a4834f77b6a2119a193 (patch)
tree225e4540f8247a7d04e68af552496ef1d11546cd /recipes/gstreamer
parent39a8f9ef397d96adc30f477bebbc14466c0537a7 (diff)
downloadopenembedded-53e7eb0ef3106cf5c9c12a4834f77b6a2119a193.tar.gz
gst-plugin-gles: add git version
* the upstream git repo is corrupted, so we employ some tricks to build it * and it has an RPATH problem...
Diffstat (limited to 'recipes/gstreamer')
-rw-r--r--recipes/gstreamer/gst-plugin-gles/omap3_disable_depth_attachment.patch45
-rw-r--r--recipes/gstreamer/gst-plugin-gles_git.bb58
2 files changed, 103 insertions, 0 deletions
diff --git a/recipes/gstreamer/gst-plugin-gles/omap3_disable_depth_attachment.patch b/recipes/gstreamer/gst-plugin-gles/omap3_disable_depth_attachment.patch
new file mode 100644
index 0000000000..1b4cf15c8f
--- /dev/null
+++ b/recipes/gstreamer/gst-plugin-gles/omap3_disable_depth_attachment.patch
@@ -0,0 +1,45 @@
+--- /tmp/gstgldisplay.c 2009-09-28 00:49:48.000000000 +0530
++++ git/gst-libs/gst/gl/gstgldisplay.c 2009-09-28 02:35:00.000000000 +0530
+@@ -1252,12 +1252,12 @@ gst_gl_display_thread_init_download (Gst
+ default:
+ g_assert_not_reached ();
+ }
+-
++#if 0
+ //attach the depth render buffer to the FBO
+ glFramebufferRenderbufferEXT (GL_FRAMEBUFFER_EXT,
+ GL_DEPTH_ATTACHMENT_EXT, GL_RENDERBUFFER_EXT,
+ display->download_depth_buffer);
+-
++#endif
+ gst_gl_display_check_framebuffer_status ();
+
+ g_assert (glCheckFramebufferStatusEXT (GL_FRAMEBUFFER_EXT) ==
+@@ -1555,11 +1555,11 @@ gst_gl_display_thread_gen_fbo (GstGLDisp
+ //attach the texture to the FBO to renderer to
+ glFramebufferTexture2DEXT (GL_FRAMEBUFFER_EXT, GL_COLOR_ATTACHMENT0_EXT,
+ GL_TEXTURE_RECTANGLE_ARB, fake_texture, 0);
+-
++#if 0
+ //attach the depth render buffer to the FBO
+ glFramebufferRenderbufferEXT (GL_FRAMEBUFFER_EXT, GL_DEPTH_ATTACHMENT_EXT,
+ GL_RENDERBUFFER_EXT, display->generated_depth_buffer);
+-
++#endif
+ g_assert (glCheckFramebufferStatusEXT (GL_FRAMEBUFFER_EXT) ==
+ GL_FRAMEBUFFER_COMPLETE_EXT);
+
+@@ -2443,11 +2443,11 @@ gst_gl_display_thread_init_upload_fbo (G
+ //attach the texture to the FBO to renderer to
+ glFramebufferTexture2DEXT (GL_FRAMEBUFFER_EXT, GL_COLOR_ATTACHMENT0_EXT,
+ GL_TEXTURE_RECTANGLE_ARB, fake_texture, 0);
+-
++#if 0
+ //attach the depth render buffer to the FBO
+ glFramebufferRenderbufferEXT (GL_FRAMEBUFFER_EXT, GL_DEPTH_ATTACHMENT_EXT,
+ GL_RENDERBUFFER_EXT, display->upload_depth_buffer);
+-
++#endif
+ gst_gl_display_check_framebuffer_status ();
+
+ g_assert (glCheckFramebufferStatusEXT (GL_FRAMEBUFFER_EXT) ==
diff --git a/recipes/gstreamer/gst-plugin-gles_git.bb b/recipes/gstreamer/gst-plugin-gles_git.bb
new file mode 100644
index 0000000000..68c1241191
--- /dev/null
+++ b/recipes/gstreamer/gst-plugin-gles_git.bb
@@ -0,0 +1,58 @@
+DESCRIPTION = "GStreamer OpenGL/GLES2 plugins"
+LICENSE = "LGPL"
+
+SRCREV = "18f5c4875006606b28aa9aa366abbc5dd1e16b60"
+SRCREV_common = "792d198f3f694e5475d1467b5ae9371a23baf7a3"
+PR_append = "+gitr${SRCREV}"
+PV = "0.10"
+
+DEPENDS = "virtual/libsdl libgles-omap3 gstreamer gst-plugins-base"
+
+
+SRC_URI = "git://anongit.freedesktop.org/gstreamer/gst-plugins-gl;protocol=git \
+ http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-0.10.23.tar.bz2 \
+ file://omap3_disable_depth_attachment.patch;patch=1 \
+"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-tests --disable-examples"
+
+do_configure_prepend () {
+ cp -rf ${WORKDIR}/gstreamer-0.10.23/common/* ${S}/common/
+ cp -rf ${WORKDIR}/gstreamer-0.10.23/po/* ${S}/po/
+ sed -i -e '/po /d' ${S}/Makefile.am
+}
+
+do_configure () {
+ #Hack to force GLES2
+ acl_cv_hardcode_libdir_flag_spec= ac_cv_header_GL_gl_h=no autotools_do_configure
+
+ #Hack to disable Werror (treat warning as errors)
+ for i in $(find "${S}" -name Makefile) ; do
+ sed -i -e 's:-Wl,-rpath-link,${STAGING_LIBDIR}::g' -e s:\Werror\:\Wno-error\:g $i
+ done
+}
+
+GST_LIBV = 0.10
+
+do_install() {
+ install -d ${D}${libdir}/gstreamer-${GST_LIBV}/
+ install -m 0755 gst/gl/.libs/libgstopengl.so ${D}${libdir}/gstreamer-${GST_LIBV}
+ install -m 0755 gst-libs/gst/gl/.libs/libgstgl-0.10.so.0.0.0 ${D}${libdir}/libgstgl-0.10.so.0
+}
+
+
+FILES_${PN} = "${libdir}/gstreamer-0.10/libgstopengl.so \
+ ${libdir}/libgstgl-0.10.so.0"
+
+FILES_${PN}-dev += "\
+ ${libdir}/gstreamer-0.10/libgstopengl.* \
+"
+
+FILES_${PN}-dbg += "${libdir}/gstreamer-0.10/.debug"
+
+INSANE_SKIP_${PN} = True
+