aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gstreamer
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-01-23 12:42:15 +0100
committerKoen Kooi <koen@openembedded.org>2010-01-24 10:11:29 +0100
commitcaebb5c3e03a389cd3355ede830e99b08a27185c (patch)
tree9a8f614b24342fdd26708022129e59af38093ff0 /recipes/gstreamer
parent6167a6d60b27474cb6ed3a649390f901879cb940 (diff)
downloadopenembedded-caebb5c3e03a389cd3355ede830e99b08a27185c.tar.gz
gst-plugins-base 0.10.25: add patch to fix 'native' sinks, so no more spurious resample and ffmpegcolorspace elements
Diffstat (limited to 'recipes/gstreamer')
-rw-r--r--recipes/gstreamer/gst-plugins-base/fix-playbin2.patch26
-rw-r--r--recipes/gstreamer/gst-plugins-base_0.10.25.bb5
2 files changed, 30 insertions, 1 deletions
diff --git a/recipes/gstreamer/gst-plugins-base/fix-playbin2.patch b/recipes/gstreamer/gst-plugins-base/fix-playbin2.patch
new file mode 100644
index 0000000000..8aba3b6eae
--- /dev/null
+++ b/recipes/gstreamer/gst-plugins-base/fix-playbin2.patch
@@ -0,0 +1,26 @@
+From 0fe6b6e8abb131471d5bd04d7f7e27ca98a67659 Mon Sep 17 00:00:00 2001
+From: Brijesh Singh <brijesh.ksingh@gmail.com>
+Date: Wed, 13 Jan 2010 08:39:54 +0000
+Subject: playsink: Fix handling of the native audio/video flags
+
+Fixes bug #606687.
+---
+
+--- /tmp/gstplaysink.c 2010-01-23 12:23:20.000000000 +0100
++++ gst-plugins-base-0.10.25/gst/playback/gstplaysink.c 2010-01-23 12:27:51.000000000 +0100
+@@ -1880,12 +1880,13 @@
+ * pick one and ignore the other then instead of erroring out?) */
+ if (need_text && need_subp)
+ goto subs_and_text;
+- } else if (flags & GST_PLAY_FLAG_VIDEO && playsink->video_pad) {
++ } else if (((flags & GST_PLAY_FLAG_VIDEO)
++ || (flags & GST_PLAY_FLAG_NATIVE_VIDEO)) && playsink->video_pad) {
+ /* we have video and we are requested to show it */
+ need_video = TRUE;
+ }
+ if (playsink->audio_pad) {
+- if (flags & GST_PLAY_FLAG_AUDIO) {
++ if ((flags & GST_PLAY_FLAG_AUDIO) || (flags & GST_PLAY_FLAG_NATIVE_AUDIO)) {
+ need_audio = TRUE;
+ }
+ if (playsink->audio_pad_raw) {
diff --git a/recipes/gstreamer/gst-plugins-base_0.10.25.bb b/recipes/gstreamer/gst-plugins-base_0.10.25.bb
index 2b33c23c3a..5852991463 100644
--- a/recipes/gstreamer/gst-plugins-base_0.10.25.bb
+++ b/recipes/gstreamer/gst-plugins-base_0.10.25.bb
@@ -1,6 +1,9 @@
require gst-plugins.inc
-PR = "${INC_PR}.1"
+SRC_URI += "file://fix-playbin2.patch;patch=1 \
+"
+
+PR = "${INC_PR}.2"
PROVIDES += "gst-plugins"