aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gtk+
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-01-31 17:14:17 +0100
committerKoen Kooi <koen@openembedded.org>2010-01-31 17:16:28 +0100
commit741a2834cb11bb498aef4522e1857a35e14c8da6 (patch)
treeb876770015f72fb64c024f8a949b94eb0a29d876 /recipes/gtk+
parentc6d759bc19db2f2027309137f67b2618fcfdb564 (diff)
downloadopenembedded-741a2834cb11bb498aef4522e1857a35e14c8da6.tar.gz
gtk+: don't install the pixbug-csource tool when building -native, it doesn't work properly
* the work around involved cleaning up old recipes as well, new-style staging here we come!
Diffstat (limited to 'recipes/gtk+')
-rw-r--r--recipes/gtk+/gtk+-native_2.18.6.bb11
-rw-r--r--recipes/gtk+/gtk+.inc20
-rw-r--r--recipes/gtk+/gtk+_2.14.2.bb10
-rw-r--r--recipes/gtk+/gtk+_2.16.4.bb8
-rw-r--r--recipes/gtk+/gtk+_2.16.6.bb8
-rw-r--r--recipes/gtk+/gtk+_2.18.0.bb8
-rw-r--r--recipes/gtk+/gtk+_2.18.3.bb8
-rw-r--r--recipes/gtk+/gtk+_2.18.6.bb14
8 files changed, 17 insertions, 70 deletions
diff --git a/recipes/gtk+/gtk+-native_2.18.6.bb b/recipes/gtk+/gtk+-native_2.18.6.bb
deleted file mode 100644
index 59459e363c..0000000000
--- a/recipes/gtk+/gtk+-native_2.18.6.bb
+++ /dev/null
@@ -1,11 +0,0 @@
-
-require gtk+_${PV}.bb
-
-inherit native
-
-DEPENDS += "atk-native pango-native cairo-native"
-PROVIDES = "gtk+-native"
-
-EXTRA_OECONF += "--without-libtiff --disable-modules"
-
-
diff --git a/recipes/gtk+/gtk+.inc b/recipes/gtk+/gtk+.inc
index 610428821f..e619a6af28 100644
--- a/recipes/gtk+/gtk+.inc
+++ b/recipes/gtk+/gtk+.inc
@@ -51,26 +51,14 @@ RRECOMMENDS_${PN} = " ${NEATSTUFF} "
RRECOMMENDS_${PN}_linux = " ${NEATSTUFF} glibc-gconv-iso8859-1 "
RRECOMMENDS_${PN}_linux-gnueabi = " ${NEATSTUFF} glibc-gconv-iso8859-1"
-do_stage () {
- oe_libinstall -so -C gtk libgtk-x11-2.0 ${STAGING_LIBDIR}
- oe_libinstall -so -C gdk libgdk-x11-2.0 ${STAGING_LIBDIR}
- oe_libinstall -so -C contrib/gdk-pixbuf-xlib libgdk_pixbuf_xlib-2.0 ${STAGING_LIBDIR}
- oe_libinstall -so -C gdk-pixbuf libgdk_pixbuf-2.0 ${STAGING_LIBDIR}
- if test -d modules/other/gail/libgail-util ; then
- oe_libinstall -so -C modules/other/gail/libgail-util libgailutil ${STAGING_LIBDIR}
- fi
-
- autotools_stage_includes
-
- mkdir -p ${STAGING_LIBDIR}/gtk-2.0/include
- install -m 0644 gdk/gdkconfig.h ${STAGING_LIBDIR}/gtk-2.0/include/gdkconfig.h
+do_install_append () {
+ mkdir -p ${D}${libdir}/gtk-2.0/include
+ install -m 0644 gdk/gdkconfig.h ${D}${libdir}/gtk-2.0/include/gdkconfig.h
# Copy over all headers, since the maemo stuff needs access to the private api. *sigh*
- cp gtk/*.h ${STAGING_INCDIR}/gtk-2.0/gtk/
+ cp gtk/*.h ${D}${includedir}/gtk-2.0/gtk/
install -m 0644 m4macros/gtk-2.0.m4 ${STAGING_DATADIR}/aclocal/
-}
-do_install_append () {
install -d ${D}${sysconfdir}/gtk-2.0
rm -f ${D}${libdir}/gtk-2.0/*/*.la ${D}${libdir}/gtk-2.0/${LIBV}/*/*.la
}
diff --git a/recipes/gtk+/gtk+_2.14.2.bb b/recipes/gtk+/gtk+_2.14.2.bb
index a6ba9ce12f..bd23eeab73 100644
--- a/recipes/gtk+/gtk+_2.14.2.bb
+++ b/recipes/gtk+/gtk+_2.14.2.bb
@@ -29,16 +29,6 @@ python populate_packages_prepend () {
bb.data.setVar('PKG_${PN}', 'libgtk-2.0', d)
}
-
-do_stage_append() {
-
- # this tool is required by gnome-keyring 2.26.0 to get built
- # it is written in Python and use only Python xml
- install -d ${STAGING_BINDIR_NATIVE}
- install -m 0755 ${S}/gtk/gtk-builder-convert ${STAGING_BINDIR_NATIVE}
-
-}
-
# gail is part of gtk+ since gtk+-2.13.0 (targetting >=GNOME 2.23):
PROVIDES = "virtual/gail"
RPROVIDES_${PN} = "libgailutil18"
diff --git a/recipes/gtk+/gtk+_2.16.4.bb b/recipes/gtk+/gtk+_2.16.4.bb
index 34d4491d66..470bd06882 100644
--- a/recipes/gtk+/gtk+_2.16.4.bb
+++ b/recipes/gtk+/gtk+_2.16.4.bb
@@ -42,11 +42,3 @@ RCONFLICTS_${PN}-dbg = "libgailutil-dbg"
RREPLACES_${PN}-dbg = "libgailutil-dbg"
# FIXME: replace locales as well
-do_stage_append() {
-
- # this tool is required by gnome-keyring 2.26.0 to get built
- # it is written in Python and use only Python xml
- install -d ${STAGING_BINDIR_NATIVE}
- install -m 0755 ${S}/gtk/gtk-builder-convert ${STAGING_BINDIR_NATIVE}
-
-}
diff --git a/recipes/gtk+/gtk+_2.16.6.bb b/recipes/gtk+/gtk+_2.16.6.bb
index 34d4491d66..470bd06882 100644
--- a/recipes/gtk+/gtk+_2.16.6.bb
+++ b/recipes/gtk+/gtk+_2.16.6.bb
@@ -42,11 +42,3 @@ RCONFLICTS_${PN}-dbg = "libgailutil-dbg"
RREPLACES_${PN}-dbg = "libgailutil-dbg"
# FIXME: replace locales as well
-do_stage_append() {
-
- # this tool is required by gnome-keyring 2.26.0 to get built
- # it is written in Python and use only Python xml
- install -d ${STAGING_BINDIR_NATIVE}
- install -m 0755 ${S}/gtk/gtk-builder-convert ${STAGING_BINDIR_NATIVE}
-
-}
diff --git a/recipes/gtk+/gtk+_2.18.0.bb b/recipes/gtk+/gtk+_2.18.0.bb
index 34d4491d66..470bd06882 100644
--- a/recipes/gtk+/gtk+_2.18.0.bb
+++ b/recipes/gtk+/gtk+_2.18.0.bb
@@ -42,11 +42,3 @@ RCONFLICTS_${PN}-dbg = "libgailutil-dbg"
RREPLACES_${PN}-dbg = "libgailutil-dbg"
# FIXME: replace locales as well
-do_stage_append() {
-
- # this tool is required by gnome-keyring 2.26.0 to get built
- # it is written in Python and use only Python xml
- install -d ${STAGING_BINDIR_NATIVE}
- install -m 0755 ${S}/gtk/gtk-builder-convert ${STAGING_BINDIR_NATIVE}
-
-}
diff --git a/recipes/gtk+/gtk+_2.18.3.bb b/recipes/gtk+/gtk+_2.18.3.bb
index 65d0b86734..ec3690d077 100644
--- a/recipes/gtk+/gtk+_2.18.3.bb
+++ b/recipes/gtk+/gtk+_2.18.3.bb
@@ -46,11 +46,3 @@ RCONFLICTS_${PN}-dbg = "libgailutil-dbg"
RREPLACES_${PN}-dbg = "libgailutil-dbg"
# FIXME: replace locales as well
-do_stage_append() {
-
- # this tool is required by gnome-keyring 2.26.0 to get built
- # it is written in Python and use only Python xml
- install -d ${STAGING_BINDIR_NATIVE}
- install -m 0755 ${S}/gtk/gtk-builder-convert ${STAGING_BINDIR_NATIVE}
-
-}
diff --git a/recipes/gtk+/gtk+_2.18.6.bb b/recipes/gtk+/gtk+_2.18.6.bb
index 6476f4c003..674a88a731 100644
--- a/recipes/gtk+/gtk+_2.18.6.bb
+++ b/recipes/gtk+/gtk+_2.18.6.bb
@@ -1,12 +1,24 @@
require gtk+.inc
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
+
+BBCLASSEXTEND = "native"
+
+DEPENDS_virtclass-native = "atk-native pango-native cairo-native"
# Enable xkb selectively
XKBTOGGLE = " --disable-xkb"
XKBTOGGLE_angstrom = ""
EXTRA_OECONF = "--with-libtiff ${XKBTOGGLE} --disable-glibtest gio_can_sniff=yes"
+EXTRA_OECONF_append_virtclass-native = " --without-libtiff --disable-modules"
+
+do_install_virtclass-native () {
+ autotools_do_install
+ find ${D}${libdir} -name "libpixbufloader-*.la" -exec rm \{\} \;
+ rm ${D}${bindir}/gdk-pixbuf-csource
+ echo "going native!"
+}
PACKAGES_DYNAMIC = "gtk-module-* gdk-pixbuf-loader-* gtk-immodule-* gtk-printbackend-*"