aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gtk+
diff options
context:
space:
mode:
authorMichael Smith <msmith@cbnco.com>2010-09-17 10:59:28 -0400
committerMichael Smith <msmith@cbnco.com>2010-09-22 18:39:36 -0400
commit6aadf6cfe90a0abd0ae9afed8daf8756935f995a (patch)
tree9a8718e958e914a9f7113d91bda177ebb849a843 /recipes/gtk+
parent1f5fb1e223df5af9fbe7af546c0a2bd3c4a5e2a5 (diff)
downloadopenembedded-6aadf6cfe90a0abd0ae9afed8daf8756935f995a.tar.gz
gtk+ 2.14.2: add BBCLASSEXTEND = "native"
Get this ancient recipe working again. Signed-off-by: Michael Smith <msmith@cbnco.com>
Diffstat (limited to 'recipes/gtk+')
-rw-r--r--recipes/gtk+/gtk+-2.14.2/no-demos.patch10
-rw-r--r--recipes/gtk+/gtk+_2.14.2.bb13
2 files changed, 22 insertions, 1 deletions
diff --git a/recipes/gtk+/gtk+-2.14.2/no-demos.patch b/recipes/gtk+/gtk+-2.14.2/no-demos.patch
new file mode 100644
index 0000000000..0fc4c48d1a
--- /dev/null
+++ b/recipes/gtk+/gtk+-2.14.2/no-demos.patch
@@ -0,0 +1,10 @@
+--- gtk+-2.10.1/Makefile.am.orig 2006-08-08 12:37:30.000000000 +0100
++++ gtk+-2.10.1/Makefile.am 2006-08-08 12:37:48.000000000 +0100
+@@ -1,6 +1,6 @@
+ ## Makefile.am for GTK+
+
+-SRC_SUBDIRS = gdk-pixbuf gdk gtk modules demos tests perf contrib
++SRC_SUBDIRS = gdk-pixbuf gdk gtk modules tests perf contrib
+ SUBDIRS = po po-properties $(SRC_SUBDIRS) docs m4macros
+
+ # require automake 1.4
diff --git a/recipes/gtk+/gtk+_2.14.2.bb b/recipes/gtk+/gtk+_2.14.2.bb
index cb0d3f7efa..acf8624bd7 100644
--- a/recipes/gtk+/gtk+_2.14.2.bb
+++ b/recipes/gtk+/gtk+_2.14.2.bb
@@ -1,12 +1,23 @@
require gtk+.inc
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
SRC_URI += "file://smallscreen_filechooser.patch \
"
+SRC_URI_append_virtclass-native = " file://no-demos.patch \
+"
+
+BBCLASSEXTEND = "native"
+
+DEPENDS_virtclass-native = "libpng-native atk-native pango-native cairo-native libxrender-native libxext-native libgcrypt-native"
+RRECOMMENDS_${PN}_virtclass-native = ""
+PROVIDES_virtclass-native = "gdk-pixbuf-csource-native"
+
EXTRA_OECONF = "--with-libtiff --disable-xkb --disable-glibtest --enable-display-migration gio_can_sniff=yes"
+EXTRA_OECONF_append_virtclass-native = " --without-libtiff --without-libjpeg --without-libjasper --disable-cups"
+
PACKAGES_DYNAMIC = "gtk-module-* gdk-pixbuf-loader-* gtk-immodule-* gtk-printbackend-*"
python populate_packages_prepend () {