aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gtk+
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-03-11 19:04:09 -0800
committerKhem Raj <raj.khem@gmail.com>2010-03-12 14:18:03 -0800
commitad0976afee298079c95262a0c8ca12bee479dd87 (patch)
tree0d5948b6e4ca9cb9038e72b444e16170fcafbbd5 /recipes/gtk+
parent578a475a6c27f8ee5daee812065d71c929c932f8 (diff)
downloadopenembedded-ad0976afee298079c95262a0c8ca12bee479dd87.tar.gz
gtk+-native: Override RRECOMMENDS for native recipe
* Remove old style native recipes. Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Graeme Gregory <dp@xora.org.uk>
Diffstat (limited to 'recipes/gtk+')
-rw-r--r--recipes/gtk+/gtk+-native-1.2_1.2.10.bb58
-rw-r--r--recipes/gtk+/gtk+-native_2.12.11.bb20
-rw-r--r--recipes/gtk+/gtk+_2.18.6.bb3
3 files changed, 2 insertions, 79 deletions
diff --git a/recipes/gtk+/gtk+-native-1.2_1.2.10.bb b/recipes/gtk+/gtk+-native-1.2_1.2.10.bb
deleted file mode 100644
index f5ad1a58ab..0000000000
--- a/recipes/gtk+/gtk+-native-1.2_1.2.10.bb
+++ /dev/null
@@ -1,58 +0,0 @@
-DESCRIPTION = "GTK+1.2 is a deprecated library provided for running programs not yet converted to GTK+2.0"
-HOMEPAGE = "http://www.gtk.org"
-SECTION = "libs"
-LICENSE = "LGPL"
-PRIORITY = "optional"
-DEPENDS = "glib-1.2 jpeg libpng libxext"
-
-PR = "r1"
-
-FILESPATH =+ "${FILE_DIRNAME}/gtk+-1.2-1.2.10:"
-SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v1.2/gtk+-${PV}.tar.gz \
- file://gtk+1.2-reconf-fix;patch=1 \
- file://no-xwc;patch=1"
-S = "${WORKDIR}/gtk+-${PV}"
-
-inherit autotools pkgconfig flow-lossage
-
-do_configure_prepend() {
- install -d m4
- rm -f ltconfig libtool ltmain.sh
- libtoolize --force
-}
-
-FILES_${PN} += "${datadir}/themes"
-FILES_${PN}-dev += "${datadir}/gtk-1.2/include ${libdir}/gtk-1.2/include"
-
-
-EXTRA_OECONF = "--enable-debug=no --disable-glibtest --disable-xim"
-# --disable-cruft
-
-LIBV = "1.2.10"
-
-gtk_include = "fnmatch.h gtk.h gtkaccelgroup.h gtkaccellabel.h gtkadjustment.h gtkalignment.h gtkarg.h gtkarrow.h gtkaspectframe.h gtkbbox.h gtkbin.h gtkbindings.h gtkbox.h gtkbutton.h gtkcalendar.h gtkcheckbutton.h gtkcheckmenuitem.h gtkclist.h gtkcolorsel.h gtkcombo.h gtkcompat.h gtkcontainer.h gtkctree.h gtkcurve.h gtkdata.h gtkdebug.h gtkdialog.h gtkdnd.h gtkdrawingarea.h gtkeditable.h gtkentry.h gtkenums.h gtkeventbox.h gtkfeatures.h gtkfilesel.h gtkfixed.h gtkfontsel.h gtkframe.h gtkgamma.h gtkgc.h gtkhandlebox.h gtkhbbox.h gtkhbox.h gtkhpaned.h gtkhruler.h gtkhscale.h gtkhscrollbar.h gtkhseparator.h gtkimage.h gtkinputdialog.h gtkintl.h gtkinvisible.h gtkitem.h gtkitemfactory.h gtklabel.h gtklayout.h gtklist.h gtklistitem.h gtkmain.h gtkmarshal.h gtkmenu.h gtkmenubar.h gtkmenufactory.h gtkmenuitem.h gtkmenushell.h gtkmisc.h gtknotebook.h gtkobject.h gtkoptionmenu.h gtkpacker.h gtkpaned.h gtkpixmap.h gtkplug.h gtkpreview.h gtkprivate.h gtkprogress.h gtkprogressbar.h gtkradiobutton.h gtkradiomenuitem.h gtkrange.h gtkrc.h gtkruler.h gtkscale.h gtkscrollbar.h gtkscrolledwindow.h gtkselection.h gtkseparator.h gtksignal.h gtksocket.h gtkspinbutton.h gtkstatusbar.h gtkstyle.h gtktable.h gtktearoffmenuitem.h gtktext.h gtkthemes.h gtktipsquery.h gtktogglebutton.h gtktoolbar.h gtktooltips.h gtktree.h gtktreeitem.h gtktypebuiltins.h gtktypeutils.h gtkvbbox.h gtkvbox.h gtkviewport.h gtkvpaned.h gtkvruler.h gtkvscale.h gtkvscrollbar.h gtkvseparator.h gtkwidget.h gtkwindow.h makeenums.h stamp-gtkmarshal.h stamp-gtktypebuiltins.h"
-gdk_include = "MwmUtil.h gdk.h gdkcursors.h gdki18n.h gdkinput.h gdkinputcommon.h gdkinputgxi.h gdkinputnone.h gdkinputxfree.h gdkkeysyms.h gdkprivate.h gdkrgb.h gdktypes.h gdkx.h gxid_lib.h gxid_proto.h"
-
-do_stage () {
- oe_libinstall -so -C gtk libgtk-1.2 ${STAGING_LIBDIR}
- oe_libinstall -so -C gdk libgdk-1.2 ${STAGING_LIBDIR}
-
- mkdir -p ${STAGING_INCDIR}/gtk-1.2/gtk
- for i in ${gtk_include}; do
- install -m 0644 gtk/$i ${STAGING_INCDIR}/gtk-1.2/gtk/$i
- done
-
- mkdir -p ${STAGING_INCDIR}/gtk-1.2/gdk
- for i in ${gdk_include}; do
- install -m 0644 gdk/$i ${STAGING_INCDIR}/gtk-1.2/gdk/$i
- done
-
- mkdir -p ${STAGING_LIBDIR}/gtk-1.2/include
-
- install -m 0644 gtk.m4 ${STAGING_DATADIR}/aclocal/
-}
-
-do_install_append () {
- install -d ${D}${sysconfdir}/gtk-1.2
-}
-
diff --git a/recipes/gtk+/gtk+-native_2.12.11.bb b/recipes/gtk+/gtk+-native_2.12.11.bb
deleted file mode 100644
index a53dcdef54..0000000000
--- a/recipes/gtk+/gtk+-native_2.12.11.bb
+++ /dev/null
@@ -1,20 +0,0 @@
-
-require gtk+_2.12.11.bb
-
-inherit native
-
-DEPENDS += "atk-native pango-native cairo-native libx11-native libxext-native libxrender-native"
-PROVIDES = "gtk+-native"
-
-EXTRA_OECONF += "--without-libtiff --disable-modules --disable-cups"
-
-PR = "r3"
-
-do_install_append() {
-
- # this tool is required by gnome-keyring 2.26.0 to get built
- # it is written in Python and use only Python xml
- install -d ${STAGING_BINDIR_NATIVE}
- install -m 0755 ${S}/gtk/gtk-builder-convert ${STAGING_BINDIR_NATIVE}
-}
-
diff --git a/recipes/gtk+/gtk+_2.18.6.bb b/recipes/gtk+/gtk+_2.18.6.bb
index 1c2ca79016..69f8ff5e59 100644
--- a/recipes/gtk+/gtk+_2.18.6.bb
+++ b/recipes/gtk+/gtk+_2.18.6.bb
@@ -3,11 +3,12 @@ require gtk+.inc
SRC_URI_append_virtclass-native = " file://no-demos.patch;patch=1 \
"
-PR = "${INC_PR}.3"
+PR = "${INC_PR}.4"
BBCLASSEXTEND = "native"
DEPENDS_virtclass-native = "libpng-native atk-native pango-native cairo-native libxrender-native libxext-native"
+RRECOMMENDS_${PN}_virtclass-native = ""
PROVIDES_virtclass-native = "gdk-pixbuf-csource-native"
# Enable xkb selectively