aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gtkhtml/gtkhtml-3.8_3.12.3.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gtkhtml/gtkhtml-3.8_3.12.3.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gtkhtml/gtkhtml-3.8_3.12.3.bb')
-rw-r--r--recipes/gtkhtml/gtkhtml-3.8_3.12.3.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/gtkhtml/gtkhtml-3.8_3.12.3.bb b/recipes/gtkhtml/gtkhtml-3.8_3.12.3.bb
new file mode 100644
index 0000000000..e8727bd0dc
--- /dev/null
+++ b/recipes/gtkhtml/gtkhtml-3.8_3.12.3.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "HTML rendering/editing library"
+SECTION = "x11/libs"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "gtk+ gail libbonoboui libgnomeprintui libgnomeui"
+
+SRC_URI = "${GNOME_MIRROR}/gtkhtml/3.12/gtkhtml-${PV}.tar.bz2 \
+ file://60_glib-2.15-g-gnuc-function.patch;patch=1"
+
+S = "${WORKDIR}/gtkhtml-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-gtk-doc"
+
+ORBIT_IDL = "${STAGING_BINDIR_NATIVE}/orbit-idl-2"
+
+do_configure_append() {
+ find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
+ find ${S} -name Makefile | xargs sed -i s:'-I${prefix}/include':'-I.':g
+ find ${S} -name Makefile | xargs sed -i 's|ORBIT_IDL =.*|ORBIT_IDL = ${ORBIT_IDL}|'
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} += "${datadir}/gtkhtml-3.8"
+