aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gtkmm
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gtkmm
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gtkmm')
-rw-r--r--recipes/gtkmm/gtkmm.inc21
-rw-r--r--recipes/gtkmm/gtkmm_2.12.7.bb9
-rw-r--r--recipes/gtkmm/gtkmm_2.14.1.bb11
3 files changed, 41 insertions, 0 deletions
diff --git a/recipes/gtkmm/gtkmm.inc b/recipes/gtkmm/gtkmm.inc
new file mode 100644
index 0000000000..139d95239d
--- /dev/null
+++ b/recipes/gtkmm/gtkmm.inc
@@ -0,0 +1,21 @@
+DESCRIPTION = "C++ bindings for the GTK+ toolkit."
+HOMEPAGE = "http://www.gtkmm.org/"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+DEPENDS = "atk glibmm gtk+ cairomm"
+
+inherit gnome autotools pkgconfig flow-lossage
+
+LIBV = "2.4.0"
+
+do_stage () {
+ autotools_stage_all
+
+ install -d ${STAGING_INCDIR}/gtkmm-2.4
+ install -m 0644 gdk/gdkmmconfig.h ${STAGING_INCDIR}/gtkmm-2.4
+ install -m 0644 gtk/gtkmmconfig.h ${STAGING_INCDIR}/gtkmm-2.4
+}
+
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${libdir}/*/include ${libdir}/*/proc/m4"
diff --git a/recipes/gtkmm/gtkmm_2.12.7.bb b/recipes/gtkmm/gtkmm_2.12.7.bb
new file mode 100644
index 0000000000..9ef908db63
--- /dev/null
+++ b/recipes/gtkmm/gtkmm_2.12.7.bb
@@ -0,0 +1,9 @@
+require gtkmm.inc
+
+PR = "r0"
+
+# Hack! Remove once gtkmm likes libtool 2x
+do_configure() {
+ gnu-configize
+ oe_runconf
+}
diff --git a/recipes/gtkmm/gtkmm_2.14.1.bb b/recipes/gtkmm/gtkmm_2.14.1.bb
new file mode 100644
index 0000000000..e3def49b5b
--- /dev/null
+++ b/recipes/gtkmm/gtkmm_2.14.1.bb
@@ -0,0 +1,11 @@
+require gtkmm.inc
+
+DEPENDS += "pangomm"
+
+PR = "r0"
+
+# Hack! Remove once gtkmm likes libtool 2x
+do_cconfigure() {
+ gnu-configize
+ oe_runconf
+}