summaryrefslogtreecommitdiffstats
path: root/recipes/hal/ohm_git.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/hal/ohm_git.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/hal/ohm_git.bb')
-rw-r--r--recipes/hal/ohm_git.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/recipes/hal/ohm_git.bb b/recipes/hal/ohm_git.bb
new file mode 100644
index 0000000000..ffdbb07b88
--- /dev/null
+++ b/recipes/hal/ohm_git.bb
@@ -0,0 +1,45 @@
+DESCRIPTION = "Open Hardware Manager"
+HOMEPAGE = "http://freedesktop.org/Software/ohm"
+LICENSE = "LGPL"
+
+DEPENDS = "gtk+ dbus-glib intltool-native hal"
+RDEPENDS_${PN} += "udev hal-info"
+SRC_URI = "git://anongit.freedesktop.org/git/ohm/;protocol=git \
+ file://fix_configure.patch;patch=1"
+
+SRCREV = "edfe25d49d67884bf004de7ae0724c162bb5e65e"
+PV = "0.1.2+${PR}+gitr${SRCREV}"
+PE = "1"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--with-distro=debian \
+ --without-xauth \
+ --disable-gtk-doc \
+ --disable-docbook-docs"
+
+do_configure_prepend() {
+ touch gtk-doc.make
+}
+
+OE_LT_RPATH_ALLOW=":${libdir}/libohm:"
+OE_LT_RPATH_ALLOW[export]="1"
+
+PACKAGES =+ "libohm ohm-plugin-x11"
+
+FILES_${PN}-dev += "${libdir}/ohm/*.a"
+
+FILES_${PN} = "${sysconfdir} \
+ ${bindir}/* \
+ ${sbindir}/* \
+ ${libdir}/ohm/*.so \
+ "
+
+FILES_libohm = "${libdir}/libohm.so.*"
+FILES_ohm-plugin-x11 = "${libdir}/ohm/libohm_x*.so \
+ ${libdir}/ohm/libohm_idle.so \
+ ${sysconfdir}/ohm/plugins.d/x* \
+ ${sysconfdir}/ohm/plugins.d/idle* \
+ "