aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/hdparm
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/hdparm
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/hdparm')
-rw-r--r--recipes/hdparm/files/uclibc.patch32
-rw-r--r--recipes/hdparm/hdparm-6.3/bswap.patch36
-rw-r--r--recipes/hdparm/hdparm-6.6/bswap.patch37
-rw-r--r--recipes/hdparm/hdparm-6.9/bswap.patch39
-rw-r--r--recipes/hdparm/hdparm-6.9/uclibc.patch62
-rw-r--r--recipes/hdparm/hdparm_6.3.bb14
-rw-r--r--recipes/hdparm/hdparm_6.6.bb14
-rw-r--r--recipes/hdparm/hdparm_6.9.bb25
8 files changed, 259 insertions, 0 deletions
diff --git a/recipes/hdparm/files/uclibc.patch b/recipes/hdparm/files/uclibc.patch
new file mode 100644
index 0000000000..495d7491bb
--- /dev/null
+++ b/recipes/hdparm/files/uclibc.patch
@@ -0,0 +1,32 @@
+--- hdparm-5.8/hdparm.c.ark 2005-05-22 19:48:34.000000000 +0000
++++ hdparm-5.8/hdparm.c 2005-05-22 19:52:18.000000000 +0000
+@@ -17,7 +17,9 @@
+ #include <sys/times.h>
+ #include <sys/types.h>
+ #include <sys/mount.h>
++#ifndef __UCLIBC__
+ #include <linux/types.h>
++#endif
+ #include <linux/hdreg.h>
+ #include <linux/major.h>
+ #include <byteswap.h>
+--- hdparm-5.8/hdparm.h.ark 2005-05-22 19:51:49.000000000 +0000
++++ hdparm-5.8/hdparm.h 2005-05-22 19:54:54.000000000 +0000
+@@ -1,6 +1,6 @@
+ /* Some prototypes for extern functions. */
+
+-#include <linux/types.h> /* for __u16 */
++#include <stdint.h>
+
+ #if !defined(__GNUC__) && !defined(__attribute__)
+ #define __attribute__(x) /* if not using GCC, turn off the __attribute__
+@@ -11,7 +11,7 @@
+ others, though, were declared in hdparm.c with global scope; since other
+ functions in that file have static (file) scope, I assume the difference is
+ intentional. */
+-extern void identify (__u16 *id_supplied, const char *devname);
++extern void identify (uint16_t *id_supplied, const char *devname);
+
+ extern void usage_error(int out) __attribute__((noreturn));
+ extern int main(int argc, char **argv) __attribute__((noreturn));
+
diff --git a/recipes/hdparm/hdparm-6.3/bswap.patch b/recipes/hdparm/hdparm-6.3/bswap.patch
new file mode 100644
index 0000000000..37fbcb7b38
--- /dev/null
+++ b/recipes/hdparm/hdparm-6.3/bswap.patch
@@ -0,0 +1,36 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- hdparm-5.8/hdparm.c~bswap
++++ hdparm-5.8/hdparm.c
+@@ -20,7 +20,9 @@
+ #include <linux/types.h>
+ #include <linux/hdreg.h>
+ #include <linux/major.h>
+-#include <asm/byteorder.h>
++#include <byteswap.h>
++
++#define le16_to_cpus(x) bswap_16(htons(x))
+
+ #include "hdparm.h"
+
+@@ -1160,7 +1162,7 @@
+ }
+ } else {
+ for(i = 0; i < 0x100; ++i) {
+- __le16_to_cpus(&id[i]);
++ le16_to_cpus(&id[i]);
+ }
+ identify((void *)id, NULL);
+ }
+@@ -1380,7 +1382,7 @@
+ }
+ for (i = 0; count >= 4; ++i) {
+ sbuf[i] = (fromhex(b[0]) << 12) | (fromhex(b[1]) << 8) | (fromhex(b[2]) << 4) | fromhex(b[3]);
+- __le16_to_cpus((__u16 *)(&sbuf[i]));
++ le16_to_cpus((__u16 *)(&sbuf[i]));
+ b += 5;
+ count -= 5;
+ }
diff --git a/recipes/hdparm/hdparm-6.6/bswap.patch b/recipes/hdparm/hdparm-6.6/bswap.patch
new file mode 100644
index 0000000000..6b0506ceb5
--- /dev/null
+++ b/recipes/hdparm/hdparm-6.6/bswap.patch
@@ -0,0 +1,37 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- hdparm-5.8/hdparm.c~bswap
++++ hdparm-5.8/hdparm.c
+@@ -20,8 +20,9 @@
+ #include <linux/types.h>
+ #include <linux/hdreg.h>
+ #include <linux/major.h>
+-#include <asm/byteorder.h>
+-//#include <endian.h>
++#include <byteswap.h>
++
++#define le16_to_cpus(x) bswap_16(htons(x))
+
+ #include "hdparm.h"
+
+@@ -1160,7 +1162,7 @@
+ }
+ } else {
+ for(i = 0; i < 0x100; ++i) {
+- __le16_to_cpus(&id[i]);
++ le16_to_cpus(&id[i]);
+ }
+ identify((void *)id, NULL);
+ }
+@@ -1380,7 +1382,7 @@
+ }
+ for (i = 0; count >= 4; ++i) {
+ sbuf[i] = (fromhex(b[0]) << 12) | (fromhex(b[1]) << 8) | (fromhex(b[2]) << 4) | fromhex(b[3]);
+- __le16_to_cpus((__u16 *)(&sbuf[i]));
++ le16_to_cpus((__u16 *)(&sbuf[i]));
+ b += 5;
+ count -= 5;
+ }
diff --git a/recipes/hdparm/hdparm-6.9/bswap.patch b/recipes/hdparm/hdparm-6.9/bswap.patch
new file mode 100644
index 0000000000..3281c33954
--- /dev/null
+++ b/recipes/hdparm/hdparm-6.9/bswap.patch
@@ -0,0 +1,39 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+Index: hdparm-6.9/hdparm.c
+===================================================================
+--- hdparm-6.9.orig/hdparm.c 2006-10-25 16:41:33.000000000 +0200
++++ hdparm-6.9/hdparm.c 2007-03-05 14:02:03.000000000 +0100
+@@ -19,8 +19,9 @@
+ #include <linux/types.h>
+ #include <linux/hdreg.h>
+ #include <linux/major.h>
+-#include <asm/byteorder.h>
+-//#include <endian.h>
++#include <byteswap.h>
++
++#define le16_to_cpus(x) bswap_16(htons(x))
+
+ #include "hdparm.h"
+
+@@ -1328,7 +1329,7 @@
+ }
+ } else {
+ for(i = 0; i < 0x100; ++i) {
+- __le16_to_cpus(&id[i]);
++ le16_to_cpus(&id[i]);
+ }
+ identify((void *)id);
+ }
+@@ -1608,7 +1609,7 @@
+ && ishex(d[++digit] = getchar())
+ && ishex(d[++digit] = getchar())) {
+ sbuf[wc] = (fromhex(d[0]) << 12) | (fromhex(d[1]) << 8) | (fromhex(d[2]) << 4) | fromhex(d[3]);
+- __le16_to_cpus((__u16 *)(&sbuf[wc]));
++ le16_to_cpus((__u16 *)(&sbuf[wc]));
+ ++wc;
+ } else if (d[digit] == EOF) {
+ goto eof;
diff --git a/recipes/hdparm/hdparm-6.9/uclibc.patch b/recipes/hdparm/hdparm-6.9/uclibc.patch
new file mode 100644
index 0000000000..b1d8e4aa47
--- /dev/null
+++ b/recipes/hdparm/hdparm-6.9/uclibc.patch
@@ -0,0 +1,62 @@
+Index: hdparm-6.9/hdparm.c
+===================================================================
+--- hdparm-6.9.orig/hdparm.c 2007-05-20 20:12:58.000000000 +0200
++++ hdparm-6.9/hdparm.c 2007-05-20 20:13:31.000000000 +0200
+@@ -16,7 +16,9 @@
+ #include <sys/times.h>
+ #include <sys/types.h>
+ #include <sys/mount.h>
++#ifndef __UCLIBC__
+ #include <linux/types.h>
++#endif
+ #include <linux/hdreg.h>
+ #include <linux/major.h>
+ #include <byteswap.h>
+@@ -1311,7 +1313,7 @@
+ perror(" HDIO_GET_IDENTITY failed");
+ }
+ if (get_IDentity) {
+- __u16 *id;
++ uint16_t *id;
+ unsigned char args[4+512] = {WIN_IDENTIFY,0,0,1,}; // FIXME?
+ unsigned i;
+ if (ioctl(fd, HDIO_DRIVE_CMD, &args)) {
+@@ -1321,7 +1323,7 @@
+ goto identify_abort;
+ }
+ }
+- id = (__u16 *)&args[4];
++ id = (uint16_t *)&args[4];
+ if (get_IDentity == 2) {
+ for (i = 0; i < (256/8); ++i) {
+ printf("%04x %04x %04x %04x %04x %04x %04x %04x\n", id[0], id[1], id[2], id[3], id[4], id[5], id[6], id[7]);
+@@ -1609,7 +1611,7 @@
+ && ishex(d[++digit] = getchar())
+ && ishex(d[++digit] = getchar())) {
+ sbuf[wc] = (fromhex(d[0]) << 12) | (fromhex(d[1]) << 8) | (fromhex(d[2]) << 4) | fromhex(d[3]);
+- le16_to_cpus((__u16 *)(&sbuf[wc]));
++ le16_to_cpus((uint16_t *)(&sbuf[wc]));
+ ++wc;
+ } else if (d[digit] == EOF) {
+ goto eof;
+Index: hdparm-6.9/hdparm.h
+===================================================================
+--- hdparm-6.9.orig/hdparm.h 2006-04-28 16:33:01.000000000 +0200
++++ hdparm-6.9/hdparm.h 2007-05-20 20:12:58.000000000 +0200
+@@ -1,6 +1,6 @@
+ /* Some prototypes for extern functions. */
+
+-#include <linux/types.h> /* for __u16 */
++#include <stdint.h>
+
+ #if !defined(__GNUC__) && !defined(__attribute__)
+ #define __attribute__(x) /* if not using GCC, turn off the __attribute__
+@@ -11,7 +11,7 @@
+ others, though, were declared in hdparm.c with global scope; since other
+ functions in that file have static (file) scope, I assume the difference is
+ intentional. */
+-extern void identify (__u16 *id_supplied);
++extern void identify (uint16_t *id_supplied);
+
+ extern void usage_error(int out) __attribute__((noreturn));
+ extern int main(int argc, char **argv) __attribute__((noreturn));
diff --git a/recipes/hdparm/hdparm_6.3.bb b/recipes/hdparm/hdparm_6.3.bb
new file mode 100644
index 0000000000..94d1e6e9bf
--- /dev/null
+++ b/recipes/hdparm/hdparm_6.3.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "hdparm is a Linux shell utility for viewing \
+and manipulating various IDE drive and driver parameters."
+SECTION = "console/utils"
+PRIORITY = "optional"
+LICENSE = "BSD"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/hdparm/hdparm-${PV}.tar.gz \
+ file://bswap.patch;patch=1 \
+ file://uclibc.patch;patch=1"
+
+do_install () {
+ install -d ${D}/${sbindir} ${D}/${mandir}/man8
+ oe_runmake 'DESTDIR=${D}' install
+}
diff --git a/recipes/hdparm/hdparm_6.6.bb b/recipes/hdparm/hdparm_6.6.bb
new file mode 100644
index 0000000000..94d1e6e9bf
--- /dev/null
+++ b/recipes/hdparm/hdparm_6.6.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "hdparm is a Linux shell utility for viewing \
+and manipulating various IDE drive and driver parameters."
+SECTION = "console/utils"
+PRIORITY = "optional"
+LICENSE = "BSD"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/hdparm/hdparm-${PV}.tar.gz \
+ file://bswap.patch;patch=1 \
+ file://uclibc.patch;patch=1"
+
+do_install () {
+ install -d ${D}/${sbindir} ${D}/${mandir}/man8
+ oe_runmake 'DESTDIR=${D}' install
+}
diff --git a/recipes/hdparm/hdparm_6.9.bb b/recipes/hdparm/hdparm_6.9.bb
new file mode 100644
index 0000000000..337a7e1e8b
--- /dev/null
+++ b/recipes/hdparm/hdparm_6.9.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "hdparm is a Linux shell utility for viewing \
+and manipulating various IDE drive and driver parameters."
+SECTION = "console/utils"
+PRIORITY = "optional"
+LICENSE = "BSD"
+
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/hdparm/hdparm-${PV}.tar.gz \
+ file://bswap.patch;patch=1 \
+ file://uclibc.patch;patch=1"
+
+do_install () {
+ install -d ${D}/${base_sbindir} ${D}/${mandir}/man8
+ oe_runmake 'DESTDIR=${D}' 'sbindir=${base_sbindir}' install
+ mv ${D}${base_sbindir}/hdparm ${D}${base_sbindir}/hdparm.${PN}
+}
+
+pkg_postinst_${PN} () {
+ update-alternatives --install ${base_sbindir}/hdparm hdparm hdparm.${PN} 100
+}
+
+pkg_prerm_${PN} () {
+ update-alternatives --remove hdparm hdparm.${PN}
+} \ No newline at end of file