aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/helloworld
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/helloworld
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/helloworld')
-rw-r--r--recipes/helloworld/helloworld_1.0.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/helloworld/helloworld_1.0.0.bb b/recipes/helloworld/helloworld_1.0.0.bb
new file mode 100644
index 0000000000..af29a7769a
--- /dev/null
+++ b/recipes/helloworld/helloworld_1.0.0.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Minimal statically compiled Hello world!"
+LICENSE = "GPL"
+PR = "r0"
+
+S = "${WORKDIR}/${P}"
+
+do_fetch () {
+ mkdir -p ${WORKDIR}/${P}
+ cd ${WORKDIR}/${P}
+ printf "#include <stdio.h>\nint main(void)\n{\n\tprintf(\"Hello world!\\\n\");\twhile(1);\n\treturn 0;\n}\n" >helloworld.c
+}
+
+do_compile () {
+ ${CC} -o helloworld helloworld.c -static
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 helloworld ${D}${bindir}/
+ # /bin/init is on purpose, it is tried after /sbin/init and /etc/init
+ # so if a sysvinit is installed, it will be used instead of helloworld
+ install -d ${D}${base_bindir}
+ ln -sf ${bindir}/helloworld ${D}${base_bindir}/init
+}