aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/hfsutils
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/hfsutils
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/hfsutils')
-rw-r--r--recipes/hfsutils/hfsutils-3.2.6/hfsutils-3.2.6-errno.patch13
-rw-r--r--recipes/hfsutils/hfsutils-3.2.6/largerthan2gb.patch15
-rw-r--r--recipes/hfsutils/hfsutils_3.2.6.bb32
3 files changed, 60 insertions, 0 deletions
diff --git a/recipes/hfsutils/hfsutils-3.2.6/hfsutils-3.2.6-errno.patch b/recipes/hfsutils/hfsutils-3.2.6/hfsutils-3.2.6-errno.patch
new file mode 100644
index 0000000000..6e25f794b2
--- /dev/null
+++ b/recipes/hfsutils/hfsutils-3.2.6/hfsutils-3.2.6-errno.patch
@@ -0,0 +1,13 @@
+diff -ruN hfsutils.orig/tclhfs.c hfsutils-3.2.6/tclhfs.c
+--- hfsutils.orig/tclhfs.c 2003-03-31 17:34:55.000000000 +0200
++++ hfsutils-3.2.6/tclhfs.c 2003-03-31 17:39:51.000000000 +0200
+@@ -43,8 +43,7 @@
+ # include "charset.h"
+ # include "suid.h"
+ # include "version.h"
+-
+-extern int errno;
++# include <errno.h>
+
+ # define ERROR(code, str) (hfs_error = (str), errno = (code))
+
diff --git a/recipes/hfsutils/hfsutils-3.2.6/largerthan2gb.patch b/recipes/hfsutils/hfsutils-3.2.6/largerthan2gb.patch
new file mode 100644
index 0000000000..423256b67d
--- /dev/null
+++ b/recipes/hfsutils/hfsutils-3.2.6/largerthan2gb.patch
@@ -0,0 +1,15 @@
+diff -ruN hfsutils.orig/libhfs/os/unix.c hfsutils-3.2.6/libhfs/os/unix.c
+--- hfsutils.orig/libhfs/os/unix.c 1998-11-02 23:09:13.000000000 +0000
++++ hfsutils-3.2.6/libhfs/os/unix.c 2007-02-27 15:44:21.023442553 +0000
+@@ -19,6 +19,11 @@
+ * $Id: largerthan2gb.patch,v 1.1 2005/02/05 21:20:43 hansmi Exp $
+ */
+
++#ifdef __linux__
++#define _FILE_OFFSET_BITS 64
++#define _LARGE_FILES
++#endif
++
+ # ifdef HAVE_CONFIG_H
+ # include "config.h"
+ # endif
diff --git a/recipes/hfsutils/hfsutils_3.2.6.bb b/recipes/hfsutils/hfsutils_3.2.6.bb
new file mode 100644
index 0000000000..5292ac386c
--- /dev/null
+++ b/recipes/hfsutils/hfsutils_3.2.6.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "HFS file system utilities"
+SECTION = "base"
+LICENSE = "GPL"
+PR = "r2"
+
+inherit autotools pkgconfig
+
+SRC_URI = "ftp://ftp.mars.org/pub/hfs/hfsutils-3.2.6.tar.gz \
+ file://hfsutils-3.2.6-errno.patch;patch=1 \
+ file://largerthan2gb.patch;patch=1 \
+ "
+
+do_configure () {
+ oe_runconf --disable-x
+}
+
+do_compile () {
+ oe_runmake
+ cd hfsck; oe_runmake
+}
+
+do_install () {
+ install -d ${D}/${bindir}
+ install -m 755 hfsutil ${D}/${bindir}/hfsutil
+ install -m 755 hfsck/hfsck ${D}/${bindir}/hfsck
+
+ for util in hattrib hcd hcopy hdel hdir hformat \
+ his hmkdir hmount hpwd hrename hrmdir \
+ humount hvol; do
+ ln -sf hfsutil ${D}/${bindir}/${util}
+ done
+}