summaryrefslogtreecommitdiffstats
path: root/recipes/hostap/hostap-conf_1.0.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/hostap/hostap-conf_1.0.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/hostap/hostap-conf_1.0.bb')
-rw-r--r--recipes/hostap/hostap-conf_1.0.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes/hostap/hostap-conf_1.0.bb b/recipes/hostap/hostap-conf_1.0.bb
new file mode 100644
index 0000000000..e0909dde3f
--- /dev/null
+++ b/recipes/hostap/hostap-conf_1.0.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "PCMCIA-cs configuration files for wireless LAN cards based on Intersil's Prism2/2.5/3 chipset"
+SECTION = "kernel/modules"
+PRIORITY = "optional"
+LICENSE = "GPL"
+RDEPENDS = "update-modules"
+PACKAGE_ARCH = "all"
+PR = "r9"
+
+SRC_URI = "file://hostap_cs.conf \
+ file://hostap_cs.modalias \
+ file://hostap_cs.conf-upstream"
+
+do_compile() {
+}
+
+do_install() {
+ install -d ${D}${sysconfdir}/pcmcia
+ install -d ${D}${sysconfdir}/modutils
+
+ install -m 0644 ${WORKDIR}/hostap_cs.conf-upstream ${D}${sysconfdir}/pcmcia/hostap_cs.conf
+ cat ${WORKDIR}/hostap_cs.conf >>${D}${sysconfdir}/pcmcia/hostap_cs.conf
+
+ install -m 0644 ${WORKDIR}/hostap_cs.modalias ${D}${sysconfdir}/modutils/hostap_cs.conf
+}
+
+pkg_postinst () {
+ if [ -n "$D" ]; then
+ exit 1
+ fi
+ update-modules || true
+}
+
+pkg_postrm () {
+ update-modules || true
+}