aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/hostap/hostap-utils_0.4.7.bb
diff options
context:
space:
mode:
authorJeremy Lainé <jeremy.laine@m4x.org>2009-04-08 08:42:23 +0000
committerJeremy Lainé <jeremy.laine@m4x.org>2009-04-08 08:42:23 +0000
commit0377cdf5dabc1a3559e86a5101114465100dc813 (patch)
tree62e52e60003ace7541a22451dfa7c2571ad7e5ee /recipes/hostap/hostap-utils_0.4.7.bb
parenta6d06c8abf1aee0bccb60005fb4ce360b1b4b66e (diff)
downloadopenembedded-0377cdf5dabc1a3559e86a5101114465100dc813.tar.gz
hostap-utils-0.4.7: use LDFLAGS (fixes QA error)
Diffstat (limited to 'recipes/hostap/hostap-utils_0.4.7.bb')
-rw-r--r--recipes/hostap/hostap-utils_0.4.7.bb24
1 files changed, 23 insertions, 1 deletions
diff --git a/recipes/hostap/hostap-utils_0.4.7.bb b/recipes/hostap/hostap-utils_0.4.7.bb
index 9fe362b19f..563594780d 100644
--- a/recipes/hostap/hostap-utils_0.4.7.bb
+++ b/recipes/hostap/hostap-utils_0.4.7.bb
@@ -1 +1,23 @@
-require hostap-utils.inc
+DESCRIPTION = "User mode helpers for the hostap driver"
+HOMEPAGE = "http://hostap.epitest.fi"
+SECTION = "kernel/userland"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "r6"
+
+SRC_URI = "http://hostap.epitest.fi/releases/hostap-utils-${PV}.tar.gz \
+ file://hostap-fw-load.patch;patch=1 \
+ file://ldflags.patch;patch=1"
+
+S = "${WORKDIR}/hostap-utils-${PV}"
+
+BINARIES = "hostap_crypt_conf hostap_diag hostap_fw_load hostap_io_debug \
+ hostap_rid prism2_param prism2_srec split_combined_hex"
+
+do_install() {
+ install -d ${D}${sbindir}/
+ for f in ${BINARIES}
+ do
+ install -m 0755 $f ${D}${sbindir}/
+ done
+}