aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/hostap
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-05-24 13:01:00 -0700
committerChris Larson <chris_larson@mentor.com>2010-05-25 12:54:52 -0700
commit6fe7cef27069415f2eba36bc640cf59013d4979b (patch)
treeb0cb8845ddc6b8bcffc50e08a2eeae98e049be98 /recipes/hostap
parentbf7d0467a0788a7fcc1c96e0dc35a25ae09278a0 (diff)
downloadopenembedded-6fe7cef27069415f2eba36bc640cf59013d4979b.tar.gz
Make the do_patch apply=yes param implicit if extension is .diff/.patch
For .diff/.patch you need to apply manually, you can specify apply=no. Signed-off-by: Chris Larson <chris_larson@mentor.com> Acked-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/hostap')
-rw-r--r--recipes/hostap/hostap-daemon.inc4
-rw-r--r--recipes/hostap/hostap-daemon_0.4.4.bb2
-rw-r--r--recipes/hostap/hostap-daemon_0.5.10.bb2
-rw-r--r--recipes/hostap/hostap-daemon_0.6.9.bb2
-rw-r--r--recipes/hostap/hostap-modules-rawtx_0.4.7.bb8
-rw-r--r--recipes/hostap/hostap-modules.inc10
-rw-r--r--recipes/hostap/hostap-modules_0.4.4.bb2
-rw-r--r--recipes/hostap/hostap-modules_0.4.7.bb2
-rw-r--r--recipes/hostap/hostap-utils_0.4.7.bb4
9 files changed, 18 insertions, 18 deletions
diff --git a/recipes/hostap/hostap-daemon.inc b/recipes/hostap/hostap-daemon.inc
index b98572e4bf..33dc1c140e 100644
--- a/recipes/hostap/hostap-daemon.inc
+++ b/recipes/hostap/hostap-daemon.inc
@@ -11,8 +11,8 @@ CPPFLAGS_append_mtx-1 = " -I${STAGING_INCDIR}/madwifi/"
CPPFLAGS_append_mtx-2 = " -I${STAGING_INCDIR}/madwifi/"
SRC_URI = "http://hostap.epitest.fi/releases/hostapd-${PV}.tar.gz \
- file://makefile-cross.diff;apply=yes;striplevel=0 \
- file://madwifi-bsd-fix.diff;apply=yes;striplevel=0 \
+ file://makefile-cross.diff;striplevel=0 \
+ file://madwifi-bsd-fix.diff;striplevel=0 \
file://defconfig \
file://init"
diff --git a/recipes/hostap/hostap-daemon_0.4.4.bb b/recipes/hostap/hostap-daemon_0.4.4.bb
index 34d5415d37..197e6cd81b 100644
--- a/recipes/hostap/hostap-daemon_0.4.4.bb
+++ b/recipes/hostap/hostap-daemon_0.4.4.bb
@@ -1,7 +1,7 @@
require hostap-daemon.inc
SRC_URI_append_nylon = "\
- file://hostap-no-bsd.patch;apply=yes"
+ file://hostap-no-bsd.patch"
PR = "r2"
diff --git a/recipes/hostap/hostap-daemon_0.5.10.bb b/recipes/hostap/hostap-daemon_0.5.10.bb
index dd27dfdc68..d5a71fc2f5 100644
--- a/recipes/hostap/hostap-daemon_0.5.10.bb
+++ b/recipes/hostap/hostap-daemon_0.5.10.bb
@@ -15,7 +15,7 @@ MY_ARCH := "${PACKAGE_ARCH}"
PACKAGE_ARCH = "${@base_contains('COMBINED_FEATURES', 'madwifi', '${MACHINE_ARCH}', '${MY_ARCH}', d)}"
SRC_URI = "http://hostap.epitest.fi/releases/hostapd-${PV}.tar.gz \
- file://makefile-cross.diff;apply=yes \
+ file://makefile-cross.diff \
file://defconfig \
file://init"
diff --git a/recipes/hostap/hostap-daemon_0.6.9.bb b/recipes/hostap/hostap-daemon_0.6.9.bb
index e3fe5490bf..ba8761ec97 100644
--- a/recipes/hostap/hostap-daemon_0.6.9.bb
+++ b/recipes/hostap/hostap-daemon_0.6.9.bb
@@ -9,7 +9,7 @@ PR = "r2"
DEFAULT_PREFERENCE = "-1"
SRC_URI = "http://hostap.epitest.fi/releases/hostapd-${PV}.tar.gz \
- file://ldflags.patch;apply=yes \
+ file://ldflags.patch \
file://defconfig \
file://init"
diff --git a/recipes/hostap/hostap-modules-rawtx_0.4.7.bb b/recipes/hostap/hostap-modules-rawtx_0.4.7.bb
index 5f5b87cd32..bed65fe1e6 100644
--- a/recipes/hostap/hostap-modules-rawtx_0.4.7.bb
+++ b/recipes/hostap/hostap-modules-rawtx_0.4.7.bb
@@ -4,11 +4,11 @@ DESCRIPTION = "A driver for wireless LAN cards based on Intersil's Prism2/2.5/3
RDEPENDS_hostap-modules-cs-rawtx = "hostap-modules-rawtx"
RDEPENDS_hostap-modules-pci-rawtx = "hostap-modules-rawtx"
-SRC_URI += "file://kernel_updates.patch;apply=yes \
- file://hostap-driver-0.4.7.patch;apply=yes \
+SRC_URI += "file://kernel_updates.patch \
+ file://hostap-driver-0.4.7.patch \
file://hostap_cs.conf "
-SRC_URI_append_mtx-1 = " file://mtx_compat.diff;apply=yes;striplevel=0 \
- file://mtx_hostap_deferred_irq.diff;apply=yes;striplevel=0"
+SRC_URI_append_mtx-1 = " file://mtx_compat.diff;striplevel=0 \
+ file://mtx_hostap_deferred_irq.diff;striplevel=0"
S = "${WORKDIR}/hostap-driver-${PV}"
diff --git a/recipes/hostap/hostap-modules.inc b/recipes/hostap/hostap-modules.inc
index 4a2afc5471..40e6742c45 100644
--- a/recipes/hostap/hostap-modules.inc
+++ b/recipes/hostap/hostap-modules.inc
@@ -5,11 +5,11 @@ LICENSE = "GPL"
RRECOMMENDS = "apm-wifi-suspendfix"
SRC_URI = "http://hostap.epitest.fi/releases/hostap-driver-${PV}.tar.gz"
-SRC_URI_append_mtx-1 = " file://mtx_compat.diff;apply=yes;striplevel=0 \
- file://mtx_hostap_deferred_irq.diff;apply=yes;striplevel=0"
-SRC_URI_append_mtx-2 = " file://mtx_compat.diff;apply=yes;striplevel=0 \
- file://mtx_hostap_deferred_irq.diff;apply=yes;striplevel=0"
-SRC_URI_append_h3900 = " file://ipaq_compat.patch;apply=yes "
+SRC_URI_append_mtx-1 = " file://mtx_compat.diff;striplevel=0 \
+ file://mtx_hostap_deferred_irq.diff;striplevel=0"
+SRC_URI_append_mtx-2 = " file://mtx_compat.diff;striplevel=0 \
+ file://mtx_hostap_deferred_irq.diff;striplevel=0"
+SRC_URI_append_h3900 = " file://ipaq_compat.patch "
S = "${WORKDIR}/hostap-driver-${PV}"
diff --git a/recipes/hostap/hostap-modules_0.4.4.bb b/recipes/hostap/hostap-modules_0.4.4.bb
index 1ba888710f..e7cd26db3c 100644
--- a/recipes/hostap/hostap-modules_0.4.4.bb
+++ b/recipes/hostap/hostap-modules_0.4.4.bb
@@ -1,7 +1,7 @@
require hostap-modules.inc
PR = "r7"
-SRC_URI += "file://kernel_updates.patch;apply=yes"
+SRC_URI += "file://kernel_updates.patch"
SRC_URI[md5sum] = "e9b4a5cb992e06c3c6bf2bc99eca6625"
SRC_URI[sha256sum] = "7b9ad6bb5cf6c485e320bd8901d2e398cb6661cda633ba6360200a9bf94eb5fb"
diff --git a/recipes/hostap/hostap-modules_0.4.7.bb b/recipes/hostap/hostap-modules_0.4.7.bb
index 90424954bb..2254598d42 100644
--- a/recipes/hostap/hostap-modules_0.4.7.bb
+++ b/recipes/hostap/hostap-modules_0.4.7.bb
@@ -1,7 +1,7 @@
require hostap-modules.inc
PR = "r5"
-SRC_URI += "file://kernel_updates.patch;apply=yes"
+SRC_URI += "file://kernel_updates.patch"
SRC_URI[md5sum] = "ee495686cf27011b4e401963c2c7f62a"
SRC_URI[sha256sum] = "e9a3e035a1483b371269936c6fde46bfbae71dc38fa04685c1338ca8ffe900a5"
diff --git a/recipes/hostap/hostap-utils_0.4.7.bb b/recipes/hostap/hostap-utils_0.4.7.bb
index d960fce470..fffa2a7bfc 100644
--- a/recipes/hostap/hostap-utils_0.4.7.bb
+++ b/recipes/hostap/hostap-utils_0.4.7.bb
@@ -6,8 +6,8 @@ LICENSE = "GPL"
PR = "r6"
SRC_URI = "http://hostap.epitest.fi/releases/hostap-utils-${PV}.tar.gz \
- file://hostap-fw-load.patch;apply=yes \
- file://ldflags.patch;apply=yes"
+ file://hostap-fw-load.patch \
+ file://ldflags.patch"
S = "${WORKDIR}/hostap-utils-${PV}"