summaryrefslogtreecommitdiffstats
path: root/recipes/hotplug-ng
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/hotplug-ng
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/hotplug-ng')
-rw-r--r--recipes/hotplug-ng/files/flags.patch87
-rw-r--r--recipes/hotplug-ng/hotplug-ng_001.bb25
-rw-r--r--recipes/hotplug-ng/hotplug-ng_002.bb25
3 files changed, 137 insertions, 0 deletions
diff --git a/recipes/hotplug-ng/files/flags.patch b/recipes/hotplug-ng/files/flags.patch
new file mode 100644
index 0000000000..1b67ce360f
--- /dev/null
+++ b/recipes/hotplug-ng/files/flags.patch
@@ -0,0 +1,87 @@
+Index: hotplug-ng-001/Makefile
+===================================================================
+--- hotplug-ng-001.orig/Makefile 2005-02-10 17:40:02.000000000 -0600
++++ hotplug-ng-001/Makefile 2005-02-17 11:22:09.000000000 -0600
+@@ -96,25 +96,28 @@
+ then echo "-Os"; else echo "-O2" ; fi}
+
+ # add -Wredundant-decls when libsysfs gets cleaned up
+-WARNINGS := -Wall
++WARNINGS = -Wall
+
+-CFLAGS := -pipe
++CFLAGS = -pipe
++rCFLAGS = -D_GNU_SOURCE
+
+ ifeq ($(strip $(USE_LOG)),true)
+- CFLAGS += -DLOG
++ rCFLAGS += -DLOG
+ endif
+
+ # if DEBUG is enabled, then we do not strip or optimize
+ ifeq ($(strip $(DEBUG)),true)
+- CFLAGS += -O1 -g -DDEBUG -D_GNU_SOURCE
++ CFLAGS += -O1 -g -DDEBUG
+ LDFLAGS += -Wl,-warn-common
+ STRIPCMD = /bin/true -Since_we_are_debugging
+ else
+- CFLAGS += $(OPTIMIZATION) -fomit-frame-pointer -D_GNU_SOURCE
++ CFLAGS += $(OPTIMIZATION) -fomit-frame-pointer
+ LDFLAGS += -s -Wl,-warn-common
+ STRIPCMD = $(STRIP) -s --remove-section=.note --remove-section=.comment
+ endif
+
++CFLAGS += $(WARNINGS)
++
+ # If we are using our version of klibc, then we need to build, link it, and then
+ # link udev against it statically.
+ # Otherwise, use glibc and link dynamically.
+@@ -132,8 +135,8 @@
+
+ CRT0 = $(KLIBC_DIR)/crt0.o
+ LIBC = $(ARCH_LIB_OBJS) $(LIB_OBJS) $(CRT0)
+- CFLAGS += $(WARNINGS) -nostdinc \
+- $(OPTFLAGS) \
++ CFLAGS += $(OPTFLAGS)
++ rCFLAGS += -nostdinc \
+ -D__KLIBC__ -fno-builtin-printf \
+ -I$(KLIBC_FIXUPS_DIR) \
+ -include $(KLIBC_FIXUPS_DIR)/klibc_fixups.h \
+@@ -148,17 +151,16 @@
+ WARNINGS += -Wshadow -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations
+ CRT0 =
+ LIBC =
+- CFLAGS += $(WARNINGS) -I$(GCCINCDIR)
+ LIB_OBJS = -lc
+ LDFLAGS =
+ endif
+
+ ifeq ($(strip $(USE_SELINUX)),true)
+- CFLAGS += -DUSE_SELINUX
++ rCFLAGS += -DUSE_SELINUX
+ LIB_OBJS += -lselinux
+ endif
+
+-CFLAGS += -I$(PWD)/libsysfs/sysfs \
++rCFLAGS += -I$(PWD)/libsysfs/sysfs \
+ -I$(PWD)/libsysfs
+
+ all: $(ROOT) $(MODULE_ALL) $(GEN_CONFIGS)
+@@ -169,7 +171,7 @@
+ @if [ ! -r klibc/linux ]; then \
+ ln -f -s $(KERNEL_DIR) klibc/linux; \
+ fi
+- $(MAKE) -C klibc SUBDIRS=klibc
++ $(MAKE) -C klibc CFLAGS="$(rCFLAGS) $(CFLAGS)" SUBDIRS=klibc
+
+ SYSFS = $(PWD)/libsysfs/sysfs_bus.o \
+ $(PWD)/libsysfs/sysfs_class.o \
+@@ -272,7 +274,7 @@
+ #.c.o:
+ # $(CC) $(CFLAGS) $(DEFS) $(CPPFLAGS) -c -o $@ $<
+ .c.o:
+- $(QUIET) $(CC) $(CFLAGS) -c -o $@ $<
++ $(QUIET) $(CC) $(rCFLAGS) $(CFLAGS) -c -o $@ $<
+
+
+ clean:
diff --git a/recipes/hotplug-ng/hotplug-ng_001.bb b/recipes/hotplug-ng/hotplug-ng_001.bb
new file mode 100644
index 0000000000..c76c0f06eb
--- /dev/null
+++ b/recipes/hotplug-ng/hotplug-ng_001.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "This collection of code replaces the existing linux-hotplug \
+package with very tiny, compiled executable programs, instead of the \
+existing bash scripts."
+LICENSE = "GPL"
+RPROVIDES = "hotplug"
+RCONFLICTS = "hotplug"
+RREPLACES = "hotplug"
+PR = "r1"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/kernel/hotplug/hotplug-ng-${PV}.tar.gz \
+ file://flags.patch;patch=1"
+S = "${WORKDIR}/hotplug-ng-${PV}"
+
+LD = "${CC}"
+export HOSTCC = "${BUILD_CC}"
+# Stripping should be done when _packaging_, not building
+EXTRA_OEMAKE += "'STRIP=/bin/true'"
+
+export etcdir = "${sysconfdir}"
+export sbindir = "${base_sbindir}"
+export bindir = "${base_bindir}"
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+}
diff --git a/recipes/hotplug-ng/hotplug-ng_002.bb b/recipes/hotplug-ng/hotplug-ng_002.bb
new file mode 100644
index 0000000000..3c5014be9a
--- /dev/null
+++ b/recipes/hotplug-ng/hotplug-ng_002.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "This collection of code replaces the existing linux-hotplug \
+package with very tiny, compiled executable programs, instead of the \
+existing bash scripts."
+LICENSE = "GPL"
+RPROVIDES_${PN} = "hotplug"
+RCONFLICTS_${PN} = "hotplug"
+RREPLACES_${PN} = "hotplug"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/kernel/hotplug/hotplug-ng-${PV}.tar.gz"
+
+#S = "${WORKDIR}/hotplug-ng-${PV}"
+
+LD = "${CC}"
+export HOSTCC = "${BUILD_CC}"
+CFLAGS = " -I${S}/libsysfs/sysfs"
+# Stripping should be done when _packaging_, not building
+EXTRA_OEMAKE += "'STRIP=/bin/true'"
+
+export etcdir = "${sysconfdir}"
+export sbindir = "${base_sbindir}"
+export bindir = "${base_bindir}"
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+}