summaryrefslogtreecommitdiffstats
path: root/recipes/htb-init
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2010-03-23 22:18:38 +0300
committerRoman I Khimov <khimov@altell.ru>2010-03-23 22:23:55 +0300
commitd8ce5c488c36b3abfc9d046eeaa87a848d4b6afc (patch)
tree193b6bfbcff158a8f9be7f3619a91a615d77c48e /recipes/htb-init
parent55e25fb988a94d4f0e2d13dc55e910d462222c80 (diff)
downloadopenembedded-d8ce5c488c36b3abfc9d046eeaa87a848d4b6afc.tar.gz
htb-init: fix ip location, use init script, update package_arch
OE has alternatives setup for ip and the link is installed in /bin/ip, rather than /sbin/ip, so fix that. Also, setup rc links by default and set package_arch to all since it's just an init script. Update RDEPENDS since versioning doesn't work here. Signed-off-by: Roman I Khimov <khimov@altell.ru>
Diffstat (limited to 'recipes/htb-init')
-rw-r--r--recipes/htb-init/htb-init_0.8.5.bb10
1 files changed, 8 insertions, 2 deletions
diff --git a/recipes/htb-init/htb-init_0.8.5.bb b/recipes/htb-init/htb-init_0.8.5.bb
index a70da77746..69d61e268a 100644
--- a/recipes/htb-init/htb-init_0.8.5.bb
+++ b/recipes/htb-init/htb-init_0.8.5.bb
@@ -1,18 +1,24 @@
DESCRIPTION = "HTB.init is a shell script that allows for easy setup of HTB-based traffic control on Linux."
HOMEPAGE = "http://sourceforge.net/projects/htbinit"
LICENSE = "GPL"
-PR = "r1"
+PR = "r2"
SRC_URI = "${SOURCEFORGE_MIRROR}/htbinit/htb.init-v${PV} \
file://htb.init+ingress+predef+verbose.diff;patch=1;pnum=0 \
file://htb-basic-verbose.diff;patch=1;pnum=0"
RRECOMMENDS = "kernel-module-sch-ingress kernel-module-cls-route kernel-module-cls-u32 kernel-module-cls-fw kernel-module-sch-sfq kernel-module-sch-htb"
-RDEPENDS = "iproute2 (>= 2.6.8-r1)"
+RDEPENDS = "iproute2"
S="${WORKDIR}"
+inherit update-rc.d
+INITSCRIPT_NAME = "htb"
+
do_install() {
install -d ${D}${sysconfdir}/init.d
install -d ${D}${sysconfdir}/htb
install -m 755 ${S}/htb.init-v${PV} ${D}${sysconfdir}/init.d/htb
+ sed -r -i "s,IP=/sbin/ip,IP=${base_bindir}/ip," ${D}${sysconfdir}/init.d/htb
}
+
+PACKAGE_ARCH = "all"