aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/htmldoc
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-09-30 14:47:05 -0700
committerTom Rini <tom_rini@mentor.com>2010-09-30 14:58:39 -0700
commitedd73eef19a90ba51c2fc4e4e6213e0804ace862 (patch)
tree658898192e5bad519c65aa4bacda6509ffe8c80c /recipes/htmldoc
parent53ddbbe512c390520bc0609e146907af011e9bc4 (diff)
downloadopenembedded-edd73eef19a90ba51c2fc4e4e6213e0804ace862.tar.gz
htmldoc-native: Switch to BBCLASSEXTEND, drop legacy staging
Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/htmldoc')
-rw-r--r--recipes/htmldoc/htmldoc-native_1.9.x-r1571.bb37
-rw-r--r--recipes/htmldoc/htmldoc_1.9.x-r1571.bb23
2 files changed, 21 insertions, 39 deletions
diff --git a/recipes/htmldoc/htmldoc-native_1.9.x-r1571.bb b/recipes/htmldoc/htmldoc-native_1.9.x-r1571.bb
deleted file mode 100644
index 60d9360dc7..0000000000
--- a/recipes/htmldoc/htmldoc-native_1.9.x-r1571.bb
+++ /dev/null
@@ -1,37 +0,0 @@
-require htmldoc.inc
-PR = "r2"
-
-
-SRC_URI = "http://ftp.rz.tu-bs.de/pub/mirror/ftp.easysw.com/ftp/pub/htmldoc/snapshots/htmldoc-${PV}.tar.bz2 \
-file://paths_1.9.x.patch"
-
-
-inherit autotools native
-
-EXTRA_AUTORECONF += "--exclude=autoheader"
-EXTRA_OECONF += "--disable-localpng --disable-localjpeg --disable-localzlib \
- --with-gui=no"
-
-
-do_compile() {
- cd htmldoc && oe_runmake all ; cd ${S}
-}
-
-
-do_stage () {
- install -d ${STAGING_DATADIR}/htmldoc/fonts
- install -m 0644 ${S}/fonts/*.afm ${STAGING_DATADIR}/htmldoc/fonts/
- install -m 0644 ${S}/fonts/*.pfa ${STAGING_DATADIR}/htmldoc/fonts/
-
- install -d ${STAGING_DATADIR}/htmldoc/data
- install -m 0644 ${S}/data/* ${STAGING_DATADIR}/htmldoc/data/
-
- install -d ${STAGING_DIR_HOST}${layout_mandir}/man1
- install -m 0644 ${S}/doc/htmldoc.man ${STAGING_DIR_HOST}${layout_mandir}/man1/
-
- install -d ${STAGING_BINDIR}
- install -m 0755 ${S}/htmldoc/htmldoc ${STAGING_BINDIR}/
-}
-
-SRC_URI[md5sum] = "eda75ba1abe14ed8e71c6f40438def85"
-SRC_URI[sha256sum] = "b4c78ff6b47521e980533e52cbe46fe86874c75b3d6bc18bcc2500a2ba854c3e"
diff --git a/recipes/htmldoc/htmldoc_1.9.x-r1571.bb b/recipes/htmldoc/htmldoc_1.9.x-r1571.bb
index aac761ebe3..01fc15e5b6 100644
--- a/recipes/htmldoc/htmldoc_1.9.x-r1571.bb
+++ b/recipes/htmldoc/htmldoc_1.9.x-r1571.bb
@@ -1,6 +1,7 @@
require htmldoc.inc
-DEPENDS += "htmldoc-native"
-PR = "r2"
+BBCLASSEXTEND = "native"
+DEPENDS_pn-htmldoc += "htmldoc-native"
+PR = "r3"
SRC_URI = "http://ftp.rz.tu-bs.de/pub/mirror/ftp.easysw.com/ftp/pub/htmldoc/snapshots/htmldoc-${PV}.tar.bz2 \
@@ -21,5 +22,23 @@ do_install() {
oe_runmake 'DESTDIR=${D}' install
}
+do_compile_virtclass-native() {
+ cd htmldoc && oe_runmake all ; cd ${S}
+}
+
+do_install_virtclass-native() {
+ install -d ${D}${datadir}/htmldoc/fonts
+ install -m 0644 ${S}/fonts/*.afm ${D}${datadir}/htmldoc/fonts/
+ install -m 0644 ${S}/fonts/*.pfa ${D}${datadir}/htmldoc/fonts/
+
+ install -d ${D}${datadir}/htmldoc/data
+ install -m 0644 ${S}/data/* ${D}${datadir}/htmldoc/data/
+
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/htmldoc/htmldoc ${D}${bindir}/
+}
+
+NATIVE_INSTALL_WORKS = "1"
+
SRC_URI[md5sum] = "eda75ba1abe14ed8e71c6f40438def85"
SRC_URI[sha256sum] = "b4c78ff6b47521e980533e52cbe46fe86874c75b3d6bc18bcc2500a2ba854c3e"