aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/htmldoc
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-08-23 22:04:09 +0200
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-08-23 22:04:31 +0200
commitd014258b95ba59bb264471a714e6182ffceb83a3 (patch)
tree5acaa8ed60e24d1f32964239e546870f0b590080 /recipes/htmldoc
parent4872124db6550fd728902fac25e777225d047290 (diff)
downloadopenembedded-d014258b95ba59bb264471a714e6182ffceb83a3.tar.gz
Revert "htmldoc[-gui]: remove old versions"
This reverts commit e5287904a9dddc8ddc0f486d8526bc8cfda427b7. Reverted request of the recipe maintainer This version is the latest official version, the 1.9 version is a development snapshot Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/htmldoc')
-rw-r--r--recipes/htmldoc/htmldoc-gui_1.8.27.bb27
-rw-r--r--recipes/htmldoc/htmldoc-native_1.8.27.bb37
-rw-r--r--recipes/htmldoc/htmldoc_1.8.27.bb25
3 files changed, 89 insertions, 0 deletions
diff --git a/recipes/htmldoc/htmldoc-gui_1.8.27.bb b/recipes/htmldoc/htmldoc-gui_1.8.27.bb
new file mode 100644
index 0000000000..2c702e6905
--- /dev/null
+++ b/recipes/htmldoc/htmldoc-gui_1.8.27.bb
@@ -0,0 +1,27 @@
+require htmldoc.inc
+DEPENDS += "htmldoc-native fltk"
+PR = "r2"
+
+
+SRC_URI = "http://ftp.rz.tu-bs.de/pub/mirror/ftp.easysw.com/ftp/pub/htmldoc/${PV}/htmldoc-${PV}-source.tar.bz2 \
+file://paths_1.8.27.patch"
+
+
+S = "${WORKDIR}/htmldoc-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_AUTORECONF += "--exclude=autoheader"
+EXTRA_OECONF += "--disable-localpng --disable-localjpeg --disable-localzlib \
+ --with-gui=yes"
+
+FILES_${PN} += "${datadir}/htmldoc/fonts"
+FILES_${PN} += "${datadir}/htmldoc/data"
+
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}
+
+SRC_URI[md5sum] = "35589e7b8fe9c54e11be87cd5aec4dcc"
+SRC_URI[sha256sum] = "89ffd223734268375dc959c200622dc5f167576c5cad9d7ce4bd7567faeb9613"
diff --git a/recipes/htmldoc/htmldoc-native_1.8.27.bb b/recipes/htmldoc/htmldoc-native_1.8.27.bb
new file mode 100644
index 0000000000..36a6dee7c9
--- /dev/null
+++ b/recipes/htmldoc/htmldoc-native_1.8.27.bb
@@ -0,0 +1,37 @@
+require htmldoc.inc
+PR = "r2"
+
+
+SRC_URI = "http://ftp.rz.tu-bs.de/pub/mirror/ftp.easysw.com/ftp/pub/htmldoc/${PV}/htmldoc-${PV}-source.tar.bz2 \
+file://paths_1.8.27.patch"
+
+
+inherit autotools native
+
+EXTRA_AUTORECONF += "--exclude=autoheader"
+EXTRA_OECONF += "--disable-localpng --disable-localjpeg --disable-localzlib \
+ --with-gui=no"
+
+
+do_compile() {
+ cd htmldoc && oe_runmake all ; cd ${S}
+}
+
+
+do_stage () {
+ install -d ${STAGING_DATADIR}/htmldoc/fonts
+ install -m 0644 ${S}/fonts/*.afm ${STAGING_DATADIR}/htmldoc/fonts/
+ install -m 0644 ${S}/fonts/*.pfa ${STAGING_DATADIR}/htmldoc/fonts/
+
+ install -d ${STAGING_DATADIR}/htmldoc/data
+ install -m 0644 ${S}/data/* ${STAGING_DATADIR}/htmldoc/data/
+
+ install -d ${STAGING_DIR_HOST}${layout_mandir}/man1
+ install -m 0644 ${S}/doc/htmldoc.man ${STAGING_DIR_HOST}${layout_mandir}/man1/
+
+ install -d ${STAGING_BINDIR}
+ install -m 0755 ${S}/htmldoc/htmldoc ${STAGING_BINDIR}/
+}
+
+SRC_URI[md5sum] = "35589e7b8fe9c54e11be87cd5aec4dcc"
+SRC_URI[sha256sum] = "89ffd223734268375dc959c200622dc5f167576c5cad9d7ce4bd7567faeb9613"
diff --git a/recipes/htmldoc/htmldoc_1.8.27.bb b/recipes/htmldoc/htmldoc_1.8.27.bb
new file mode 100644
index 0000000000..bb5ce8b78a
--- /dev/null
+++ b/recipes/htmldoc/htmldoc_1.8.27.bb
@@ -0,0 +1,25 @@
+require htmldoc.inc
+DEPENDS += "htmldoc-native"
+PR = "r2"
+
+
+SRC_URI = "http://ftp.rz.tu-bs.de/pub/mirror/ftp.easysw.com/ftp/pub/htmldoc/${PV}/htmldoc-${PV}-source.tar.bz2 \
+file://paths_1.8.27.patch"
+
+
+inherit autotools pkgconfig
+
+EXTRA_AUTORECONF += "--exclude=autoheader"
+EXTRA_OECONF += "--disable-localpng --disable-localjpeg --disable-localzlib \
+ --with-gui=no"
+
+FILES_${PN} += "${datadir}/htmldoc/fonts"
+FILES_${PN} += "${datadir}/htmldoc/data"
+
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}
+
+SRC_URI[md5sum] = "35589e7b8fe9c54e11be87cd5aec4dcc"
+SRC_URI[sha256sum] = "89ffd223734268375dc959c200622dc5f167576c5cad9d7ce4bd7567faeb9613"