summaryrefslogtreecommitdiffstats
path: root/recipes/icedtea
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2010-07-15 21:53:51 +0200
committerHenning Heinold <heinold@inf.fu-berlin.de>2010-07-15 22:03:30 +0200
commit10f63b3d596662ac375e06a8ed959a6369d1ef20 (patch)
treefdf830855ea42f9749cbe539da70812c6076ad05 /recipes/icedtea
parentcefd83f5b99607ddc592e973c50acf704a0db855 (diff)
downloadopenembedded-10f63b3d596662ac375e06a8ed959a6369d1ef20.tar.gz
icedtea6-native: use zip-native, rather than hostsystem-zip which is not an oe-requirement
* bump INC_PR
Diffstat (limited to 'recipes/icedtea')
-rw-r--r--recipes/icedtea/icedtea6-native-1.7.3/icedtea-oe-path.patch13
-rw-r--r--recipes/icedtea/icedtea6-native-1.8/icedtea-oe-path.patch13
-rw-r--r--recipes/icedtea/icedtea6-native.inc11
-rw-r--r--recipes/icedtea/icedtea6-native_1.7.3.bb2
-rw-r--r--recipes/icedtea/icedtea6-native_1.8.bb2
5 files changed, 37 insertions, 4 deletions
diff --git a/recipes/icedtea/icedtea6-native-1.7.3/icedtea-oe-path.patch b/recipes/icedtea/icedtea6-native-1.7.3/icedtea-oe-path.patch
new file mode 100644
index 0000000000..ad25472851
--- /dev/null
+++ b/recipes/icedtea/icedtea6-native-1.7.3/icedtea-oe-path.patch
@@ -0,0 +1,13 @@
+Index: openjdk/jdk/make/common/shared/Defs-utils.gmk
+===================================================================
+--- openjdk/jdk/make/common/shared/Defs-utils.gmk 2010-07-15 18:22:59.731376457 +0200
++++ openjdk/jdk/make/common/shared/Defs-utils.gmk 2010-07-15 18:24:09.784285551 +0200
+@@ -146,7 +146,7 @@
+ WC = $(UTILS_USR_BIN_PATH)wc
+ WHICH = $(UTILS_USR_BIN_PATH)which
+ YACC = $(UTILS_CCS_BIN_PATH)yacc
+-ZIPEXE = $(UTILS_DEVTOOL_PATH)zip
++ZIPEXE = $(STAGING_BINDIR_NATIVE)zip
+
+ # Special cases
+ #RM is defined by GNU Make as 'rm -f'
diff --git a/recipes/icedtea/icedtea6-native-1.8/icedtea-oe-path.patch b/recipes/icedtea/icedtea6-native-1.8/icedtea-oe-path.patch
new file mode 100644
index 0000000000..ad25472851
--- /dev/null
+++ b/recipes/icedtea/icedtea6-native-1.8/icedtea-oe-path.patch
@@ -0,0 +1,13 @@
+Index: openjdk/jdk/make/common/shared/Defs-utils.gmk
+===================================================================
+--- openjdk/jdk/make/common/shared/Defs-utils.gmk 2010-07-15 18:22:59.731376457 +0200
++++ openjdk/jdk/make/common/shared/Defs-utils.gmk 2010-07-15 18:24:09.784285551 +0200
+@@ -146,7 +146,7 @@
+ WC = $(UTILS_USR_BIN_PATH)wc
+ WHICH = $(UTILS_USR_BIN_PATH)which
+ YACC = $(UTILS_CCS_BIN_PATH)yacc
+-ZIPEXE = $(UTILS_DEVTOOL_PATH)zip
++ZIPEXE = $(STAGING_BINDIR_NATIVE)zip
+
+ # Special cases
+ #RM is defined by GNU Make as 'rm -f'
diff --git a/recipes/icedtea/icedtea6-native.inc b/recipes/icedtea/icedtea6-native.inc
index d032a7c28e..4ee792adb7 100644
--- a/recipes/icedtea/icedtea6-native.inc
+++ b/recipes/icedtea/icedtea6-native.inc
@@ -1,13 +1,14 @@
DESCRIPTION = "Harness to build the source code from OpenJDK using Free Software build tools"
HOMEPAGE = "http://icedtea.classpath.org"
LICENSE = "GPL with Classpath Exception"
-INC_PR = "r0"
+INC_PR = "r1"
DEPENDS = "virtual/javac-native classpath-tools-native \
virtual/java-native classpath-native \
xalan-j-native xerces-j-native rhino-native \
ant-native libx11-native xproto-native libxt-native \
- freetype-native zlib-native giflib-native jpeg-native\
+ freetype-native zlib-native giflib-native jpeg-native \
+ zip-native \
"
inherit native java autotools
@@ -17,8 +18,6 @@ JAVA_HOME[unexport] = "1"
# No parallel build yet.
PARALLEL_MAKE = ""
-#EXTRA_OEMAKE = "--debug=v"
-
# Configure options compatible with Cacao >= 0.99 only!
EXTRA_OECONF = "\
--with-parallel-jobs=1 \
@@ -105,6 +104,10 @@ do_configure_append() {
done
}
+EXTRA_OEMAKE = ' \
+ STAGING_BINDIR_NATIVE="${STAGING_BINDIR_NATIVE}/" \
+ '
+
do_compile() {
# OpenJDK uses slightly different names for certain arches. We need to know
# this to create some files which are expected by the build.
diff --git a/recipes/icedtea/icedtea6-native_1.7.3.bb b/recipes/icedtea/icedtea6-native_1.7.3.bb
index 9ac7aa6e5b..16575a4380 100644
--- a/recipes/icedtea/icedtea6-native_1.7.3.bb
+++ b/recipes/icedtea/icedtea6-native_1.7.3.bb
@@ -24,6 +24,7 @@ ICEDTEA_PATCHES = "\
file://icedtea-hotspot-make-arch-sane-for-x86.patch;apply=no \
file://icedtea-jdk-sane-x86-arch.patch;apply=no \
file://icedtea-unbreak-float.patch;apply=no \
+ file://icedtea-oe-path.patch;apply=no \
"
export DISTRIBUTION_PATCHES = "\
@@ -33,4 +34,5 @@ export DISTRIBUTION_PATCHES = "\
patches/icedtea-hotspot-make-arch-sane-for-x86.patch \
patches/icedtea-jdk-sane-x86-arch.patch \
patches/icedtea-unbreak-float.patch \
+ patches/icedtea-oe-path.patch \
"
diff --git a/recipes/icedtea/icedtea6-native_1.8.bb b/recipes/icedtea/icedtea6-native_1.8.bb
index 67c26321ce..61cf6e673b 100644
--- a/recipes/icedtea/icedtea6-native_1.8.bb
+++ b/recipes/icedtea/icedtea6-native_1.8.bb
@@ -42,6 +42,7 @@ ICEDTEA_PATCHES = "\
file://icedtea-hotspot-make-arch-sane-for-x86.patch;apply=no \
file://icedtea-jdk-sane-x86-arch.patch;apply=no \
file://icedtea-unbreak-float.patch;apply=no \
+ file://icedtea-oe-path.patch;apply=no \
"
export DISTRIBUTION_PATCHES = "\
@@ -51,6 +52,7 @@ export DISTRIBUTION_PATCHES = "\
patches/icedtea-hotspot-make-arch-sane-for-x86.patch \
patches/icedtea-jdk-sane-x86-arch.patch \
patches/icedtea-unbreak-float.patch \
+ patches/icedtea-oe-path.patch \
"
EXTRA_OECONF += " --with-jaxws-drop-zip=${DL_DIR}/jdk6-jaxws-2009_10_27.zip \