summaryrefslogtreecommitdiffstats
path: root/recipes/ifplugd
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/ifplugd
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/ifplugd')
-rw-r--r--recipes/ifplugd/files/kernel-types.patch10
-rw-r--r--recipes/ifplugd/files/nobash.patch8
-rw-r--r--recipes/ifplugd/ifplugd_0.25.bb20
3 files changed, 38 insertions, 0 deletions
diff --git a/recipes/ifplugd/files/kernel-types.patch b/recipes/ifplugd/files/kernel-types.patch
new file mode 100644
index 0000000000..ad630ab5d4
--- /dev/null
+++ b/recipes/ifplugd/files/kernel-types.patch
@@ -0,0 +1,10 @@
+--- ifplugd-0.25/src/interface.c-orig 2007-04-18 14:57:33.106790279 +0200
++++ ifplugd-0.25/src/interface.c 2007-04-18 14:57:42.591211214 +0200
+@@ -18,6 +18,7 @@
+ * Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
+ */
+
++#define __KERNEL_STRICT_NAMES
+ #include <linux/sockios.h>
+ #include <linux/if_ether.h>
+ #include <sys/types.h>
diff --git a/recipes/ifplugd/files/nobash.patch b/recipes/ifplugd/files/nobash.patch
new file mode 100644
index 0000000000..8d0be50925
--- /dev/null
+++ b/recipes/ifplugd/files/nobash.patch
@@ -0,0 +1,8 @@
+--- ifplugd-0.28/conf/ifplugd.init.in.orig 2007-05-24 19:00:03.000000000 +0000
++++ ifplugd-0.28/conf/ifplugd.init.in 2007-05-24 19:00:09.000000000 +0000
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+ # $Id: ifplugd.init.in 86 2004-01-26 15:34:24Z lennart $
+
+ # This file is part of ifplugd.
diff --git a/recipes/ifplugd/ifplugd_0.25.bb b/recipes/ifplugd/ifplugd_0.25.bb
new file mode 100644
index 0000000000..ca7f219165
--- /dev/null
+++ b/recipes/ifplugd/ifplugd_0.25.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "ifplugd is a Linux daemon which will automatically configure your ethernet device \
+when a cable is plugged in and automatically unconfigure it if the cable is pulled."
+HOMEPAGE = "http://0pointer.de/lennart/projects/ifplugd/"
+SECTION = "network"
+DEPENDS = "libdaemon"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "http://0pointer.de/lennart/projects/ifplugd/ifplugd-${PV}.tar.gz \
+ file://kernel-types.patch;patch=1 \
+ file://nobash.patch;patch=1"
+
+inherit autotools update-rc.d pkgconfig
+
+EXTRA_OECONF = "--disable-lynx"
+
+INITSCRIPT_NAME = "ifplugd"
+INITSCRIPT_PARAMS = "defaults"
+
+CONFFILES_${PN} = "${sysconfdir}/ifplugd/ifplugd.conf"