aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ifupdown
diff options
context:
space:
mode:
authorMartyn Welch <martyn.welch@ge.com>2010-03-21 23:35:56 +0000
committerMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2010-03-30 14:10:22 +0200
commit7d7f2596ec0aea7684d2c05fa852f093b622b530 (patch)
tree33b9543ca39f0da7b30a8cd12162759d39bdbaca /recipes/ifupdown
parent02f7331e4ff167f29266cc8b630a5f20da6de004 (diff)
downloadopenembedded-7d7f2596ec0aea7684d2c05fa852f093b622b530.tar.gz
Add ubuntu verison of ifupdown
We need some of the features in the ubuntu version of ifupdown, rather than the version found in Debian. Signed-off-by: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl>
Diffstat (limited to 'recipes/ifupdown')
-rw-r--r--recipes/ifupdown/ifupdown-ubuntu-0.6.8/init15
-rw-r--r--recipes/ifupdown/ifupdown-ubuntu_0.6.8.bb45
2 files changed, 60 insertions, 0 deletions
diff --git a/recipes/ifupdown/ifupdown-ubuntu-0.6.8/init b/recipes/ifupdown/ifupdown-ubuntu-0.6.8/init
new file mode 100644
index 0000000000..fa415e57ed
--- /dev/null
+++ b/recipes/ifupdown/ifupdown-ubuntu-0.6.8/init
@@ -0,0 +1,15 @@
+#!/bin/sh -e
+
+case "$1" in
+ start|restart)
+ #create the network directory in the volatile /var directory
+ mkdir -p /var/run/network
+ if [ -e /var/run/network/ifstate ]; then
+ echo -n "Cleaning: /var/run/network/ifstate"
+ echo -n >/var/run/network/ifstate
+ echo "."
+ fi
+ ;;
+ stop|reload|force-reload)
+ ;;
+esac
diff --git a/recipes/ifupdown/ifupdown-ubuntu_0.6.8.bb b/recipes/ifupdown/ifupdown-ubuntu_0.6.8.bb
new file mode 100644
index 0000000000..3c8de81a10
--- /dev/null
+++ b/recipes/ifupdown/ifupdown-ubuntu_0.6.8.bb
@@ -0,0 +1,45 @@
+DESCRIPTION = "High level tools to configure network interfaces \
+This package provides the tools ifup and ifdown which may be used to \
+configure (or, respectively, deconfigure) network interfaces, based on \
+the file /etc/network/interfaces."
+LICENSE = "GPL"
+
+SECTION = "base"
+
+PROVIDES = "ifupdown"
+
+PR = "r2"
+
+inherit update-rc.d
+
+SRC_URI = "http://archive.ubuntu.com/ubuntu/pool/main/i/ifupdown/ifupdown_0.6.8ubuntu19.tar.gz;name=ifupdown \
+ file://init"
+
+SRC_URI[ifupdown.md5sum] = "9c4533a289bd55316a9981b1fe41fad4"
+SRC_URI[ifupdown.sha256sum] = "4c86cc0534061896c1f825766a29fe5282607123b8978b623f5c6f1fa5458b4d"
+
+EXTRA_OEMAKE = ""
+
+S = "${WORKDIR}/ifupdown-${PV}ubuntu15"
+
+do_compile () {
+ chmod a+rx *.pl *.sh
+ oe_runmake 'CC=${CC}' "CFLAGS=${CFLAGS} -Wall -W -D'IFUPDOWN_VERSION=\"${PV}\"'"
+}
+
+do_install () {
+ install -d ${D}${sysconfdir}/init.d \
+ ${D}${sysconfdir}/network \
+ ${D}${mandir}/man8 \
+ ${D}${mandir}/man5 \
+ ${D}${base_sbindir}
+ install -m 0755 ifup ${D}${base_sbindir}/
+ ln ${D}${base_sbindir}/ifup ${D}${base_sbindir}/ifdown
+ install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/ifup
+ install -m 0644 ifup.8 ${D}${mandir}/man8
+ install -m 0644 interfaces.5 ${D}${mandir}/man5
+ cd ${D}${mandir}/man8 && ln -s ifup.8 ifdown.8
+}
+INITSCRIPT_NAME = "ifup"
+INITSCRIPT_PARAMS = "start 39 S . stop 39 0 6 1 ."
+