aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/initrdscripts
diff options
context:
space:
mode:
authorCarsten Haitzler (Rasterman <raster@rasterman.com>2009-04-17 15:44:58 +1000
committerCarsten Haitzler (Rasterman) <raster@rasterman.com>2009-04-17 15:48:45 +1000
commit212e36417ae27e1be11147168b6f5cdfd1c5eda9 (patch)
tree00892cc3bca94534140f1e44ab98b4e58587410c /recipes/initrdscripts
parentd92391844e4454ba9ea3af5b4273721496511ebb (diff)
downloadopenembedded-212e36417ae27e1be11147168b6f5cdfd1c5eda9.tar.gz
angstrom, exquisite, psplash, opkg, angsrtom-images, sysvinit: abstract splash
this abstracts psplash to be generic. now as long as something provides a splashfuncs file that sysvinit (and other scripts) can source, and all the approproate init hooks to start the splash etc. you can use psplash, exquisitie, usplash or anything that tickles your fancy. this moves splash toa ${SPLASH} variable to include in your image (or override). the default in angstrom is psplash - unless you override it. opkg also runs a configure script that cna take forever - and so this speically sends off some splash commands (if there) to let you know the systme is alive and working (but just busy). this is one commit as if this breaks things you either want to fix the minor break or totally revert the whole patch. i hope it didn't break anything.
Diffstat (limited to 'recipes/initrdscripts')
-rw-r--r--recipes/initrdscripts/files/00-psplash.sh4
-rw-r--r--recipes/initrdscripts/files/99-psplash.sh4
-rw-r--r--recipes/initrdscripts/initramfs-module-psplash_1.0.bb2
3 files changed, 5 insertions, 5 deletions
diff --git a/recipes/initrdscripts/files/00-psplash.sh b/recipes/initrdscripts/files/00-psplash.sh
index db8aabedd7..bd1ed04452 100644
--- a/recipes/initrdscripts/files/00-psplash.sh
+++ b/recipes/initrdscripts/files/00-psplash.sh
@@ -1,6 +1,6 @@
if ! grep -Eq '\s?psplash=false\s?' /proc/cmdline; then
- mkdir -p /mnt/.psplash
- mount tmpfs -t tmpfs /mnt/.psplash -o,size=40k
+ mkdir -p /mnt/.splash
+ mount tmpfs -t tmpfs /mnt/.splash -o,size=40k
psplash &
fi
diff --git a/recipes/initrdscripts/files/99-psplash.sh b/recipes/initrdscripts/files/99-psplash.sh
index 3d5f1d60d1..ae8495c39b 100644
--- a/recipes/initrdscripts/files/99-psplash.sh
+++ b/recipes/initrdscripts/files/99-psplash.sh
@@ -1,4 +1,4 @@
if ! grep -Eq '\s?psplash=false\s?' /proc/cmdline; then
- mkdir -p /mnt/mnt/.psplash
- mount -n -o move /mnt/.psplash /mnt/mnt/.psplash
+ mkdir -p /mnt/mnt/.s0plash
+ mount -n -o move /mnt/.splash /mnt/mnt/.splash
fi
diff --git a/recipes/initrdscripts/initramfs-module-psplash_1.0.bb b/recipes/initrdscripts/initramfs-module-psplash_1.0.bb
index 44781fb6bf..8d61257220 100644
--- a/recipes/initrdscripts/initramfs-module-psplash_1.0.bb
+++ b/recipes/initrdscripts/initramfs-module-psplash_1.0.bb
@@ -1,5 +1,5 @@
SRC_URI = "file://00-psplash.sh file://99-psplash.sh"
-PR = "r3"
+PR = "r4"
RDEPENDS = "initramfs-uniboot virtual/psplash"
DESCRIPTION = "An initramfs module to enable psplash."