aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/inkspill
diff options
context:
space:
mode:
authorJustus Winter <4winter@informatik.uni-hamburg.de>2010-10-07 12:31:46 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2010-10-12 20:34:44 +0200
commit13c14c750c64b56f9d650e02ae283b1479a8f04e (patch)
tree4945b3f0fd55de342cc43909f3f4d74f04039448 /recipes/inkspill
parent219b605104ae12a24dc0a2551390437db154f1ac (diff)
downloadopenembedded-13c14c750c64b56f9d650e02ae283b1479a8f04e.tar.gz
inkspill: add recipe for nice little game written by Al Sweigart.
* I merely optimized the animations until it ran smoothly on my openmoko, tweaked the user interface for the mokos screen and packaged it. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/inkspill')
-rw-r--r--recipes/inkspill/inkspill_0.1.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/recipes/inkspill/inkspill_0.1.bb b/recipes/inkspill/inkspill_0.1.bb
new file mode 100644
index 0000000000..3f72e83064
--- /dev/null
+++ b/recipes/inkspill/inkspill_0.1.bb
@@ -0,0 +1,12 @@
+DESCRIPTION = "Ink Spill is a Flood It Clone by Al Sweigart"
+HOMEPAGE = "http://inventwithpython.com/blog/2010/09/09/code-comments-tutorial-ink-spill-a-flood-it-clone/"
+LICENSE = "Creative Commons BY-NC-SA 3.0 US"
+DEPENDS = "python-pygame"
+RDEPENDS_${PN} = "python-pygame"
+SRC_URI = "hg://www.jade-hamburg.de/~teythoon/repos;module=${PN};rev=${SRCREV};proto=https"
+SRCREV = "d7185f0b3f28"
+S = "${WORKDIR}/inkspill"
+
+inherit distutils
+
+FILES_${PN} += " ${datadir}/applications/* ${datadir}/pixmaps/*"