summaryrefslogtreecommitdiffstats
path: root/recipes/ipaq-sleep
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/ipaq-sleep
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/ipaq-sleep')
-rw-r--r--recipes/ipaq-sleep/files/init-script-busybox.patch11
-rw-r--r--recipes/ipaq-sleep/files/install-fix.patch11
-rw-r--r--recipes/ipaq-sleep/files/unbreak.patch11
-rw-r--r--recipes/ipaq-sleep/ipaq-sleep_0.9.bb14
4 files changed, 47 insertions, 0 deletions
diff --git a/recipes/ipaq-sleep/files/init-script-busybox.patch b/recipes/ipaq-sleep/files/init-script-busybox.patch
new file mode 100644
index 0000000000..9a8685de68
--- /dev/null
+++ b/recipes/ipaq-sleep/files/init-script-busybox.patch
@@ -0,0 +1,11 @@
+--- ipaq-sleep-0.9/ipaq-sleep.init.orig 2006-06-05 12:11:38.889777832 +0200
++++ ipaq-sleep-0.9/ipaq-sleep.init 2006-06-05 12:11:53.059623688 +0200
+@@ -9,7 +9,7 @@
+ ;;
+ stop)
+ echo -n "Stopping sleep daemon: ipaq-sleep"
+- /sbin/start-stop-daemon --stop --quiet --oknodo --exec /usr/bin/ipaq-sleep
++ /sbin/start-stop-daemon --stop --quiet --exec /usr/bin/ipaq-sleep
+ echo "."
+ ;;
+ *)
diff --git a/recipes/ipaq-sleep/files/install-fix.patch b/recipes/ipaq-sleep/files/install-fix.patch
new file mode 100644
index 0000000000..59eb17b071
--- /dev/null
+++ b/recipes/ipaq-sleep/files/install-fix.patch
@@ -0,0 +1,11 @@
+--- /tmp/Makefile 2006-08-12 12:16:47.000000000 +0200
++++ ipaq-sleep-0.9/Makefile 2006-08-12 12:22:42.188306000 +0200
+@@ -24,7 +24,7 @@
+ $(CC) -o $(PACKAGE) $(PACKAGE).o $(LDFLAGS) $(PACKAGE_LDFLAGS)
+
+ install-program: all
+- install -Ds $(PACKAGE) $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)
++ install -D -s $(PACKAGE) $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)
+ mkdir -p $(DESTDIR)/etc/init.d
+ install $(PACKAGE).init $(DESTDIR)/etc/init.d/$(PACKAGE)
+ install $(PACKAGE).conf $(DESTDIR)/etc/$(PACKAGE).conf
diff --git a/recipes/ipaq-sleep/files/unbreak.patch b/recipes/ipaq-sleep/files/unbreak.patch
new file mode 100644
index 0000000000..5116e9957f
--- /dev/null
+++ b/recipes/ipaq-sleep/files/unbreak.patch
@@ -0,0 +1,11 @@
+--- a/ipaq-sleep.c.org 2006-01-20 19:43:14.000000000 +0200
++++ a/ipaq-sleep.c 2007-12-26 06:26:32.000000000 +0200
+@@ -108,7 +111,7 @@
+ if (fgets (buf, 32, input))
+ {
+ if (!strncmp (buf, "on ", 3))
+- r = atoi (buf + 4);
++ r = atoi (buf + 3);
+ else
+ r = -1;
+ }
diff --git a/recipes/ipaq-sleep/ipaq-sleep_0.9.bb b/recipes/ipaq-sleep/ipaq-sleep_0.9.bb
new file mode 100644
index 0000000000..24d881dd05
--- /dev/null
+++ b/recipes/ipaq-sleep/ipaq-sleep_0.9.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Automatic sleep/suspend control daemon"
+SECTION = "x11/base"
+LICENSE = "GPL"
+DEPENDS = "apmd virtual/xserver libxext virtual/libx11 libxau xscrnsaverh libxss"
+RDEPENDS = "apm"
+PR = "r6"
+
+inherit gpe pkgconfig
+
+SRC_URI_append = " file://init-script-busybox.patch;patch=1"
+SRC_URI_append = " file://install-fix.patch;patch=1"
+SRC_URI_append = " file://unbreak.patch;patch=1"
+
+CONFFILES_${PN} += "${sysconfdir}/ipaq-sleep.conf"